Windows 8 and 8.1 Forums

BSODs, HD undetected on reboot, storahci error 129?

  1. #1

    Posts : 1
    Windows 8.1 (OEM)

    BSODs, HD undetected on reboot, storahci error 129?

    Hi, I'm a first time computer builder working on a system that's almost 2 weeks old. Here's the recurring pattern that started the first night after I'd installed Windows that morning:
    1. Apps and the OS hang for 10-30 seconds.
    2. The system may either recover or bluescreen and restart.
    3. If it restarts, it prompts to insert boot media (does not detect hard drive).
    4. After powering down completely and turning back on, it boots with no problem, but no "you just crashed" message or logs are present.
    5. I have seen storahci warning 129, "Reset to device, \Device\RaidPort0, was issued.", in the vicinity of most of the incidents in the Event Viewer.
    An "incident" happens every 1/2-3 days, although there was a period where it was only brief hangs, not BSODs.

    Before I get into details, a disclosure and apology: Due to a combination of 1) relative infrequency/unreplicability of the problem 2) premature diagnoses 3) busy-ness 4) denial, I haven't been as proactive as I should be on this problem and am now running into Micro Center's 15 day return window on my motherboard (and processor), which I will almost certainly make use of out of an abundance of caution. Only an incredibly confident rapid diagnosis would convince me this is solved since I don't have a week to wait and see how stable things are. So, I don't want to waste your time and there may be a delay in my responses when I have to reassemble the system with the replacement parts, but I still would love to hear your thoughts a) in case the problem continues after those replacements b) for my own edification. Appreciate your understanding, and I'm sorry for the non-ideal context for this request.

    Okay, let's get into it.

    The hanging: As I said the system always hangs before it BSODs, and sometimes it recovers. The cursor is movable with the "busy circle" during this time, I can get to the taskbar context menu, and the temperatures in the system tray continue to update. But the active application stops moving, and anything else I try to switch to also doesn't respond (for instance the task manager didn't open until after the hang ended). If it recovers, it all comes back at once.

    The reboot failure: As I said the motherboard appears to completely lose the hard drive after the BSODs. I've opened up the UEFI BIOS and the HD was not in the boot order options. (Unfortunately I don't think I ever checked to see what was listed for that SATA port in the SATA Configuration "advanced" section.) After manual power off-and-on, it's back no problem; I can boot directly or go to BIOS and see that the HD has returned.

    Lack of crash info: The BSOD auto-restarts faster than I can read the details. I only recently found out you can disable that, and did so. The system gives no "you have recovered from a serious error, send a report" prompt like I remember. It also has no memory.dmp file or minidump(s) folder in C:\Windows. I had never changed it from the default "automatic memory dump", and have now set it to "Small memory dump", but I haven't yet had my next crash after those 2 tweaks. (My virtual memory size is the default of 1280 MB, and I have 8 GB ram, if that's relevant.)

    Event viewer: Lacking logs I looked at event viewer for clues. You can look at my day-by-day journal below for every little thing I once thought worth noting, but long story short the only recurring suspect event has been a "storahci" warning #129, reading "Reset to device, \Device\RaidPort0, was issued." This seems to be there every time the system hangs and recovers, and is also present before most of the actual BSODs.

    When does it happen: Generally the system has always been at at least a moderate level of activity when it hangs. Twice I had World of Warcraft open, and the rest of the times I was using Chrome, often loading a page or multiple tabs. Right before the very first BSOD, WoW actually crashed with an error message saying something about "couldn't write local", but before I could really read it I got the big blue smiley frown. I've seen "waiting for cache" for a suspiciously long time in Chrome on a couple instances, but not all. At one point I hit "stop" in Chrome during a long "waiting for cache" and didn't get a hang; checking the event log there was indeed a 129 event.

    So my amateur best understanding was that something was happenening to make either the hard drive seize up, or the motherboard stop talking to the hard drive. This also seemed to explain why it couldn't write logs. The "reset to device" notices were the only thing I really had to go on so I kinda latched onto that angle, perhaps unjustifiably. Last week I googled that and several people reported issues surrounding that event, although I think most/all were hangs without the crash.

    I followed these suggestions:
    * Turn off PCI-E Link State Power Management and
    * turn off Hard Disk Sleep, in Advanced Power Management.
    * Reseating, then swapping drive data and power cables.
    I also saw but did not want to blindly try:
    * Install new Intel Rapid Storage Technology (RST) drivers.
    * Enable "hot swap" of drives in BIOS. It's my understanding this is unsurprisingly not an option on boot drives.
    * Install Hyper-V.
    * Run "bcdedit /set disabledynamictick".

    I also verified that the Device Manager could find no updates for HDD drivers. Just today I ran chkdsk-via-drive-properties and got essentially "it's all good"; 0 bad file records, index verified, Usn Journal verified, no problems, no action required. I also ran the SF diag tool today though of course there were no logs for it to grab (results attached).

    System miscellany: First build-your-own PC, parts selected partly due to deals available. World of Warcraft, Chrome, AVG basically the only things installed (since shortly after WoW the crash hit and I didn't want to commit a lot of setup time to a questionable system). GeForce 660 drivers seem to've been correctly retrieved by Windows Update. Early on I had a USB external HD plugged in but that seems to have no connection to the issue. The whole thing seems to work great except for this. I've played a healthy (well...) amount of WoW and done plenty of multi-tab web surfing with only the few incidents.

    Summary of events:
    7/2 am - Built.
    7/2 pm - BSOD. World of Warcraft crashed just prior. Event 129 noted in EV.
    7/4 am - BSOD. Chrome was opening 5 tabs rapidly. No event 129 before crash.
    7/4 am - Reseated connections, switched cables to new PSU outlet and new mobo SATA port.
    7/4 am - Hang & recover. Chrome was restoring tabs after reboot. Event 129 noted twice.
    7/4 am - Disabled PCIE Link State Power Management and Hard Disk Sleep options.
    7/5 am - Event 129 noted in log after the fact; I believe Chrome was opening multiple tabs.
    7/5 pm - Hang & recover. Chrome in use. Event 129 noted.
    7/7 am - Hang & recover. Chrome being restarted to disable an extension. Event 129 noted.
    7/7 pm - Event 129. Not much, if any, noticeable Chrome lag this time.
    7/8 pm - Hang & recover. Two Chrome windows being opened. Event 129 noted.
    7/9 pm - BSOD. Had 2 multi-tab Chrome windows open, activating omnibar search mode. No event 129 in EV.
    7/9 pm - Swapped SATA data connectors. Used alternate SATA power cable.
    7/11 pm - BSOD. Away from computer with WoW and Chrome running. No event 129 logged.

    Extra details:
    7/2 - Some of the event log timing was funny. There were a couple "your last shutdown was not proper" events but it listed a shutdown time well before the actual crash. I also had events (apparently pertaining to windows startup after reboot) from "the future" the next morning. Perhaps it somehow reset to GMT time when it crashed?

    Probably unrelated: I saw "The driver \Driver\WudfRd failed to load for the device SWD\WPDBUSENUM\{832f56e7-023b-11e4-8254-40167e25a2da}#0000000000007E00" at several points, including once before the crash. I think this has something to do with the external HD I had plugged in? (Which worked completely fine during a very long data copy.) In any case the crashes continued even after it was unplugged.

    World of Warcraft "Errors" folder had nothing in it despite displaying a lengthy error message. Its last log file entries were something about "Preparing to create GBuffer" and "GBuffer is supported!" which a) don't sound problematic and b) WoW wasn't even open for half the bluescreens and all the hangs.

    7/4 - List of items from Custom Views\Administrative Events:
    Error - 11:32:20 - Eventlog - 1101 - Event processing - Audit events have been dropped by the transport. 0
    [Crash happened at least 10-20 minutes after this.]
    Error - 12:00:24 - EventLog - 6008 - None - The previous system shutdown at 11:32:20 PM was unexpected.
    Critical - 12:00:08 - Kernel-Power - 41 - (63) - The system has rebooted without cleanly...
    Error - 12:00:26 - Eventlog - 1101 - Event processing - Audit events have been dropped by the transport. 0
    Warning - 12:01:00 - DeviceSetupManager - 122 - None - Access to drivers on Windows Update was blocked by policy
    [The following may have been when I restored Chrome tabs.]
    Warning - 12:04:04 - storahci - 129 - None - Reset to device, \Device\RaidPort0, was issued.
    Warning - 12:04:35 - storahci - 129 - None - Reset to device, \Device\RaidPort0, was issued.

    Also noticed possibly ironic events like this:
    Information - Ntfs (Microsoft-Windows-Ntfs) - 98 - None - Volume C: (\Device\HarddiskVolume4) is healthy. No action is needed.

    7/5 am - I didn't notice the 129 until later; I estimated that it may have occurred when I was opening a number of tabs. With it I noticed another warning, id 153 "The IO operation at logical block address 0x6b9758 for Disk 0 (PDO name: \Device\0000002f) was retried." The last bytes in the details were 00 04 2A which correspond to SCSISTAT_GOOD, SCSIOP_WRITE, and SRB_STATUS_ERROR, based on this guide: Interpreting Event 153 Errors - Ntdebugging Blog - Site Home - MSDN Blogs However I haven't seen this one again.

    7/9 pm - The semi-modular PSU came with several power cables; I initially had both DVD and HD on the same long cable but gave the HD a different short one at this time. The motherboard came with 2 SATA data connectors; I simply swapped the HD and DVD ones here. Frankly the only time I ever plan to use the DVD is for Windows installation.

    That's all I got. Like I said the motherboard is losing the benefit of the doubt here due to its shorter return policy, but really I'm pretty clueless. Everything recovers so crisply, it's hard to believe there's some unfixable hardware failure. Gr. Thanks for your help!

      My System SpecsSystem Spec

  2. #2

    Posts : 5,139
    Win8.1Pro - Finally!!!

    Sorry for the delay in responding. There just aren't that many people who do BSOD analysis, so at times we get a bit overwhelmed!

    Do your still need help with this problem?
    I will be notified if you reply to this topic and will respond within 48 hours.
      My System SpecsSystem Spec

  3. #3

    Posts : 1
    Windows 8.1

    Hey Jerodast,

    did you ever find a solution?

    i literally have the exact same problem.
      My System SpecsSystem Spec

BSODs, HD undetected on reboot, storahci error 129?
Related Threads
Solved BSODs, lot of different error codes in BSOD Crashes and Debugging
Almost every time I use Windows I will get a BSOD at some point, with different error codes. Often while playing LoL (since that is the main thing I use Windows for), but also during other things. I also have Ubuntu installed on the same PC, which I use at least as often as Windows. I have never...
Dear everyone, I've been receiving some strange BSODS as of late, and they've been driving me nuts.. I have no idea what to do about them, and they seem to be occurring when I either have a Facebook tab open in my Google Chrome, or when I'm browsing my Facebook timeline. Here's some PC stats...
Hi, I'm hoping someone can help. For a while now I've been getting BSODs, sometimes while playing games, sometime when watching Youtube, sometimes when using other programs. I'm suspicious of a driver issue, but when I tried using verifier.exe and rebooting I get another BSOD -...
Hi there, Stated in the title, I've been receiving BSODs with the following: Irql_not_less_or_equal. After reading in various forums, it seems to be a common issue. I personally refreshed and did a complete new installation to no avail and hoping for some guidance here. I attached the SF...
Hi there, I have Windows 8 x64 Pro installed on my new machine, and have been getting frequent BSODs with varying error messages. I suspect it may be some driver issue but I could be wrong. It occurs quite randomly, but seems more frequent when I am transferring large quantities of data. I...
Solved BSOD storahci.sys in BSOD Crashes and Debugging
Hi there, Recently since I have installed windows 8 I have been getting a lot of BSOD's, they happen when I shut down my computer, install windows updates or try to start a program like CPU-Z. I've been searching on google and on these forums but I haven't found a solution yet. Hopefully...
help random reboot minidump error!! in BSOD Crashes and Debugging
please help..
Eight Forums Android App Eight Forums IOS App Follow us on Facebook