Windows 8 and 8.1 Forums

BSOD - Kernel Data Inpage Error - new SSD, no dump

  1. #1

    Posts : 3
    Windows 8.1 Pro x64

    BSOD - Kernel Data Inpage Error - new SSD, no dump


    So for the past 8 days I've been getting BSOD's (Kernel Data Inpage Error) randomly about once a day, without any dumps or logs being created, despite the settings being right and WERS service running.

    Attachment 46733

    I'm new here, and I know there are several other similar posts here, but let me tell you my story:
    Two weeks ago my 2 year old SSD (Corsair Force GT) died. Bios would freeze at around 70% when trying to boot off it, other computers wouldn't recognize it, it was basically bricked (i suspect the controller, since I only had it for 2 years, and only used for OS). So I sent it back, and they ended up giving me a different model (Corsair Force GS).

    I performed a fresh install of Windows 8.1 Pro x64 on the new SSD, and ever since then I've been having the BSOD's. At first I suspected a driver problem, but Windows says all drivers are up to date and there's another weird thing happening: after the BSOD, when restarts and tries to boot up again, the BIOS freezes at around 70% again (around the time when it communicates with the default boot device), and I have to manually shut it down (from the power button), and turn it back on again(this time it works fine, and writes the 'Event 41, Kernel Power' event to logs).

    I suspect it's the SSD again, but I can't explain it. It's been driving me crazy for the past week, especially since I also use this laptop (Acer Aspire 5737z) for work.

    Please help with this issue!

    Thanks in advance!

    Attachment 46735Attachment 46736

      My System SpecsSystem Spec

  2. #2

    Posts : 5,139
    Win8.1Pro - Finally!!!

    In most cases I find that it's unnecessary to troubleshoot the cause of a dump file not being generated.
    Usually the BSOD fix involves something in the storage sub-system (a deliberately vague term), and when it's fixed the dump files are usually being generated appropriately. More info on memory dump generation here: BSOD Crash Dump Generation

    In this case, the dump file only reaches 70% and then freezes - so the dump is never complete.
    And, then note that the MSINFO32 report shows 384 mB for page file space. I would suggest that you set your pagefile to "System-Managed" size.

    On to the analysis.....

    Only 45 Windows Updates installed. Most systems have 60 to 80 or more. Please visit Windows Update and get ALL available updates (it may take several trips to get them all).

    Don't worry about the specific number, it's just important that you have checked and installed any updates that were available.

    Your BIOS dates from 2009. Please check at the manufacturer's website to see if there are any BIOS updates available for your system. Also check the readme file to see if they apply to the problems that you are having. Please be advised that flashing the BIOS is a very unforgiving process - and one mistake can physically damage your motherboard.

    These devices have problems in Device Manager:
    Coprocessor PCI\VEN_10DE&DEV_0AA3&SUBSYS_01601025&REV_B1\3&2411E6FE&0&1D The drivers for this device are not installed.
    NVIDIA High Definition Audio HDAUDIO\FUNC_01&VEN_10DE&DEV_0007&SUBSYS_10DE0101&REV_1001\4&36A2733B&0&0301 This device is disabled.
    The Coprocessor driver is a part of the chipset drivers for your system. If unable to find the chipset info (I couldn't find it easily), run CPU-Z (free here: CPU-Z CPUID - System & hardware benchmark, monitoring, reporting ) and post the info from the Mainboard tab. You're looking for the Windows 8.1 chipset drivers for your system - these are critical!!!

    The NVIDIA High Definition Audio is disabled. Is this deliberate? If so, why?

    Daemon Tools (and Alcohol % software) are known to cause BSOD's on some Windows systems (mostly due to the sptd.sys driver, although I have seen dtsoftbus01.sys blamed on several occasions).
    Please un-install the program, then use the following free tool to ensure that the troublesome sptd.sys driver is removed from your system (pick the 32 or 64 bit system depending on your system's configuration): New link (15 Aug 2012): DuplexSecure - Downloads (pick the appropriate version for your system and select "Un-install" when you run it).
    Alternate link:
    Manual procedure here: Registry and SPTD problems | DAEMON Pro Help
    DrvAgent64 DrvAgent64 Kernel 14/12/2009 12:23:26 PM
    This driver dates from 2009 - please uninstall the program associated with this driver.

    Look through the driver list in the uploaded reports, and start updating all drivers that date from before the release of Windows 8.1 (17 Oct 2013) - check to see that each and every one is compatible w/Windows 8.1 (at the manufacturer's website). If not, you must either remove the device and it's software - or locate a Windows 8.1 compatible update on the web. Removing some drivers may make the system unstable - so if you're unable to find updates, post back for info on the one's that can/cannot be safely removed.

    If all of this doesn't stop the BSOD's, please run Driver Verifier according to these instructions: Driver Verifier Settings
    Be sure to note the information on the Blue Screen (don't let the system automatically restart) in case this doesn't generate memory dumps.

    Updating all of the drivers in a a system this old is a formidable task when one doesn't have dump files. You may wish to consider reverting back to Win7 or even WinVista with this system in order to achieve reliability.

    Good luck!
      My System SpecsSystem Spec

  3. #3

    Posts : 3
    Windows 8.1 Pro x64

    Thanks for the quick response!

    Ok, status update: today for the first time the BSOD didn't say 'Kernel Data Inpage Error', but it said 'Critical process died'. As far as I could tell nothing was different from when the other blue screens occurred.

    In this case, the dump file only reaches 70% and then freezes
    I didn't mean the dump file reaches 70%, but the BIOS loading. The dump always stays at 0%.
    Attachment 46786
    And this is what I meant:
    Attachment 46787

    I would suggest that you set your pagefile to "System-Managed" size.
    It was like that, but I started making changes hoping it might actually create a dump. I've set it back to "System-Managed".

    The NVIDIA High Definition Audio is disabled. Is this deliberate? If so, why?
    The same: read some where someone had a similar issue(however he had ATI not NVIDIA) and was trying different things hoping for results. It was enabled at first, and I've enabled it again now.

    Please visit Windows Update and get ALL available updates (it may take several trips to get them all).
    Since the last BSOD I was only missing 3 optional updates (besides Silverlight, Bing Bar and Bing Desktop), other than that I checked several times and it said there are no more updates to install. I've also installed the missing 3 (one of them was for NVIDIA GeForce 9400M G, and the other two were KB296409 and KB2967917). Hopefully these might make a difference.

    Daemon Tools (and Alcohol % software) are known to cause BSOD's on some Windows systems
    In my case the BSOD's started happening even before Daemon Tools was installed, so I don't think that will make much difference, but I'll give it a shot.

    Your BIOS dates from 2009. Please check at the manufacturer's website to see if there are any BIOS updates
    Unfortunately I appear to have the latest for my Acer Aspire 5737z. I've checked Acer's website and nothing was released (bios or drivers) for this model since 2009.
    With regards to this and the other driver issues you mentioned: I don't know how relevant this is, since there is a new piece of hardware installed (the SSD), but with my old SSD I never had any sort of problems related to drivers, even though they were old. They were basically the same drivers i'm using now, I didn't have to manually update anything. I've used Windows 8 and 8.1 pretty much ever since they were first released, and I used the exact same iso to install Windows on this SSD.
    Also, the Coprocessor driver was never installed (I could never find it) since I started running Windows 8 or 8.1, and still there were no problems.
    This is the info from the Mainboard tab when running CPU-Z:
    Attachment 46791

    You may wish to consider reverting back to Win7 or even WinVista with this system in order to achieve reliability.
    I would really like to save that as a last (very last) resort. I've grown too fond of Windows 8.1 .

    Ok, so I'll work on the rest of your sugestions. Hopefully one of them will fix this issue.
    I'll post again soon with a status update.

    Thank you!
      My System SpecsSystem Spec

  4. #4

    Posts : 3
    Windows 8.1 Pro x64

    Status update (earlier than i expected):

    I changed some things: uninstalled daemon tools, uninstalled logitech mouse software(i also have microsoft mouse software), and a few other small things (plus the 3 updates mentioned in the previous post). I didn't update any drivers though, because i hadn't yet found any updates.

    But the news is this: when tried to restart i got a different BSOD that said 'Driver Power State Failure' and this time it actually created a minidump. Here it is:
    Attachment 46813

    Hopefully this means that i'm done with the other issues, and didn't just create a new one .
      My System SpecsSystem Spec

  5. #5

    Posts : 5,139
    Win8.1Pro - Finally!!!

    A Windows system is a dynamic system - things change as the system goes about it's business.
    So, if you didn't have a problem previously, that's no guarantee that there won't be one in the future.

    For example, if you're using an incompatible program that still works on Windows 8.1 - that's fine.
    Until Windows updates - and that may break that incompatible program. It may be OK for many updates, but it only takes one update to break it.

    Also, BSOD's aren't necessarily just between a particular program and Windows. Programs can conflict with each other and cause BSOD's on their own.

    In this case you've changed enough of the potential problems that Windows was able to generate and capture a memory dump.
    Let's see what that tells us......

    This memory dump seems to be involved with a power transition (sleep/hibernate/shutdown/powerup/etc)
    As such we have to wonder about the BIOS. It's possible that this system isn't compatible w/Win8.1 - and you may have to downgrade (to Win8 or even Win7) in order to achieve stability. In addition to the worries about the BIOS' compatibility with Win8.1, I also have to wonder about the BIOS' compatibility with the SSD. There were numerous BSOD problems with older systems when SSD's first came out - and the problems didn't stop happening until 2012/2013. Well after the date of your BIOS.

    But first, let's look at the DrvAgent64.sys driver - it's still on the system (and it dates from 2009). Have you removed the software that uses it?

    These are the latest drivers for your chipset: NVIDIA DRIVERS nForce Driver Version 15.56 WHQL
    They are for Win7 - so the chipset is not compatible w/Win8.1
    Still, you can try installing these drivers in compatibility mode for Win7 and see if that fixes the Coprocessor error.

    Please uninstall Acronis for now (one of it's drivers is from 2011). Feel free to reinstall it once the system is stabilized.

    Good luck!

    The following is for informational purposes only.
    **************************Fri Jul 11 14:02:20.121 2014 (UTC - 4:00)**************************
    Loading Dump File [C:\Users\John\SysnativeBSODApps\071114-11062-01.dmp]
    Windows 8 Kernel Version 9600 MP (2 procs) Free x64
    Built by: 9600.17085.amd64fre.winblue_gdr.140330-1035
    System Uptime:0 days 3:50:34.224
    Probably caused by :ntkrnlmp.exe ( nt!PnpBugcheckPowerTimeout+6a )
    BugCheck 9F, {4, 12c, ffffe001896e4880, fffff801417eea50}
    Arg1: 0000000000000004, The power transition timed out waiting to synchronize with the Pnp
    Arg2: 000000000000012c, Timeout in seconds.
    Arg3: ffffe001896e4880, The thread currently holding on to the Pnp lock.
    Arg4: fffff801417eea50, nt!TRIAGE_9F_PNP on Win7 and higher
    PROCESS_NAME:  System
    FAILURE_BUCKET_ID: 0x9F_4_nt!PnpBugcheckPowerTimeout
      BIOS Version                  V1.10
      BIOS Release Date             06/22/2009
      Manufacturer                  Acer            
      Product Name                  Aspire 5737Z    
    3rd Party Drivers:
    The following is for information purposes only.
    Any drivers in red should be updated or removed from your system. And should have been discussed in the body of my post.
    **************************Fri Jul 11 14:02:20.121 2014 (UTC - 4:00)**************************
    DrvAgent64.SYS         Mon Dec 14 05:23:26 2009 (4B26121E)
    afcdp.sys              Wed Jul 20 10:46:03 2011 (4E26EA2B)
    tib.sys                Wed Mar 20 05:00:38 2013 (51497AB6)
    b57nd60a.sys           Mon Mar 25 20:14:03 2013 (5150E84B)
    fltsrv.sys             Mon May 13 05:40:09 2013 (5190B4F9)
    nvhda64v.sys           Sun Jun 16 08:38:07 2013 (51BDB1AF)
    netr28x.sys            Thu Jul 11 05:27:41 2013 (51DE7A8D)
    snapman.sys            Wed Aug 14 08:17:26 2013 (520B7556)
    intelppm.sys           Thu Aug 22 04:46:35 2013 (5215CFEB)
    dump_storahci.sys      Thu Aug 22 07:40:39 2013 (5215F8B7)
    tap0901.sys            Thu Aug 22 08:40:01 2013 (521606A1)
    nvlddmkm.sys           Thu Aug 29 17:39:12 2013 (521FBF80)
    tib_mounter.sys        Mon Sep 30 09:04:20 2013 (524976D4)
    kerneld.x64            Sun Nov 17 11:10:46 2013 (5288EA86)
    point64.sys            Thu Dec 12 08:16:17 2013 (52A9B721)
    dc3d.sys               Thu Dec 12 08:16:35 2013 (52A9B733)
      My System SpecsSystem Spec

BSOD - Kernel Data Inpage Error - new SSD, no dump
Related Threads
I have a Asus G50VT laptop. The same disk image resumes from hibernate fine on a X25-M G2 SSD but on a Crucial M500 with MU05 (latest) firmware, on resuming it says 'kernel data inpage error' and sometimes (spaceport.sys) after that. It BSODs right when the blue windows logo with animation start to...
BSOD kernel data inpage error in BSOD Crashes and Debugging
Hello guys, im new to this forum. I keep getting blue screen all the time, its so frustrating, ive reinstalled for 2nc time now and this error doesnt go away. I dont know what to do, i dont know if it is a hardware problem or a software problem, ive run RAM and HDD tests and passed both. And...
BSOD Inpage Kernel Data Error - New HP laptop in BSOD Crashes and Debugging
Hi, English is not my native language, so bare with me. :) My laptop has 4 months old. Envy dv6 1TB, i7, 12 Gb Ram. I was doing normal work, and i left my laptop downloading a torrent. Laptop not connected to power, so only running on the battery on High Performance Profile. I had lunch ,...
BSOD - Kernel data inpage error in BSOD Crashes and Debugging
Hi all, I have started having BSODs since last week. They seemingly seem to occur at random after using my computer around an hour. My computer is 2 years old, and I have never had problems with it, nor have I made any changes in the last weeks. I have run chkdsk on both my drives, and...
BSOD Kernel Data Inpage Error (bowser) in BSOD Crashes and Debugging
Okay so I've been working on my mothers laptop and she has a HP Pavilion G6-1C51NR. She told me her laptop was a bit slow, so I decide to upgrade her to Win 8.1 from Win 7. I did a fresh install of Win 8 then updated to Win 8.1, now here is the weird part. Every time I boot the Laptop I get the...
Hi, I've install Windows 8 on my computer some days ago, and sometimes (50%) when waking up from sleep, windows do a BSOD Kernel data Inpage Error. I've read that it could be a MBR issue, but i've done chkdsk /f /r without result. So I assume it's a driver issue. Can you help me find the bad one...
Solved BSOD Kernel Data Inpage Error in BSOD Crashes and Debugging
Hello, I have a Gateway GT5408, purchased in 2007 that came with Vista. Last week my system failed to boot and I kept getting the black repair screen on an endless loop. So I replaced what I thought was a faulty hard drive and installed Windows 8. I’m now getting a BSOD that reads Kernel Data...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook