Windows 8 and 8.1 Forums


  1. #1

    Posts : 6
    Windows 8.1

    Windows 8.1 BSOD: KMODE_EXCEPTION_NOT_HANDLED, hard locks

    Hello everyone.

    I'm at my wit's end here with a computer I assembled around Christmas time last year that has had a large amount of BSODs, crashes, freezes, reboots without BSODs and the like. Though I have apparently managed to fend off a lot of the issues (including IRQL_NOT_LESS_OR_EQUAL, and CLOCK_WATCHDOG_VIOLATION), this particular KMODE_EXCEPTION_NOT_HANDLED bsod persists.

    I've attached the SF Diagnostic Tool dump as instructed.

    I took many steps to fix these crashes before I came to the forum, listed below:
    • Uninstalled Daemon Tools and its driver.
    • Disabled the Nvidia Streaming Service which was apparently known to cause BSODs.
    • Uninstalled ASUS GPU-Tweak and its driver, also known to cause BSODs (same driver as SmartDoctor)
    • Uninstalled my ASUS GX950's mouse driver and reinstalled the latest driver stated to support windows 8.
    • Ran driver verifier which caught the Nvidia Streaming Service above, also Virtual Audio Cable's driver (now removed)
    • Ran sfc /scannow in elevated command prompt without issue.
    • Ran dism /online /cleanup-image /restorehealth which apparently caught something, restarted.
    • Ran memtest86 for 5 passes on both RAM sticks, no errors.
    • Ran CHKDSK both from the hdd's properties menu and via elevated command prompt + restart. No errors.

    Some additional info:

    • Hard locks/reboots without bsods occur most frequently when using a web browser. Current browser is Google Chrome, tested with both Firefox and IE with the same results. Of course this makes it hard to check/post here.
    • I very, very rarely have the computer freeze or hard lock while playing a game. I have not had a bsod occur in the middle of a game in recent memory.
    • KMODE_EXCEPTION_NOT_HANDLED bsod occurs whenever it pleases apparently, though again less likely if I do not have a web browser open. I have witnessed it occur while the system was simply sitting on desktop with no applications open.
    • The forced reboots without bsods are only a recent occurrence, KMODE_EXCEPTION_NOT_HANDLED has been happening for far longer, although less frequently. IRQL_NOT_LESS_OR_EQUAL and CLOCK_WATCHDOG_TIMEOUT have not been seen since I removed daemon tool, virtual audio cable, gpu-tweak and disabled nvidia streamer service.
    • My graphics card's drivers are up to date as well as the nvidia geforce experience program.
    Last edited by Azba; 04 Jun 2014 at 00:35. Reason: more details

      My System SpecsSystem Spec

  2. #2

    Posts : 660
    windows 8.1

    It is known that many network devices with windows 8driver have problems with windows 8.1
    Your Realtek PCIe GBE Family Controller has drivers from may 2013

    Please updatethis to the latest windows 8.1 compatible drivers from ,ASRock > 970 Pro3 R2.0 also check if can update the other drivers.

    Your TP-LINK 150Mbps Wireless N Adapter has drivers from april 2013, please update to the latest version here Drivers for Atheros AR5006G and Windows 8

    You are using a EasyTether Network Adapter with a driver from march 2013. I have no experience with this device and do not know if it is windows 8.1 compatible.
    Check this here:
    Driver Description: Mobile Stream EasyTether
    Driver Update Site: Support: Easy Tether for Android, USB Modem, Bluetooth DUN modem, Palm Card Reader, mobile games - Mobile Stream Support Team.
    Downloads: Download EasyTether for BlackBerry and Android, USB Modem for Palm and Windows Mobile, iPhone, Android, Nokia games

    You said you uninstalled Virtual Audio Cable's but in your driverlist it is still installed
    vbaudio_cable64_win7 fffff801`8d883000 fffff801`8d890000 Tue Jun 25 12:42:03 2013 (51c973fb) 00018fb6 vbaudio_cable64_win7.sys

    I noticed you have many programs installed related to safety/dataprotection etc.with drivers from 2007, 2009 etc. do not know if this are windows 8.1 compatible. Please check with the makers of these programs.
    Please check it and remove/uninstall it.

      My System SpecsSystem Spec

  3. #3

    Posts : 6
    Windows 8.1

    Hey, thanks for the help.

    I've downloaded and installed the drivers for Realtek LAN and Audio from the ASrock page, and also updated the TPLink Wireless Adapter driver from the link given.
    Following that, I uninstalled Easytether to see if that'd make a difference.

    Unfortunately, during this process my PC would not behave, first hardlocking (requiring a restart) while downloading the Realtek Audio driver, then throwing a KMODE_EXCEPTION_NOT_HANDLED after having extracted the zip files. Following this it threw an IRQL_NOT_LESS_OR_EQUAL during the realtek audio driver setup (bad, I thought I was clear of those) and finally another KMODE_EXCEPTION_NOT_HANDLED when I went to look at the Programs and Features list to uninstall Easytether.

    So, not so good so far but I have managed to get the drivers suggested updated.
    Thanks again.

    Also, VB Audio Cable is a different program from Virtual Audio Cable, which I installed as an alternative after driver verifier pointed out VAC's drivers were a problem.

    Decided to reinstall malwarebytes and run a full scan in safe mode with networking. First it BSOD while scanning the filesystem (ATTEMPTED_EXECUTE_OF_NOEXECUTE_MEMORY) and after restarting and running the scan again, it hard-locked while scanning the filesystem again. I'm retrying now in minimal safe mode to see if it makes a difference.
    ...and it hardlocked during the filesystem scan section again.
    ...and again. It seems to be freezing at around the same point - namely ~49000 items scanned. This also happens to be Max Payne 3's folder. I shall try scanning MP3's folder by itself. Nope, wasn't Max Payne 3.
    ...finally managed to get a full system scan done by having it ignore both Max Payne 3 and Steam's folders, and then scanning them separately. Malwarebytes detected 1 threat, (PUP optional.somoto) in google chrome's programdata.
    Last edited by Azba; 05 Jun 2014 at 03:50. Reason: durr moment
      My System SpecsSystem Spec

  4. #4

    Posts : 660
    windows 8.1

    Did you already run the SFC/scannow and/or DISM commands to check for corrupted or modified system(files).
    Sometimes you need to run it 3 times.

    tutorial here SFC /SCANNOW Command - Run in Windows 8
      My System SpecsSystem Spec

  5. #5

    Posts : 6
    Windows 8.1

    Alright, I did try running SFC /scannow a couple of times but it did not think anything was the matter. I also ran the DISM commands a few times, and it did apparently catch some kind of corruption and "fix" it.
    However, I will try them again in case they missed something, restarting between each try.

    Meanwhile, I made another SF Diagnostic dump for the crashes that occurred after updating the suggested drivers and cleaning out some others.
    Things changed:
    • Uninstalled TAGES drivers (lirsgt and atksgt) via their uninstallation tool.
    • Uninstalled Macromedia secdrv driver.
    • Updated Realtek PCIe GBE Family Controller driver via Asrock mobo page.
    • Updated TPLink wireless card driver via link given.
    • Uninstalled suspicious software "Granddog run time environment" which I do not remember installing.
    • Reinstalled Malwarebytes and ran several scans in safe mode, succeeded only in removing dormant toolbar adware.
    • Ran WD Elements HDD Lifeguard diagnostic tool (for my HDD, a WD Caviar Blue 1tb) - all clear on both quick and extended tests.

    PC has hard-locked and BSODed several times today, even more concerning is that it still hardlocked while inside safe mode.

    Anyway I will be running more of those DISM and SFC checks and will get back to you.

    Jeeeeeez. Windows 8.1 is throwing every BSOD it has at me now while I'm trying to get SFC /scannow to run. DISM announced it found and fixed something, so I restarted the PC and now every single time I've tried running SFC again it's BSODed. However I shall persevere until it actually completes the process. BSODs include CLOCK_WATCHDOG_TIMEOUT, IRQL_NOT_LESS_OR_EQUAL, SYSTEM_SERVICE_EXCEPTION and KMODE_EXCEPTION_NOT_HANDLED. Bluescreenview indicted athwbx.sys (the TPLink driver) for the IRQL error, which is bad because I just got done updating that. Also pointed out is storport.sys.

    Decided to go temporarily remove and uninstall the TPLink wireless network adapter and run sfc and dism again. Internet access is via ethernet cable now. Still getting KMODE_EXCEPTION_NOT_HANDLED bsods, especially while SFC and/or DISM are trying to run. Very frustrating.
    Last edited by Azba; 05 Jun 2014 at 07:44.
      My System SpecsSystem Spec

  6. #6

    Posts : 6
    Windows 8.1

    Well, it was a long night of BSODs and hard locks, but in the end I managed to get DISM (with restorehealth) to "repair" something, restart and then have SFC work. SFC reported no corruption to be repaired.

    Decided I'd get the SF Diagnostic Tool to collect a dump again, just in case. It also caused a BSOD just now while it was trying to generate the MSINFO32 file (IRQL not less or equal).
    At this point I'm seriously considering just grabbing an SSD or something and installing Windows 7 on it.

    Things done since last post:
    Literally nothing except trying to get SFC and DISM commands to run without being interrupted by a BSOD.
    DISM now reports no component store corruption with /checkhealth and /scanhealth.
    SFC also reports no corruption to fix.

    Additionally, Malwarebytes appears to have corrupted itself somehow in between the safe mode scans and now. It now crashes upon trying to launch (APPCRASH in MSVCR100.dll)

    At the suggestion of a friend I am going to try booting my PC with a livedisc instead and see if it still has the same issues. Just to rule out hardware issues.
    ...and just as I expected, the windows 7 livedisc was able to connect to the internet, browse around, open images, run DISM and SFC without any bsods at all. Though, chances are this is simply because it had bare minimum drivers installed.
    Last edited by Azba; 05 Jun 2014 at 21:38.
      My System SpecsSystem Spec

  7. #7

    Posts : 6
    Windows 8.1

    Decided to see if it was Nvidia GEForce Experience causing the bsods after catching a lead from a different forum, but disabling it doesn't seem to have done any good.
    At this point I am thinking the best course of action is to run a Windows 8 refresh, and if that fails I will simply give up and install windows 7.
    That is, unless the most recent dumps were able to shed any light on the problem?
      My System SpecsSystem Spec

  8. #8

    Posts : 660
    windows 8.1

    Analysing/looking at your latest dumpfiles, there were also 2 probably caused by hardware dumpfiles.

    You have a genius imperator pro keyboard.
    I found this driver KYEKBPRO fffff800`30cac000 fffff800`30cba000 Fri Oct 14 09:24:15 2011 (4e97e39f) 00010efb KYEKBPRO.sys from 2011. It is not in DRT we are using, but i suspect that it is the driver for your gaming keyboard and it predates windows 8.
    Please update it from here Genius.
    Please also update/check the drivers for your asus gaming mouse from here Keyboards & Mice - GX950 - ASUS.

    Your latest dumpfile show the driver hostnet.sys from 2007. This belongs to Sentinel protection. Please update from here Sentinel Drivers| SafeNet

    I notice that you are using the legacy mode on this install, if you considering a fresh install of windows 8.1 i advice you to use uefi mode.

    In the latest dumpfile in the stacktext there are references to problems with ACPI and to amdppm this is processor device driver Driver Description: Processor Device Driver
    Driver Update Site: Windows Update

    fffff803`1a3093f8 fffff803`187dbae9 : 00000000`0000000a 00000000`00004ee7 00000000`0000000d 00000000`00000001 : nt!KeBugCheckEx
    fffff803`1a309400 fffff803`187da33a : 00000000`00000001 fffff803`18962180 00000000`00000000 fffff803`1a309540 : nt!KiBugCheckDispatch+0x69
    fffff803`1a309540 fffff803`187d1dce : 00000000`00000000 00000004`191fddb2 fffff803`00001000 ffffe001`f09382f0 : nt!KiPageFault+0x23a
    fffff803`1a3096d0 fffff800`3050bcd2 : fffff800`3050b527 00000000`00000000 ffffe001`f2fef010 fffff803`1a3099a0 : nt!KiInterruptDispatchNoLockNoEtw+0x12e
    fffff803`1a309868 fffff800`3050b527 : 00000000`00000000 ffffe001`f2fef010 fffff803`1a3099a0 fffff803`18962180 : amdppm!C1Halt+0x2
    fffff803`1a309870 fffff803`1873271a : fffff803`18962180 fffff803`1a309900 00000001`66a2b23e 00000000`00000000 : amdppm!AcpiCStateIdleExecute+0x17
    fffff803`1a3098a0 fffff803`1873218a : fffff803`18962180 fffff803`1a309acc fffff803`1a309ad0 fffff803`1a309ad8 : nt!PpmIdleExecuteTransition+0x3da
    fffff803`1a309a90 fffff803`187d3abc : fffff803`18962180 fffff803`18962180 fffff803`189c9a00 00000000`0001064e : nt!PoIdle+0x27a
    fffff803`1a309be0 00000000`00000000 : fffff803`1a30a000 fffff803`1a303000 00000000`00000000 00000000`00000000 : nt!KiIdleLoop+0x2c
      My System SpecsSystem Spec

  9. #9

    Posts : 6
    Windows 8.1

    Alrighty, drivers updating. However, I see no available updates in Windows Update, so how would I go about amdppm? Is it possible an earlier update got it but it did not install correctly?
      My System SpecsSystem Spec

  10. #10

    Posts : 660
    windows 8.1

    Try updating your chipset drivers from here AMD Chipset Drivers
      My System SpecsSystem Spec

Related Threads
Hi t all, i've a problem with my computer. From a few day i expect a random BSOD on my computer. I don't have do nothing like hardware modify or software upgrade but the problem still persist. Today i've try to reinstall my OS (Windows 8.1 Update 1) but the problem still persist. Try again...
Windows 8.1 BSoD KMODE_EXCEPTION_NOT_HANDLED in BSOD Crashes and Debugging
Hello, After building my new computer i've been receiving a BSoD every day. The most common of these is KMODE_EXCEPTION_NOT_HANDLED. I've tried completely uninstalling and reinstalling Graphics Drivers, testing the RAM and the Hard Drive. Any help is appreciated -Jon
Brand new Sony Vaio SVS151290X laptop on Windows 8 (5 weeks old), SSD drive (replacing another Sony Vaio that was 8 mos old running on Win 7 that had Power_State_Failures trying to sleep or hibernate as well). Two issues: 1) Random BSOD, 2 to 4 times a day You can see from the attached...
Solved Kmode_exception_not_handled bsod in BSOD Crashes and Debugging
As in title. Using Dell 10 Latitude Tablet with Windows 8.1 (no problem with Dell original installed 8).BSOD only shows when going to Korean banking site. Diagnostic zip file included. Thank you very much for any help with this problem
Hi everyone. Quite a while back, I purchased an HP Pavilion Sleekbook with Windows 8. It had problems since the day I bought it around two months ago. The shop does not accept refunds. But this laptop has been in the PC clinic around 8 times since I bought it. The problem persisted, although the...
hi all! I had some BSOD with my windows 8. I usually check for update but I still got this problem. please help me! thanks all!:)
Hello, I upgraded my system to Windows 8 32bit from Windows 7. Prior to the upgrade my computer had issues where it would occasionally lock up completely (not responding to any keys even Ctrl-Alt-Del and unable to move the mouse) and a hard Shut Down (i.e. holding the Power Button down for a...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook