Windows 8 and 8.1 Forums

BSOD Inaccessible_Boot_Device Win 8.1 Pro X64

  1. #1

    Posts : 27
    Windows 8.1 Pro X64

    BSOD Inaccessible_Boot_Device Win 8.1 Pro X64


    After a thorough search through the forum, I can't solve my weird problem:

    Before all, my setup is:
    - Windows 8.1 PRO X64 (upgraded from Windows 8 x64 Pro upgrade)
    - SSD Samdung 840 Pro (O/S)
    - HDD Hitachi 1TB (Data)
    - HDD WD Green 2tb (Storage)
    - MB: Gigabyte X58 Extreme

    Yesterday, I turned my PC on as usual and letf it loading windows for like 2 minutes. When I had a sit and tried the mouse it wasn't working, the other USB components were working fine, I logged off, unplugged the mouse and plugged back again, it didn't work. Restarted windows, and after the BIOS splah screen came up, the mouse light was on, which means this time the mouse was working, but suddenly I get this BSOD:

    I restarted the PC, and it started the automatic repair process, however the same BSOD came up.
    I should say that I have upgraded from Windows 7 to Windows 8 using a Windows 8 Upgrade DVD but I was able to perform a clean install. I have upgraded to windows 8.1 afterwards. The SSD always worked fine in AHCI mode. I haven't installed nothing in the previous day, unless Windows installed any update or driver itself, but the automatic updates are off, and that's what is confusing me.

    I've tried loads of procedures, started by changing from AHCI to IDE, switched cables, reset CMOS, system recovery, and refresh install. If I select refresh install, a message comes up saying that the drive is locked and needs to be unlocked. I've tried all "bootrec" comands, it does not detect any windows instalations. I used the macrium PE usb drive to attempt a backup of the SSD, and it was successful, I could access to any file in it, which makes me believe that the SSD is not faulty. All the drives are detected by the BIOS, however, if I change to AHCI mode, no driver is detected. I cannot even boot into safemode.

    I believe that I cannot repair a windows 8.1 installation with a windows 8 upgrade disc and that's probably the reason why the automatic repair failed, so what are my options here?


      My System SpecsSystem Spec

  2. #2

    Posts : 5,139
    Win8.1Pro - Finally!!!

    It takes 2 minutes to load Windows with a Samsung 840 SSD? That's just not right! Mine starts much quicker. Hold on while I time it..........
      My System SpecsSystem Spec

  3. #3

    Posts : 5,139
    Win8.1Pro - Finally!!!

    I just timed it - it took less than 12 seconds (and that might be a bit long as I timed the restart).
    That was to get to the login screen.
    This install was done as a clone of the slow hard drive that the laptop came with.

    The first thing would be to see what's causing the long boot times.
    Could you take a screen shot of the Disk Management window and post it here?
    What I suspect is that the system boots from one of the other hard drives, then transfers control to the SSD.

    Please provide this information so we can provide a complete analysis (from the Pinned Topic at the top of the forum): Blue Screen of Death (BSOD) Posting Instructions Please use Option 1 as it provides Event Viewer logs.

    The Gigabyte site seems to indicate that this mobo isn't certified for Win8 (and, possibly, isn't compatible with it).
    This may affect how we proceed (Win7 vs Win8). Do you have a copy of Win7 (just in case)?

    Please run these hard drive diagnostics on ALL hard drives while waiting for a reply: Hard Drive Diagnostic Procedure
      My System SpecsSystem Spec

  4. #4

    Posts : 27
    Windows 8.1 Pro X64

    Quote Originally Posted by usasma View Post
    It takes 2 minutes to load Windows with a Samsung 840 SSD? That's just not right! Mine starts much quicker. Hold on while I time it..........
    No, it takes about 20 seconds to boot, but I left it for 2 minutes, because I was grabbing for some

    Anyway, I attempted an automatic repair and system restore, both unsuccessful. After the repairs it ended up on a screen with this message:
    After multiple tries, the operating system on your PC failed to start, so it needs to be repaired.

    Error code: 0xc0000001

    You'll need to use the recovery tools on your installation media. If you don't have any installation media (like a disc or USB device), contact your system administrator or PC manufacturer.

    I had 2 options, either continue to O/S or to select safe mode options, if select continue to O/S or safemode or any other option, it ends up on the same error "inaccesible boot device".

    What I've noticed was that when I installed windows 8 it created a recovery partition on the 2nd HDD, and I believe that somehow it attempted to boot from there. It's weird, I use this setup since January without any problems, everything worked perfectly until Thursday.

    In order to find out if it was SSD fault I have formatted it and reinstalled windows 8 and did the 8.1 upgrade, it worked fine, I then restored the image from macrium PE and it does not work, it's definitely a windows problem, looks like the drive is somehow locked, BTW, I don't have bitlocker enabled, and I've never had, but it wouldn't surprise that windows could lock a drive by itself the same way I had DCOM permissions problems before.

    Meanwhile I did a windows 8.1 pro recovery disk, and attempted to repair the boot with it, but it comes up with an error stating "a patch is preventing the system from starting".

    Please provide this information so we can provide a complete analysis (from the Pinned Topic at the top of the forum): Blue Screen of Death (BSOD) Posting Instructions Please use Option 1 as it provides Event Viewer logs.
    How can I do this if cannot log into windows? Is there a way to do it using winPE?

      My System SpecsSystem Spec

  5. #5

    Posts : 5,139
    Win8.1Pro - Finally!!!

    The info we need is from Windows reports.
    The only thing that you can do (fairly easily) outside of Windows is to upload the memory dump files (in C:\Windows\Minidump)

    The Inaccessible Boot Device is either a boot problem or a hard drive problem (hardware).
    Please run the diagnostics that I suggested previously - the hard drive diagnostics are bootable and don't require Windows to work (and, AFAIK, you can run the Western Digital diagnostics for Windows from within WinPE).

    I've seen the "hard drive is locked" error and the "patch is preventing" error - and in these cases I've resorted to wiping out the partitions on the hard drive and starting over fresh. You MUST have a full set of recovery media BEFORE doing this.

    As we're talking about starting over fresh here, it'd be a good idea to:
    - set the SSD as the boot drive in the UEFI/BIOS
    - make sure that UEFI/BIOS and Secure Boot are enabled.
    - reset the UEFI/BIOS to default values
    - disconnect the other hard drives while installing Windows (this'll ensure that the entire boot sequence occurs on the SSD). You can reconnect them afterwards (as long as you leave the SSD first in the boot sequence).
      My System SpecsSystem Spec

  6. #6

    Posts : 27
    Windows 8.1 Pro X64

    Ok, now I've used an external HDD case to connect the SSD to this PC so I can upload the dmp file, it matches the date and hour when the first boot failed, please find it here: Note: This dmp was stored in a folder called "svchost.exe appcrash".

    UPDATE: I've decided to perform a fresh install, I just would like to know what is the possible cause of this because I haven't done any changes, this happened suddenly. Of course I will keep doing incremental and differential backups of the SSD every 2 days from now on as the system restore or automatic repair really sucks in windows 8/8.1.
    Last edited by blz; 24 May 2014 at 14:08.
      My System SpecsSystem Spec

  7. #7

    Posts : 5,139
    Win8.1Pro - Finally!!!

    This dump is from the crash of a user mode process.
    This is not from a BSOD (which is from the crash of a kernel mode process.
    In short, a user mode process cannot cause a BSOD crash.

    I suspect that there are indirect ways in which a BSOD can occur after a user mode process has crashed - but I'm uncertain of the exact mechanisms behind that.

    The error here appears to be from HP Digital Image Monitor Software (hpslpsvc64.dll)
    I would suggest:
    1) download a fresh copy of the HP printer software
    2) uninstall the current HP printer software and utilities from your system
    3) use CCleaner (free from here: Piriform - Download CCleaner - Millions of users worldwide! ) to remove all the temp files (this topic shows that the offending DLL often located in a Temp folder within the user's AppData folder: How fix this hpslpsvc64.dll? - HP Support Forum - 343239 )
    4) install the freshly downloaded HP printer software

    As you are starting over fresh, there's no need for you to do this.

    Here's the user mode dump analysis:
    Microsoft (R) Windows Debugger Version 6.3.9600.16384 AMD64
    Copyright (c) Microsoft Corporation. All rights reserved.
    Loading Dump File [C:\Users\John\Downloads\triagedump.dmp]
    User Mini Triage Dump File: Only registers, stack and portions of memory are available
      The user dump currently examined is a triage dump. Consequently, only a subset of debugger
      functionality will be available. If needed, please collect a minidump or a heap dump.
          To create a mini user dump use the command: .dump /m <filename>
          To create a full user dump use the command: .dump /ma <filename>
      Triage dumps have certain values on the stack and in the register contexts overwritten with
      pattern 0xAAAAAAAA. If you see this value
          1. the original value was not NULL
          2. the original value was not a direct pointer to a loaded or unloaded image
          3. the original value did not point to an object whose VFT points to a loaded or
             unloaded image (indirect pointer)
          4. the original value did not point to the stack itself or any memory area added to
             the dump (TEB, PEB, memory for CLR stackwalk or exceptions, etc.)
          5. the original value was not a valid handle value
    ************* Symbol Path validation summary **************
    Response                         Time (ms)     Location
    Deferred                                       SRV*c:\symbols*
    Deferred                                       srv*c:\SymcachePublic*
    Symbol search path is: SRV*c:\symbols*;srv*c:\SymcachePublic*
    Executable search path is: 
    Windows 8 Version 9600 MP (8 procs) Free x64
    Product: WinNt, suite: SingleUserTS
    Built by: 6.3.9600.16384 (winblue_rtm.130821-1623)
    Machine Name:
    Debug session time: Thu May 22 13:03:01.000 2014 (UTC - 4:00)
    System Uptime: 11 days 17:15:46.112
    Process Uptime: 11 days 17:15:52.000
    Loading unloaded module list
    This dump file has an exception of interest stored in it.
    The stored exception information can be accessed via .ecxr.
    (ce4.ce8): Access violation - code c0000005 (first/second chance not available)
    00007ffb`c087738a c3              ret
    0:000> !analyze -v
    *                                                                             *
    *                        Exception Analysis                                   *
    *                                                                             *
    *** WARNING: Unable to verify timestamp for hpslpsvc64.dll
    *** ERROR: Module load completed but symbols could not be loaded for hpslpsvc64.dll
    00007ffb`be705639 48894160        mov     qword ptr [rcx+60h],rax
    EXCEPTION_RECORD:  ffffffffffffffff -- (.exr 0xffffffffffffffff)
    ExceptionAddress: 00007ffbbe705639 (combase!CStdIdentity::CInternalUnk::Release+0x0000000000000398)
       ExceptionCode: c0000005 (Access violation)
      ExceptionFlags: 00000000
    NumberParameters: 2
       Parameter[0]: 0000000000000001
       Parameter[1]: 0000000000000060
    Attempt to write to address 0000000000000060
    CONTEXT:  0000000000000000 -- (.cxr 0x0;r)
    rax=aaaaaaaaaaaaaaaa rbx=aaaaaaaaaaaaaaaa rcx=aaaaaaaaaaaaaaaa
    rdx=0000000000000000 rsi=aaaaaaaaaaaaaaaa rdi=000000956b3fdef0
    rip=00007ffbc087738a rsp=000000956b3fddf8 rbp=aaaaaaaaaaaaaaaa
     r8=0000000000000080  r9=0000000000000000 r10=aaaaaaaaaaaaaaaa
    r11=aaaaaaaaaaaaaaaa r12=aaaaaaaaaaaaaaaa r13=aaaaaaaaaaaaaaaa
    r14=aaaaaaaaaaaaaaaa r15=aaaaaaaaaaaaaaaa
    iopl=0         nv up ei pl zr na po nc
    cs=0033  ss=002b  ds=002b  es=002b  fs=0053  gs=002b             efl=00000246
    00007ffb`c087738a c3              ret
    PROCESS_NAME:  svchost.exe
    ERROR_CODE: (NTSTATUS) 0xc0000005 - The instruction at 0x%08lx referenced memory at 0x%08lx. The memory could not be %s.
    EXCEPTION_CODE: (NTSTATUS) 0xc0000005 - The instruction at 0x%08lx referenced memory at 0x%08lx. The memory could not be %s.
    EXCEPTION_PARAMETER1:  0000000000000001
    EXCEPTION_PARAMETER2:  0000000000000060
    WRITE_ADDRESS:  0000000000000060 
    00000001`80031f16 ??              ???
    APP:  svchost.exe
    ANALYSIS_VERSION: 6.3.9600.16384 (debuggers(dbg).130821-1623) amd64fre
    FAULTING_THREAD:  0000000000000ce8
    LAST_CONTROL_TRANSFER:  from 0000000180031f16 to 00007ffbbe705639
    00000095`6b3ff420 00000001`80031f16 : aaaaaaaa`aaaaaaaa 00000001`80069b74 00000095`6bf37cc0 aaaaaaaa`aaaaaaaa : combase!CStdIdentity::CInternalUnk::Release+0x398
    00000095`6b3ff490 aaaaaaaa`aaaaaaaa : 00000001`80069b74 00000095`6bf37cc0 aaaaaaaa`aaaaaaaa aaaaaaaa`aaaaaaaa : hpslpsvc64+0x31f16
    00000095`6b3ff498 00000001`80069b74 : 00000095`6bf37cc0 aaaaaaaa`aaaaaaaa aaaaaaaa`aaaaaaaa 00000095`6bf30dc0 : 0xaaaaaaaa`aaaaaaaa
    00000095`6b3ff4a0 00000095`6bf37cc0 : aaaaaaaa`aaaaaaaa aaaaaaaa`aaaaaaaa 00000095`6bf30dc0 00000095`6bf30dc0 : hpslpsvc64+0x69b74
    00000095`6b3ff4a8 aaaaaaaa`aaaaaaaa : aaaaaaaa`aaaaaaaa 00000095`6bf30dc0 00000095`6bf30dc0 00000001`80026eb3 : 0x00000095`6bf37cc0
    00000095`6b3ff4b0 aaaaaaaa`aaaaaaaa : 00000095`6bf30dc0 00000095`6bf30dc0 00000001`80026eb3 00000095`6bf37cd0 : 0xaaaaaaaa`aaaaaaaa
    00000095`6b3ff4b8 00000095`6bf30dc0 : 00000095`6bf30dc0 00000001`80026eb3 00000095`6bf37cd0 aaaaaaaa`aaaaaaaa : 0xaaaaaaaa`aaaaaaaa
    00000095`6b3ff4c0 00000095`6bf30dc0 : 00000001`80026eb3 00000095`6bf37cd0 aaaaaaaa`aaaaaaaa 00000095`6bf37cc0 : 0x00000095`6bf30dc0
    00000095`6b3ff4c8 00000001`80026eb3 : 00000095`6bf37cd0 aaaaaaaa`aaaaaaaa 00000095`6bf37cc0 00000095`6b5de510 : 0x00000095`6bf30dc0
    00000095`6b3ff4d0 00000095`6bf37cd0 : aaaaaaaa`aaaaaaaa 00000095`6bf37cc0 00000095`6b5de510 aaaaaaaa`aaaaaaaa : hpslpsvc64+0x26eb3
    00000095`6b3ff4d8 aaaaaaaa`aaaaaaaa : 00000095`6bf37cc0 00000095`6b5de510 aaaaaaaa`aaaaaaaa aaaaaaaa`aaaaaaaa : 0x00000095`6bf37cd0
    00000095`6b3ff4e0 00000095`6bf37cc0 : 00000095`6b5de510 aaaaaaaa`aaaaaaaa aaaaaaaa`aaaaaaaa 00000095`6bf30cc0 : 0xaaaaaaaa`aaaaaaaa
    00000095`6b3ff4e8 00000095`6b5de510 : aaaaaaaa`aaaaaaaa aaaaaaaa`aaaaaaaa 00000095`6bf30cc0 aaaaaaaa`aaaaaaaa : 0x00000095`6bf37cc0
    00000095`6b3ff4f0 aaaaaaaa`aaaaaaaa : aaaaaaaa`aaaaaaaa 00000095`6bf30cc0 aaaaaaaa`aaaaaaaa 00000095`6bf30dc0 : 0x00000095`6b5de510
    00000095`6b3ff4f8 aaaaaaaa`aaaaaaaa : 00000095`6bf30cc0 aaaaaaaa`aaaaaaaa 00000095`6bf30dc0 aaaaaaaa`aaaaaaaa : 0xaaaaaaaa`aaaaaaaa
    00000095`6b3ff500 00000095`6bf30cc0 : aaaaaaaa`aaaaaaaa 00000095`6bf30dc0 aaaaaaaa`aaaaaaaa aaaaaaaa`aaaaaaaa : 0xaaaaaaaa`aaaaaaaa
    00000095`6b3ff508 aaaaaaaa`aaaaaaaa : 00000095`6bf30dc0 aaaaaaaa`aaaaaaaa aaaaaaaa`aaaaaaaa 00000095`6bf37cc0 : 0x00000095`6bf30cc0
    00000095`6b3ff510 00000095`6bf30dc0 : aaaaaaaa`aaaaaaaa aaaaaaaa`aaaaaaaa 00000095`6bf37cc0 aaaaaaaa`aaaaaaaa : 0xaaaaaaaa`aaaaaaaa
    00000095`6b3ff518 aaaaaaaa`aaaaaaaa : aaaaaaaa`aaaaaaaa 00000095`6bf37cc0 aaaaaaaa`aaaaaaaa 00000001`80030e39 : 0x00000095`6bf30dc0
    00000095`6b3ff520 aaaaaaaa`aaaaaaaa : 00000095`6bf37cc0 aaaaaaaa`aaaaaaaa 00000001`80030e39 00000095`6bf37cc0 : 0xaaaaaaaa`aaaaaaaa
    00000095`6b3ff528 00000095`6bf37cc0 : aaaaaaaa`aaaaaaaa 00000001`80030e39 00000095`6bf37cc0 00000095`6bf37cd0 : 0xaaaaaaaa`aaaaaaaa
    00000095`6b3ff530 aaaaaaaa`aaaaaaaa : 00000001`80030e39 00000095`6bf37cc0 00000095`6bf37cd0 aaaaaaaa`aaaaaaaa : 0x00000095`6bf37cc0
    00000095`6b3ff538 00000001`80030e39 : 00000095`6bf37cc0 00000095`6bf37cd0 aaaaaaaa`aaaaaaaa 00000000`00000000 : 0xaaaaaaaa`aaaaaaaa
    00000095`6b3ff540 00000095`6bf37cc0 : 00000095`6bf37cd0 aaaaaaaa`aaaaaaaa 00000000`00000000 aaaaaaaa`aaaaaaaa : hpslpsvc64+0x30e39
    00000095`6b3ff548 00000095`6bf37cd0 : aaaaaaaa`aaaaaaaa 00000000`00000000 aaaaaaaa`aaaaaaaa aaaaaaaa`aaaaaaaa : 0x00000095`6bf37cc0
    00000095`6b3ff550 aaaaaaaa`aaaaaaaa : 00000000`00000000 aaaaaaaa`aaaaaaaa aaaaaaaa`aaaaaaaa aaaaaaaa`aaaaaaaa : 0x00000095`6bf37cd0
    00000095`6b3ff558 00000000`00000000 : aaaaaaaa`aaaaaaaa aaaaaaaa`aaaaaaaa aaaaaaaa`aaaaaaaa 00000001`80030d05 : 0xaaaaaaaa`aaaaaaaa
    STACK_COMMAND:  ~0s; .ecxr ; kb
    SYMBOL_NAME:  hpslpsvc64+31f16
    FOLLOWUP_NAME:  MachineOwner
    MODULE_NAME: hpslpsvc64
    IMAGE_NAME:  hpslpsvc64.dll
    FAILURE_BUCKET_ID:  NULL_CLASS_PTR_WRITE_c0000005_hpslpsvc64.dll!Unknown
    FAILURE_ID_HASH_STRING:  um:null_class_ptr_write_c0000005_hpslpsvc64.dll!unknown
    FAILURE_ID_HASH:  {94772296-0838-7631-a6ec-b0e6ea5afffa}
    Followup: MachineOwner
    0:000> lmvm hpslpsvc64
    start             end                 module name
    00000001`80000000 00000001`80155000   hpslpsvc64 T (no symbols)           
        Loaded symbol image file: hpslpsvc64.dll
        Image path: hpslpsvc64.dll
        Image name: hpslpsvc64.dll
        Timestamp:        Thu Aug 18 04:29:49 2011 (4E4CCD7D)
        CheckSum:         00106311
        ImageSize:        00155000
        File version:     140.0.416.0
        Product version:
        File flags:       0 (Mask 3F)
        File OS:          10004 DOS Win32
        File type:        2.0 Dll
        File date:        00000000.00000000
        Translations:     0000.04b0 0000.04e4 0409.04b0 0409.04e4
      My System SpecsSystem Spec

  8. #8

    Posts : 27
    Windows 8.1 Pro X64

    I had problems with that HP digital imaging monitor thing before, but it never caused BSOD, in the worst of options it would not allow me to use my printer by wifi. This is very weird, it could be just a coincidence. Anyway, I have everything running up again, it took me some hours to reinstall everything, but at least it's a clean install. I am seriously confused of what may caused this, since I've made no changes to drivers or hardware whatsoever in the previous day, I suspect that a virus sneaked in or some hardware intermittent problem came up (the USB mouse wasn't working even if plugged in another USB port, the mouse is only 2 months old). Other thing that I suspect is that 2 days before the BSOD happened, I did a SFC repair, and it eventually could have changed the registry to IDE mode instead of keeping AHCI like it was before, but I've done loads of SFC's since I have this setup and never had any problems.

    Anyway, thanks for analysing the dump file, I appreciate your help.
      My System SpecsSystem Spec

BSOD Inaccessible_Boot_Device Win 8.1 Pro X64
Related Threads
Inaccessible_boot_device in BSOD Crashes and Debugging
The other day I installed Paragon HFS+ and it was unable to work. I then proceeded to install MacDrive, then going to uninstall Paragon I tried to uninstall MacDrive but it wouldn't uninstall. I clicked repair and rebooted and upon reboot I was greeted with INACCESSIBLE_BOOT_DEVICE. I am running...
I'm sorry to make another post within this area of the forum on the same problem, however I thought it would have been easier to start a new topic seeing that new developments have occurred and that it's been ages since I posted in the my last thread here. And now to the topic. My desktop's been...
This all started when I was looking up methods to fix the USB root hub errors I've been having since I upgraded to windows 8. I found this method that involved deleting the Upperfilter regkey. I deleted the CDRom one and I think the other one I deleted was the devicemgr one. I backed them both up...
inaccessible_boot_device in Installation & Setup
Hi there, Ive just tried to upgrade to Windows 8 from my Windows 7 (64bit) and it all seems to install okay until it restarts and it fails with a big sad face sayign "inaccessible_boot_device". I have a HP Envy 6-1010ea Ultrabook if that helps. Ive read on some other forums that I need to...
Inaccessible_boot_device in Installation & Setup
Hi guys, I've been waiting for the cp of windows 8 for a long time. So when yesterday it was released i couldn't be happier. Untill i tried to install it. Everything goes well. the in windows installation, Restart, preparation (where you see the fish and the percentages underneath and when it...
Inaccessible_boot_device in Windows Updates & Activation
Inaccessible_boot_device in Installation & Setup
Hello Eightforums! I have tried so many, many Windows 8 installation attempts (in fact I wasted 2 DVDs, time and effort) but all led to one error "INACCESSIBLE_BOOT_DEVICE". After the installation (100%), my PC rebooted and the Windows Developer Preview bootscreen begins to load and after a few...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook