Windows 8 and 8.1 Forums


Dual Boot Blue Screen Even Before I Select OS?

  1. #1

    Dual Boot Blue Screen Even Before I Select OS?


    I am running Seven and Eight in a dual boot set up. I ran into an issue that I think is weird... but maybe it is normal. I dunno... I am new to dual booting.

    I managed to corrupt a bunch of Eight's system files [side note: 7tsp does NOT work with Eight yet. Heh. Oh well... live and learn. ]. That is not the weird part. When I went to reboot into Seven, however, the weird thing happens. I get a blue screen telling me my PC couldn't start before I even chose which OS to go to!

    I ran Visual BCD Dual Boot Repair and it still gives me the error. Eight runs an auto-repair function or two and when it restarts only then does it give me the choice to boot into a different OS.

    Why would a bunch of corrupted SysWow64 and System 32 files affect a boot selector screen? The OS hasn't been started yet... is this some sort of pre-boot integrity check? Or is this normal? Or is the boot screen GUI part of Eight itself and not a separate bunch of files on the MBR?

    Like I said, I'm a noob at dual booting...
    Last edited by stevieray; 08 Mar 2012 at 06:34. Reason: unclear writing in original

      My System SpecsSystem Spec

  2. #2


    Quote Originally Posted by stevieray View Post
    I am running Seven and Eight in a dual boot set up. I ran into an issue that I think is weird... but maybe it is normal. I dunno... I am new to dual booting.

    I managed to corrupt a bunch of Eight's system files [side note: 7tsp does NOT work with Eight yet. Heh. Oh well... live and learn. ]. That is not the weird part. When I went to reboot into Seven, however, the weird thing happens. I get a blue screen telling me my PC couldn't start before I even chose which OS to go to!

    I ran Visual BCD Dual Boot Repair and it still gives me the error, then it restarts and only then does it give me the choice to boot into a different OS.

    Why would a bunch of corrupted SysWow64 and System 32 files affect a boot selector screen? The OS hasn't been started yet... is this some sort of pre-boot integrity check? Or is this normal? Or is the boot screen GUI part of Eight itself and not a separate bunch of files on the MBR?

    Like I said, I'm a noob at dual booting...
    You arent the only one. My third clean install just finished.
      My System SpecsSystem Spec

  3. #3


    I'll be doing my third later today too. Or maybe I'll run sfc scannow at boot and direct it towards drive W:\ where Eight lives. Haven't decided yet...
      My System SpecsSystem Spec

  4. #4


    Posts : 5,139
    Win8.1Pro - Finally!!!


    Check for winload~1.exe Others have had dual boot issues involving winload.exe and have found that the other one (winload~1.exe) works properly.
      My System SpecsSystem Spec

  5. #5


    Quote Originally Posted by usasma View Post
    Check for winload~1.exe Others have had dual boot issues involving winload.exe and have found that the other one (winload~1.exe) works properly.
    I've got winload.exe in ten separate places (four winload.exe.mui, four winload.exe, and a backup of each type) but no winload~1.exe. Where do I get it and what do I do with the others... just delete them?
      My System SpecsSystem Spec

  6. #6


    Posts : 5,139
    Win8.1Pro - Finally!!!


    No need to get the other one, it's a different problem and won't affect what you're experiencing.
      My System SpecsSystem Spec

  7. #7


    Posts : 502
    Vanilla 8 Pro x64


    Quote Originally Posted by stevieray View Post

    When I went to reboot into Seven, however, the weird thing happens. I get a blue screen telling me my PC couldn't start before I even chose which OS to go to!


    I get a BSOD every time I reboot into Seven after being in 8, but upon restart all is fine. It doesn't make any difference which OS is set as the default.

    The OS hasn't been started yet... is this some sort of pre-boot integrity check? Or is this normal? Or is the boot screen GUI part of Eight itself and not a separate bunch of files on the MBR?
    I also get a BSOD every time I shutdown/restart Win 8 on my desktop. I suspect it's something to do with the hybrid boot function not playing nicely with some chipsets. PITA either way.
      My System SpecsSystem Spec

  8. #8


    Well, I got the issue fixed by running sfc at boot using diskpart, so my immediate problem is gone. However I still would like to know how file corruptions in an OS that hasn't been selected yet can cause a blue screen before the boot selector screen has even appeared.
      My System SpecsSystem Spec

  9. #9


    Posts : 5,139
    Win8.1Pro - Finally!!!


    Because the boot is affected by the stuff in the MBR, the partition tables (which specify which partition to use when booting) and boot sectors. And this stuff is setup by Windows during installation.
      My System SpecsSystem Spec

Dual Boot Blue Screen Even Before I Select OS?
Related Threads
Hi everyone, recently i installed a windows 7 alongside with windows 8. However, the booting screen is black (DOS mode), while it's blue (somewhat Metro-like i guess) for my bro. This is not really an issue but i'd like it to be blue with usable mouse. As stated above, it's not really an issue but...
Solved how to get back blue boot screen. in Installation & Setup
I had win7 and win8 on my system. then I deleted win7 and installed a fresh copy. the boot screen is now traditional black and white boot screen where we have to choose OS. I want win8 blue boot screen back. plz help.
I have installed Blue 8.1 on a separate drive in my system along side 8.0. When I restart the 8.0 boots unless I manually select the 8.1 drive in bios. How can I alter the Boot menu to add the option to boot from either OS?
Let's say I have an OEM preinstalled Windows 8 Pro (installed under UEFI) where all installed software and data are on one partition, and the computer (a laptop) has only one drive. And, let's say I shrink the partition mentioned above leaving unallocated space and do a dual boot with...
Hi all, Apologies if this is in the wrong section, I'm new to this forum. My Dad got a Windows 8 computer about a month ago and up til now it has worked okay. Today when he turned it on, all he got was this screen: 14116 Sorry the quality is poor, I had to use my iPod camera... Basically...
Hi! Alright, so I screwed up big time. I had Windows XP pre-installed (C:) when I bought the computer nearly 3-4 years ago.Then I dually installed Windows 7 to a logical partition (D:), and then experimentally installed Windows 8 Pro WMC (G:) to the last partition, which is currently the default....
Eight Forums Android App Eight Forums IOS App Follow us on Facebook