Windows 8 and 8.1 Forums

EXPLORER.EXE crashes constantly in SHELL32.DLL

  1. #1

    Posts : 10
    Windows 8.1 64 bit

    EXPLORER.EXE crashes constantly in SHELL32.DLL

    I have a brand new Lenovo ThinkPad X1 Carbon 20A7 with Windows 8.1 Professional. EXPLORER.EXE is crashing constantly. I disabled non-Microsoft shell extensions, applied all updates, even restored back to the factory image, but nothing works. This is a very expensive new machine that is basically an unstable paperweight.

    Can someone look at the following minidump analysis, and give me some ideas, please? Thank you very much!

    *                                                                             *
    *                        Exception Analysis                                   *
    *                                                                             *
    00007ffb`535771d2 488b01          mov     rax,qword ptr [rcx]
    EXCEPTION_RECORD:  ffffffffffffffff -- (.exr 0xffffffffffffffff)
    ExceptionAddress: 00007ffb535771d2 (shell32!Microsoft::WRL::ComPtr<ISyncStatusCacheEntry>::As<IUnknown>+0x0000000000000022)
       ExceptionCode: c0000005 (Access violation)
      ExceptionFlags: 00000000
    NumberParameters: 2
       Parameter[0]: 0000000000000000
       Parameter[1]: 0000000000000000
    Attempt to read from address 0000000000000000
    CONTEXT:  0000000000000000 -- (.cxr 0x0;r)
    rax=00000000139b0000 rbx=0000000000000003 rcx=00000000139b0000
    rdx=0000000000000000 rsi=0000000000000000 rdi=0000000000000003
    rip=00007ffb54586b2a rsp=00000000194fbd58 rbp=00000000194ffa90
     r8=0000000000001000  r9=0000000000000000 r10=0000000000000040
    r11=0000000000000286 r12=0000000000000010 r13=00000000194fc128
    r14=0000000000000000 r15=0000000000000000
    iopl=0         nv up ei pl zr na po nc
    cs=0033  ss=002b  ds=002b  es=002b  fs=0053  gs=002b             efl=00000246
    00007ffb`54586b2a c3              ret
    PROCESS_NAME:  explorer.exe
    ERROR_CODE: (NTSTATUS) 0xc0000005 - The instruction at 0x%08lx referenced memory at 0x%08lx. The memory could not be %s.
    EXCEPTION_CODE: (NTSTATUS) 0xc0000005 - The instruction at 0x%08lx referenced memory at 0x%08lx. The memory could not be %s.
    EXCEPTION_PARAMETER1:  0000000000000000
    EXCEPTION_PARAMETER2:  0000000000000000
    READ_ADDRESS:  0000000000000000
    00007ffb`535771d2 488b01          mov     rax,qword ptr [rcx]
    APP:  explorer.exe
    ANALYSIS_VERSION: 6.3.9600.17029 (debuggers(dbg).140219-1702) x86fre
    FAULTING_THREAD:  00000000000007fc
    LAST_CONTROL_TRANSFER:  from 00007ffb5313d131 to 00007ffb535771d2
    00000000`194fd630 00007ffb`5313d131 : 00000000`00000000 00007ffb`52ec9ce7 00000000`14a36180 00000000`00000000 : shell32!Microsoft::WRL::ComPtr<ISyncStatusCacheEntry>::As<IUnknown>+0x22
    00000000`194fd660 00007ffb`5313c71a : 00000000`00000000 00000000`00000000 00000000`194fd700 00000000`194fd700 : shell32!`Microsoft::WRL::Module<1,Microsoft::WRL::smileyvery-happy:etails::smileyvery-happy:efaultModule<5> >::Create'::`2'::`dynamic atexit destructor for 'module''+0x95b3d
    00000000`194fd6a0 00007ffb`5301e455 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`2446ea40 : shell32!`Microsoft::WRL::Module<1,Microsoft::WRL::smileyvery-happy:etails::smileyvery-happy:efaultModule<5> >::Create'::`2'::`dynamic atexit destructor for 'module''+0x9510b
    00000000`194fd740 00007ffb`53020174 : 00000000`00000001 00000000`241e5998 00000000`241e5998 00000000`00000000 : shell32!CSyncIntegrationManager::_GetValueAndStateFromCache+0x85
    00000000`194fd7e0 00007ffb`53018930 : 00000000`00000000 00000000`194ff680 00000000`00000000 00000000`00000000 : shell32!CSyncIntegrationManager::GetSyncStatusByIdList+0x88
    00000000`194fd8b0 00007ffb`5301d0dc : 00000000`00000000 00000000`087e18d0 00000000`00000000 00000000`00000000 : shell32!CSyncStatusHandler::GetValue+0x70
    00000000`194fd910 00007ffb`52d42a12 : 00000000`194ff698 00000000`00000000 00000000`00000000 00007ffb`52ec338d : shell32!CFSFolder::_GetSyncStatusProperties+0xc8
    00000000`194fd990 00007ffb`4cea6656 : 00000000`14d82000 00007ffb`4cea2930 00000000`194ff690 00007ffb`4cea2930 : shell32!CFSFolderPropertyStore::GetValue+0x5e8
    00000000`194fef10 00007ffb`4cea6656 : 00000000`14d82000 00000000`00000001 00000000`00000001 00007ffb`4cea2930 : propsys!CMultiplexPropertyStore::GetValue+0x186
    00000000`194ff190 00007ffb`4cea32ff : 00007ffb`52f0b4f0 00000000`00514b80 00000000`24519398 00000000`194ff680 : propsys!CMultiplexPropertyStore::GetValue+0x186
    00000000`194ff410 00007ffb`4cea56ca : 00000000`00000000 00000000`194ff680 00000000`194ff680 00000000`00000000 : propsys!PSGetValueAndPath+0x5f
    00000000`194ff490 00007ffb`5301ca14 : 00000000`00000000 00000000`04e30000 00007ffb`53048050 00000000`194ff680 : propsys!CPropertyProvider::GetValue+0xca
    00000000`194ff630 00007ffb`5301b7a5 : 00000000`00000000 00000000`242823e0 00000000`80004005 00007ffb`52fd93eb : shell32!CStatusBarPropertyStore::GetValue+0x78
    00000000`194ff660 00007ffb`5301b623 : 00000000`242823e0 00000000`00000003 00000000`194ff720 00000000`1271cab0 : shell32!CGetPropertiesWorkItem::_CacheProperty+0x55
    00000000`194ff6e0 00007ffb`530215d2 : 00000000`00000000 00007ff6`b23b9000 00000000`242823e0 00000000`00000002 : shell32!CGetPropertiesWorkItem::_CachePropertyList+0x77
    00000000`194ff750 00007ffb`52fd90c7 : 00000000`12645b30 00000000`243122c0 00000000`00000000 00000000`087e0e30 : shell32!CGetPropertiesWorkItem::smileyvery-happy:oWork+0x8e
    00000000`194ff7a0 00007ffb`52ebb565 : 00000000`00000ca0 00000000`243122c0 00000000`0000000f 00000000`0000000b : shell32!CFrameTask::InternalResumeRT+0x17
    00000000`194ff7d0 00007ffb`52efe6b0 : 00000000`00000000 00000000`00000000 ffffffff`fffffffe 00000000`00200000 : shell32!CRunnableTask::Run+0x95
    00000000`194ff800 00007ffb`52efe887 : 00000000`2444ef80 00000000`2444ef80 00000000`00424270 00000000`00486d48 : shell32!CShellTaskThread::ThreadProc+0x284
    00000000`194ff950 00007ffb`4e041637 : 00007ff6`b223c000 00000000`00000000 0000f3e1`90eaa829 00000000`00000000 : shell32!CShellTaskThread::s_ThreadProc+0x2b
    00000000`194ff980 00007ffb`5451a122 : 00000000`14cb0750 00000000`00486d48 00000000`00000000 00000000`00000017 : SHCore!ExecuteWorkItemThreadProc+0xf
    00000000`194ff9b0 00007ffb`5452bddb : 00000001`00010004 00000000`1664ea50 00000000`00486d48 00000000`00424270 : ntdll!RtlpTpWorkCallback+0x11e
    00000000`194ffa90 00007ffb`52bf15cd : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : ntdll!TppWorkerThread+0x81b
    00000000`194ffe80 00007ffb`545643d1 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : kernel32!BaseThreadInitThunk+0xd
    00000000`194ffeb0 00000000`00000000 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : ntdll!RtlUserThreadStart+0x1d
    SYMBOL_NAME:  shell32!Microsoft::WRL::ComPtr<ISyncStatusCacheEntry>::As<IUnknown>+22
    FOLLOWUP_NAME:  MachineOwner
    MODULE_NAME: shell32
    IMAGE_NAME:  shell32.dll
    STACK_COMMAND:  ~67s; .ecxr ; kb
    FAILURE_BUCKET_ID:  NULL_POINTER_READ_BEFORE_CALL_c0000005_shell32.dll!Microsoft::WRL::ComPtr_ISyncStatusCacheEntry_::As_IUnknown_
    BUCKET_ID:  APPLICATION_FAULT_NULL_POINTER_READ_BEFORE_CALL_shell32!Microsoft::WRL::ComPtr_ISyncStatusCacheEntry_::As_IUnknown_+22
    FAILURE_ID_HASH_STRING:  um:null_pointer_read_before_call_c0000005_shell32.dll!microsoft::wrl::comptr_isyncstatuscacheentry_::as_iunknown_
    FAILURE_ID_HASH:  {4b7ac51a-a918-f7d6-8b9f-6758c5666bf4}
    Followup: MachineOwner
    Last edited by Brink; 10 Apr 2014 at 10:29. Reason: code box

      My System SpecsSystem Spec

  2. #2

    Posts : 660
    windows 8.1

    Please could you post your dumpfiles according to the instructions here: Blue Screen of Death (BSOD) Posting Instructions
    Please use options 1 and use grab all.
      My System SpecsSystem Spec

  3. #3

    Posts : 10
    Windows 8.1 64 bit

    The attachment contains the information gathered by the tool.
      My System SpecsSystem Spec

  4. #4

    Posts : 660
    windows 8.1

    Sorry for the delay in responding.

    There are no dumpfiles inside your Please 1. If you have not already, then please follow this using step 6 there first: Dump Files - Configure Windows to Create on BSOD

    As a start.
    Only 30Windows updates installed ensure thatyou have ALL Windows Updates. Most Windows 8.1 system have around 55 or moreupdates on average).

      My System SpecsSystem Spec

  5. #5

    Posts : 10
    Windows 8.1 64 bit

    I ran the tool as you instructed, so I don't know why the minidump wasn't automatically included. Nonetheless, I have attached it here.
      My System SpecsSystem Spec

  6. #6

    Posts : 10
    Windows 8.1 64 bit

    Forgot to mention that the identical failure occurs when all Windows 8 updates have been applied. I've tested this backwards and forwards, and every combination of refresh, restore, updates, no updates, SFC /SCANNOW, disable third party shell extensions, disable DLNA shell extension, etc. Perhaps the minidump will be a little bit enlightened.
      My System SpecsSystem Spec

  7. #7

    Posts : 660
    windows 8.1

    Perhaps the minidump will be a little bit enlightened.
    No, im sorry at least not for me. Únfortunately this is not a normal dumpfile

    This dump file has an exception of interest stored in it.
    The stored exception information can be accessed via .ecxr.
    (ca0.7fc): Access violation - code c0000005 (first/second chance not available)
    00007ffb`54586b2a c3              ret
    0:067> .ecxr
    rax=0000000000000000 rbx=00000000194fd740 rcx=0000000000000000
    rdx=00007ffb52f73750 rsi=00000000194fd750 rdi=00000000194fd6a8
    rip=00007ffb535771d2 rsp=00000000194fd630 rbp=00000000ffffffff
     r8=00000000194fd6c0  r9=00000000194fd750 r10=0000000000000000
    r11=0000000000000040 r12=0000000000000000 r13=0000000000000e00
    r14=00000000194fd740 r15=0000000000000080
    iopl=0         nv up ei pl nz na po nc
    cs=0033  ss=002b  ds=002b  es=002b  fs=0053  gs=002b             efl=00010206
    00007ffb`535771d2 488b01          mov     rax,qword ptr [rcx] ds:00000000`00000000=????????????????
    I will PM Usasma (our BSODexpert ) and ask him if he has any clue or ideas.

    My suggestion:
    Have you already checked if the issue persists in the safe mode.
    If the issue does not persist in the safe mode then I would suggest that you perform clean boot procedure and check.
    There is a possibility that some third party programs installed on the computer is causing the issue.
    How to perform a clean boot in Windows
      My System SpecsSystem Spec

  8. #8

    Posts : 5,139
    Win8.1Pro - Finally!!!

    Have you done the DISM steps here:
    DISM - Fixing Component Store Corruption in Windows 8

    I suspect Office (propsys.dll in the stack text)
    I also found references to smiley's and highlighting (if you have any programs like that, uninstall them)

    Disable all Office shell extensions to see if that helps.
    After that, the next step would be to uninstall Office and see if that helps.
    Once iit's fixed, then reinstall Office to see what happens.
      My System SpecsSystem Spec

  9. #9

    Posts : 10
    Windows 8.1 64 bit


    How could I have a corrupt component store, whatever that is, after a fresh install of Windows 8.1? I did try Safe Mode as suggested by lifetec, but that didn't help.

    I don't see any obvious Office shell extensions using ShellExView. Any idea how I might recognize them? Nothing jumps out and screams "Microsoft Office".

    Microsoft Office did not come pre-installed on this computer, to my knowledge. I can't find anything to uninstall.
      My System SpecsSystem Spec

  10. #10

    Posts : 5,139
    Win8.1Pro - Finally!!!

    I am a BSOD specialist - as such, most of my experience is in the kernel space.
    This is user space stuff, so I'm guessing to the best of my ability (it's similar and the techniques appear to be somewhat similar).

    I don't know if there is a corruption - but I asked about running DISM in order to thoroughly diagnose the problem.

    Have you scanned for malware?

    Are you saying that Office is not installed on this computer? If so, the propsys.dll (in the stack text) may not be related to Office (which my research seems to suggest). Under the Product Name column in Shell Extension Viewer it should say Microsoft Office.
    FWIW - here's the entry from my system (note that it says Windows Search - not Microsoft Office in the Product Name column. But, it is listed as an Office Document handler):
    Office Document Property Handler No Property Handler Microsoft Property System 7.00.9600.16384 (winblue_rtm.130821-1623) Windows® Search Microsoft Corporation No No No No No No C:\WINDOWS\system32\propsys.dll {97e467b4-98c6-4f19-9588-161b7773d6f6} 2/12/2014 7:49:06 AM 8/22/2013 11:37:50 AM Yes A 1,202,888 No
    Another revealing option in Shell Extension Viewer is to enable viewing of 32 bit handlers (as most Office installs are 32 bit). To do this, click on Options, then on "Show 32 bit Shell Extensions"'

    If you can locate the above handler, disable it and see if that helps.

    What about the smiley's and highlighting programs - what do you have installed that's similar to this?

    Have you obtained ALL of the Windows Updates? I'm not too concerned about the Windows 8.1 Update 1 that was released today - but I am concerned about you only having 30 updates in the previous report that you submitted. If uncertain, run systeminfo from an elevated (Run as administrator) command prompt and look at the number of hotfixes.

    Finally, you stated that you have disabled non-Microsoft shell extensions. There's an important (and confusing) distinction here between non-Microsoft and non-Windows. Windows File Protection protects Windows files - not necessarily Microsoft files (in other words, Windows files are a sub-set of Microsoft files). Additionally, Windows Update updates Windows files and not Microsoft files.

    Exactly which files are protected is difficult to say (I haven't looked at a list since the XP days) - but there are files that are protected that aren't Windows files - yet Microsoft has seen fit to install/support/update them.
    Some examples are processor drivers and storage controller drivers.

    Then add to this the fact that Windows Update will provide 3rd party driver updates (not certified by Microsoft) and that they'll provide other non-protected updates via Microsoft Update - and it's a mess that's very difficult to asses.

    You could attempt to capture a Process Explorer trace of the event surrounding an explorer.exe crash. But even if the trace actually contains the offending event, the log is so huge that it's difficult to figure out exactly where the problem stems from. Others who are more experienced with Process Explorer may be able to reduce the log size by selecting the proper filters - I'm not that familiar with it myself, so I can't be much help there.
      My System SpecsSystem Spec

Page 1 of 2 12 LastLast
EXPLORER.EXE crashes constantly in SHELL32.DLL
Related Threads
I recently installed 8 and eventually 8.1. Every 5-10 mins no matter what i'm doing, explorer freezes. THe only thing i can click on is the taskbar. The bar eventually crashes after a few clicks and then explorer restarts, but with a few of my icons near the clock missing. I then have to log...
Every time I load IE11, I get the following error: 'Internet Explorer has stopped working', and then another pop up to close the program. This has recently started happening, and from my knowledge, nothing has changed, and I haven't installed anything. I can't get to the tools/settings as the pop...
KERNEL_SECURITY_CHECK_FAILURE, it happens while i try to play games on Steam and also while watching Youtube videos. Really, it happens a lot while i just do everyday task. I don't know what the problem is but I have the dump files. I did RAM test and I downloaded all drivers; everything is up to...
I wasn't sure what to name this thread because everything sounded so vague. But basically my icons are fubar! :'( More detail: Current Setup/programs that affected this issue: RDP Stardock Fences 2 Super Street Fighter 4 Arcade Edition Basically I RDPed into my home PC, tried to play...
Howdy. In about every 10 minutes I get this pop-up saying ThumbnailExtractionHost.exe has stopped working Problem signature: Problem Event Name: APPCRASH Application Name: ThumbnailExtractionHost.exe Application Version: 6.2.9200.16384
Chrome Constantly Crashes Computer in BSOD Crashes and Debugging
Hello everyone. Since I have gotten a new computer, with Windows 8 64x, when problems come up, I don't know how to fix them. Being a constant user of Chrome, I had gotten accustomed to using the browser, and for the first two days, it worked fine. After that, the computer randomly reboots, often...
I have noticed that the weather app crashes every time that I try it now, and other apps crash sporadically. Just wondering if anybody is witnessing the same troubles.
Eight Forums Android App Eight Forums IOS App Follow us on Facebook