Windows 8 and 8.1 Forums

Frequent BAD_POOL_HEADER BDOs in 8.1

  1. #1

    Posts : 2
    Windows 8.1

    Frequent BAD_POOL_HEADER BDOs in 8.1

    I'm running Windows 8.1, and for the past few days I've been getting a lot of BSODs with the error BAD_POOL_HEADER

    Nothing specific seems to be causing the BSOD, I'll just be browsing the internet, nothing intensive and I'll get one. Other times I could just be at the desktop and get one. Sometimes I'll get one as soon as I boot up, other times it could take 1+ hour.

    I've already ran memtest with no errors. I've scanned for viruses/malware. I even cleaned out my tower for dust and dirt.

    I'm not sure what else to do, I've researched BAD_POOL_HEADER and nothing works

    Any help would really be appreaciated

      My System SpecsSystem Spec

  2. #2

    Posts : 660
    windows 8.1

    All your dumpfiles are probably caused by athuw8x.sys driver.

    BugCheck 19, {20, ffffe0000204da70, ffffe0000204dbf0, 4180003}
    *** WARNING: Unable to verify timestamp for athuw8x.sys
    *** ERROR: Module load completed but symbols could not be loaded for athuw8x.sys
    Probably caused by : athuw8x.sys ( athuw8x+44e7 )
    Followup: MachineOwner
    1: kd> !analyze -v
    *                                                                             *
    *                        Bugcheck Analysis                                    *
    *                                                                             *
    The pool is already corrupt at the time of the current request.
    This may or may not be due to the caller.
    The internal pool links must be walked to figure out a possible cause of
    the problem, and then special pool applied to the suspect tags or the driver
    verifier to a suspect driver.
    Arg1: 0000000000000020, a pool block header size is corrupt.
    Arg2: ffffe0000204da70, The pool entry we were looking for within the page.
    Arg3: ffffe0000204dbf0, The next pool entry.
    Arg4: 0000000004180003, (reserved)
    Debugging Details:
    BUGCHECK_STR:  0x19_20
    POOL_ADDRESS: GetPointerFromAddress: unable to read from fffff802421cf150
    GetUlongFromAddress: unable to read from fffff802421cf208
     ffffe0000204da70 Nonpaged pool
    PROCESS_NAME:  System
    ANALYSIS_VERSION: 6.3.9600.16384 (debuggers(dbg).130821-1623) amd64fre
    LAST_CONTROL_TRANSFER:  from fffff802421144cf to fffff80241fcfca0
    ffffd000`23762118 fffff802`421144cf : 00000000`00000019 00000000`00000020 ffffe000`0204da70 ffffe000`0204dbf0 : nt!KeBugCheckEx
    ffffd000`23762120 fffff800`00a92b65 : ffffe000`02e61800 ffffe000`01891900 fffff800`035ded10 00000000`4d687441 : nt!ExFreePoolWithTag+0x11ff
    ffffd000`237621f0 fffff800`032664e7 : ffffe000`0204da80 00000000`00000000 ffff1f4c`905a0eb4 fffff800`0343f841 : ndis!NdisFreeMemory+0x15
    ffffd000`23762220 ffffe000`0204da80 : 00000000`00000000 ffff1f4c`905a0eb4 fffff800`0343f841 ffffe000`0204da80 : athuw8x+0x44e7
    ffffd000`23762228 00000000`00000000 : ffff1f4c`905a0eb4 fffff800`0343f841 ffffe000`0204da80 00000000`0000013e : 0xffffe000`0204da80
    fffff800`032664e7 ??              ???
    SYMBOL_NAME:  athuw8x+44e7
    FOLLOWUP_NAME:  MachineOwner
    MODULE_NAME: athuw8x
    IMAGE_NAME:  athuw8x.sys
    FAILURE_BUCKET_ID:  0x19_20_athuw8x+44e7
    BUCKET_ID:  0x19_20_athuw8x+44e7
    FAILURE_ID_HASH_STRING:  km:0x19_20_athuw8x+44e7
    FAILURE_ID_HASH:  {5d499ba4-9ca2-ad8e-3086-6dd09e7dbf4c}
    Followup: MachineOwner

    This drivers is from a Atheros wireless network adapter.

    Usasma (BSODexpert) says:

    I do not recommend using wireless USBnetwork devices. Especially in Win7/Windows 8/8.1 systems.
    These wireless USB devices have many issues with Win7 and later - using Vistadrivers with them is almost sure to cause a BSOD.
    Should you want to keep using these devices, be sure to have Win7/Windows 8/8.1drivers -
    DO NOT use Vista drivers!!!
    An installable wireless PCI/PCIe card that's plugged into your motherboard ismuch more robust, reliable, and powerful

    It appears there are no windows 8.1 drivers for this device and it causes many BSOD.

    Advice; change or buy a compatible wireless network adapter.

    Please update these older drivers. Links areincluded to assist in looking up the source of the drivers. If unable to find an update, please remove (un-install) the program responsible for that driver.DO NOT manually delete/rename the driver as it may make the system unbootable!:

    HECIx64 Oct 20 01:33:43 2010 (4cbe2ad7) 0001b15f HECIx64.sys

    Driver Description:
    Intel Management Engine Interface
    Driver Update Site:

    GEARAspiWDM Thu May 03 21:56:17 2012 (4fa2e2e1) 00008963 GEARAspiWDM.sys

    Driver Description: CD-ROM Class Filter Driver by Gear Software.
    Also comes with iTunes
    Driver Update Site:

    athuw8x Mon Oct 15 13:08:55 2012 (507beec7) 003956bb None athuw8x.sys

    see notice above

    lvbflt64 Tue Oct 23 04:10:38 2012 (5085fc9e) 0000dcdf lvbflt64.sys

    Driver Description: Logitech Webcam Software driver
    Driver Update Site: Logitech Support - Downloads, Manuals, FAQs & More

    lvrs64 Tue Oct 23 04:11:24 2012 (5085fccc) 00058cf8 lvrs64.sys

    Driver Description: Logitech Camera driver
    Driver Update Site: Logitech Support - Downloads, Manuals, FAQs & More

    lvuvc64 Tue Oct 23 04:12:08 2012 (5085fcf8) 004912c7 lvuvc64.sys

    Driver Description: Logitech USB Video Class Driver (WebCam)
    Driver Update Site: Logitech Support - Downloads, Manuals, FAQs & More

    Last edited by lifetec; 01 Apr 2014 at 14:45.
      My System SpecsSystem Spec

  3. #3

    Posts : 2
    Windows 8.1

    I've been using this card with the same driver for months on 8.1, any specific reason it would cause errors now? Unfortunate as I've never had luck with PCI network cards
      My System SpecsSystem Spec

  4. #4

    Posts : 660
    windows 8.1

    No, could be other software installed lately or your Antivrus/security Software reacts on not compatible drivers or the driver is corrupted somehow or Hardware faiillure related or ?.

    If the drivers are corrupted you can try to uninstall the driver completly from your system with for instance REVOuninstaller and reinstall them and maybe the driver will work again.
      My System SpecsSystem Spec

Frequent BAD_POOL_HEADER BDOs in 8.1
Related Threads
BDOS on startup - ERROR 0xc0000001 in BSOD Crashes and Debugging
I apologise for the typo in the title, BSOD not bdos :/ I currently run windows 8.1. The computer is an Asus S400C. On startup it says preparing automatic repair then after a few seconds takes me to the BSOD where It says: Recovery Your pc couldn't start properly after multiple tries, the...
BDOS when idle in BSOD Crashes and Debugging
I get BDOS like everyday on this computer when on idle. Please help.
BDOS - Win8 - 64bit in BSOD Crashes and Debugging
Dear, I have a new pc, it has 3month it's a: i7-3820 CPU - 16GB RAM sometime I had blue screen, i can copy paste here, the dump result: 041813-9328-01.dmp 18.04.2013 23:20:07 CRITICAL_PROCESS_DIED 0x000000ef fffffa80`0cb41080 00000000`00000000 00000000`00000000 ...
No BDOS but constant crashes and boot problems in BSOD Crashes and Debugging
No BDOS as the computer crashes, turns off the monitor, HDDs stop, and it just stays this way. My computer periodically crashes and won't boot -- more specificially, it'll post, show the Windows 8 logo then the screen turns off, the keyboard is still backlit, but the HDD stops and it just stays...
system BSODs fairly frequently, I think usually while watching youtube but sometimes when switching from remote desktop connection to local login. dump seems to point to graphics driver but I've tried updating a few times already. I have also tried the disk tests provided by the vendors, as well as...
BDOS crash my laptop in BSOD Crashes and Debugging
Help me, Thank you!.
Bad_pool_header in Drivers & Hardware
what the heck is this i experienced this while installing my drivers and applications to my laptop excluding intel vga
Eight Forums Android App Eight Forums IOS App Follow us on Facebook