Windows 8 and 8.1 Forums

[BSoD] Windows 8.1 - On Power Down (Restart or Shutdown)

  1. #1

    Posts : 21
    Windows 8.1 Pro w/ Media Center

    [BSoD] Windows 8.1 - On Power Down (Restart or Shutdown)

    **EDIT: Included SF Debug zip**

    System Specs:
    CPU: i7-920 [Cooled via Corsair H-series liquid cooling]
    RAM: 12GB Corsair Dominator [Fully tested; 100% pass]
    GPU: Geforce GTX 670 4GB [x2; SLI]
    OS: Windows 8.1 w/ lastest drivers from Windows Update
    Main Drive: Intel 510 120GB SSD

    This actually started with Windows 8 at some point. I performed a fresh install of Win8 on a Win7 machine (part of that Win8 Pro for $20).

    I had hoped that 8.1 might fix the issue if there was a 'core' driver that had been corrupted...sadly it did not.
    Below is the Kernel Memory Dump, this is the same result for every BSoD I get. And the BSoD isn't on every power down...sometimes the machine will sit at 'Shutting Down' for a few seconds (less than 10; <3 SSD) or last over half a minute before finally powering down. The other's upwards to 1 minute and the "unhappy face".
    Microsoft (R) Windows Debugger Version 6.2.9200.20512 AMD64
    Copyright (c) Microsoft Corporation. All rights reserved.
    Loading Dump File [E:\System Data\MEMORY.DMP]
    Kernel Bitmap Dump File: Only kernel address space is available
    Symbol search path is:
    Executable search path is: 
    Windows 8 Kernel Version 9600 MP (8 procs) Free x64
    Product: WinNt, suite: TerminalServer SingleUserTS
    Built by: 9600.16452.amd64fre.winblue_gdr.131030-1505
    Machine Name:
    Kernel base = 0xfffff803`dbe74000 PsLoadedModuleList = 0xfffff803`dc138990
    Debug session time: Fri Feb  7 02:04:18.080 2014 (UTC - 5:00)
    System Uptime: 0 days 22:42:09.400
    Loading Kernel Symbols
    Loading User Symbols
    Loading unloaded module list
    *                                                                             *
    *                        Bugcheck Analysis                                    *
    *                                                                             *
    Use !analyze -v to get detailed debugging information.
    BugCheck 9F, {3, ffffe00001f1f830, fffff803dd9ef980, ffffe00001f51010}
    Probably caused by : pci.sys
    Followup: MachineOwner
    0: kd> !analyze -v
    *                                                                             *
    *                        Bugcheck Analysis                                    *
    *                                                                             *
    A driver has failed to complete a power IRP within a specific time (usually 10 minutes).
    Arg1: 0000000000000003, A device object has been blocking an Irp for too long a time
    Arg2: ffffe00001f1f830, Physical Device Object of the stack
    Arg3: fffff803dd9ef980, nt!TRIAGE_9F_POWER on Win7, otherwise the Functional Device Object of the stack
    Arg4: ffffe00001f51010, The blocked IRP
    Debugging Details:
    DRIVER_OBJECT: ffffe00000fca060
    IMAGE_NAME:  pci.sys
    MODULE_NAME: pci
    FAULTING_MODULE: fffff8000053e000 pci
    PROCESS_NAME:  System
    TAG_NOT_DEFINED_c000000f:  FFFFF803DD9F6FB0
    fffff803`dd9ef948 fffff803`dc06b1a6 : 00000000`0000009f 00000000`00000003 ffffe000`01f1f830 fffff803`dd9ef980 : nt!KeBugCheckEx
    fffff803`dd9ef950 fffff803`dc06b0c6 : ffffe000`01fb5f08 ffffe000`08478250 00000000`00000004 00000000`00000000 : nt!PopIrpWatchdogBugcheck+0xde
    fffff803`dd9ef9b0 fffff803`dbf21f64 : ffffe000`01fb5f40 00000000`00000001 fffff803`dd9efa79 00000000`00000002 : nt!PopIrpWatchdog+0x32
    fffff803`dd9efa00 fffff803`dbf22478 : 00000000`00000000 ffffe000`06d88700 fffff803`dc162180 fffff803`dc1668a0 : nt!KiProcessExpiredTimerList+0x1d8
    fffff803`dd9efae0 fffff803`dbf7e478 : fffff803`dc162180 00000000`002c9779 00000000`002f92a1 00000000`002f92b9 : nt!KiExpireTimerTable+0x218
    fffff803`dd9efb80 fffff803`dbeceabc : ffffe000`06d884c0 00000000`00000001 fffff803`dd9efd50 fffff803`dbec9fbc : nt!KiTimerExpiration+0x148
    fffff803`dd9efc30 fffff803`dbfc57ea : fffff803`dc162180 fffff803`dc162180 00000000`001a3fe0 fffff803`dc1baa80 : nt!KiRetireDpcList+0x19c
    fffff803`dd9efda0 00000000`00000000 : fffff803`dd9f0000 fffff803`dd9ea000 00000000`00000000 00000000`00000000 : nt!KiIdleLoop+0x5a
    FOLLOWUP_NAME:  MachineOwner
    FAILURE_BUCKET_ID:  0x9F_3_IMAGE_pci.sys
    BUCKET_ID:  0x9F_3_IMAGE_pci.sys
    Followup: MachineOwner
    0: kd> !drvobj ffffe00000fca060 f
    Driver object (ffffe00000fca060) is for:
    Driver Extension List: (id , addr)
    Device Object list:
    ffffe00001f6d270  ffffe00001f6e060  ffffe00001f1e060  ffffe00001f1f830
    ffffe00001f21060  ffffe00001f23060  ffffe00001f24800  ffffe00001f26880
    ffffe00001f26060  ffffe00001f2e8e0  ffffe00001f2f6f0  ffffe00001f2f040
    ffffe00001f40040  ffffe00001f41ba0  ffffe00001f42ba0  ffffe00001f438e0
    ffffe00001f446f0  ffffe00001f44040  ffffe00001f1d880  ffffe00001f1d060
    ffffe00000ffd880  ffffe00000ffd060  ffffe00000ffe880  ffffe00000ffe060
    ffffe00000fff880  ffffe00000fff060  ffffe00000fcd880  ffffe00000fcd060
    ffffe00000fbc880  ffffe00000fbc060  ffffe00000fbd880  ffffe00000fbd060
    ffffe00000fbe880  ffffe00000fbe060  ffffe00000fbf880  ffffe00000fbf060
    ffffe00000fc0880  ffffe00000fc0060  ffffe00000fc1880  ffffe00000fc1060
    ffffe00000fc2880  ffffe00000fc2060  ffffe00000fc3880  ffffe00000fc3060
    DriverEntry:   fffff80000545910    pci!GsDriverEntry
    DriverStartIo: 00000000    
    DriverUnload:  fffff8000057df80    pci!PciDriverUnload
    AddDevice:     fffff8000056c1f0    pci!PciAddDevice
    Dispatch routines:
    [00] IRP_MJ_CREATE                      fffff803dbf6d904    nt!IopInvalidDeviceRequest
    [01] IRP_MJ_CREATE_NAMED_PIPE           fffff803dbf6d904    nt!IopInvalidDeviceRequest
    [02] IRP_MJ_CLOSE                       fffff803dbf6d904    nt!IopInvalidDeviceRequest
    [03] IRP_MJ_READ                        fffff803dbf6d904    nt!IopInvalidDeviceRequest
    [04] IRP_MJ_WRITE                       fffff803dbf6d904    nt!IopInvalidDeviceRequest
    [05] IRP_MJ_QUERY_INFORMATION           fffff803dbf6d904    nt!IopInvalidDeviceRequest
    [06] IRP_MJ_SET_INFORMATION             fffff803dbf6d904    nt!IopInvalidDeviceRequest
    [07] IRP_MJ_QUERY_EA                    fffff803dbf6d904    nt!IopInvalidDeviceRequest
    [08] IRP_MJ_SET_EA                      fffff803dbf6d904    nt!IopInvalidDeviceRequest
    [09] IRP_MJ_FLUSH_BUFFERS               fffff803dbf6d904    nt!IopInvalidDeviceRequest
    [0a] IRP_MJ_QUERY_VOLUME_INFORMATION    fffff803dbf6d904    nt!IopInvalidDeviceRequest
    [0b] IRP_MJ_SET_VOLUME_INFORMATION      fffff803dbf6d904    nt!IopInvalidDeviceRequest
    [0c] IRP_MJ_DIRECTORY_CONTROL           fffff803dbf6d904    nt!IopInvalidDeviceRequest
    [0d] IRP_MJ_FILE_SYSTEM_CONTROL         fffff803dbf6d904    nt!IopInvalidDeviceRequest
    [0e] IRP_MJ_DEVICE_CONTROL              fffff800005402a0    pci!PciDispatchDeviceControl
    [0f] IRP_MJ_INTERNAL_DEVICE_CONTROL     fffff803dbf6d904    nt!IopInvalidDeviceRequest
    [10] IRP_MJ_SHUTDOWN                    fffff803dbf6d904    nt!IopInvalidDeviceRequest
    [11] IRP_MJ_LOCK_CONTROL                fffff803dbf6d904    nt!IopInvalidDeviceRequest
    [12] IRP_MJ_CLEANUP                     fffff803dbf6d904    nt!IopInvalidDeviceRequest
    [13] IRP_MJ_CREATE_MAILSLOT             fffff803dbf6d904    nt!IopInvalidDeviceRequest
    [14] IRP_MJ_QUERY_SECURITY              fffff803dbf6d904    nt!IopInvalidDeviceRequest
    [15] IRP_MJ_SET_SECURITY                fffff803dbf6d904    nt!IopInvalidDeviceRequest
    [16] IRP_MJ_POWER                       fffff8000053f5c0    pci!PciDispatchPnpPower
    [17] IRP_MJ_SYSTEM_CONTROL              fffff80000563be8    pci!PciDispatchSystemControl
    [18] IRP_MJ_DEVICE_CHANGE               fffff803dbf6d904    nt!IopInvalidDeviceRequest
    [19] IRP_MJ_QUERY_QUOTA                 fffff803dbf6d904    nt!IopInvalidDeviceRequest
    [1a] IRP_MJ_SET_QUOTA                   fffff803dbf6d904    nt!IopInvalidDeviceRequest
    [1b] IRP_MJ_PNP                         fffff8000053f5c0    pci!PciDispatchPnpPower
    I've tried updating the SSD driver: Nope
    I've tried running shipped-with SSD Driver: Nope
    I've tried updating Video Driver: Nope
    I've tried running shipped-with Video Driver: Nope

    I'm not really sure what other steps I can take, besides the obvious fresh install, to rectify this.
    Last edited by illutian; 07 Feb 2014 at 18:22.

      My System SpecsSystem Spec

  2. #2

    Posts : 1,883
      My System SpecsSystem Spec

  3. #3

    Posts : 21
    Windows 8.1 Pro w/ Media Center

    Quote Originally Posted by MasterChief View Post
    Done. Been awhile, I forgot what all was asked of in a BSoD post :P
      My System SpecsSystem Spec

  4. #4

    Posts : 1,883

    Uninstall Realtemp:

        ImageSize:  0000C000
    0: kd> lmvm winring0x64
    start             end                 module name
    fffff800`03841000 fffff800`03848000   WinRing0x64   (deferred)             
        Image path: \??\E:\System Data\RealTemp\WinRing0x64.sys
        Image name: WinRing0x64.sys
        Timestamp:        Sat Jul 26 09:29:37 2008 (488B26C1)
        CheckSum:         00011908
        ImageSize:        00007000
        Translations:     0000.04b0 0000.04e4 0409.04b0 0409.04e4
    Delete the following driver, then open Regedit and delete its subkey found at the following location shown after the code below:

    0: kd> lmvm  PxHlpa64
    start             end                 module name
    fffff800`008ed000 fffff800`008f91a0   PxHlpa64   (deferred)             
        Image path: \SystemRoot\System32\Drivers\PxHlpa64.sys
        Image name: PxHlpa64.sys
        Timestamp:        Tue Apr 24 13:26:29 2012 (4F96E245)
        CheckSum:         0000E1AD
        ImageSize:        0000C1A0
        Translations:     0000.04b0 0000.04e4 0409.04b0 0409.04e4


    Then follow this post to fix the DVD drive: DVD ROM not reading any disc

    If still necessary, see about removing this hardware and driver, to test.
    RAMDiskVE RAMDiskVE.sys Tue Dec 31 11:08:35 2013 (52C2EC03)

    Install the storage driver from

    Name    Intel(R) ICH10 Family 6 Port SATA AHCI Controller - 3A22
    Manufacturer    Intel
    Status    OK
    PNP Device ID    PCI\VEN_8086&DEV_3A22&SUBSYS_3A208086&REV_00\3&2411E6FE&0&FA
    I/O Port    0x0000F900-0x0000F907
    I/O Port    0x0000F800-0x0000F803
    I/O Port    0x0000F700-0x0000F707
    I/O Port    0x0000F600-0x0000F603
    I/O Port    0x0000F500-0x0000F51F
    Memory Address    0xF3FFC000-0xF3FFC7FF
    IRQ Channel    IRQ 19
    Driver    c:\windows\system32\drivers\storahci.sys (6.3.9600.16384, 105.34 KB (107,872 bytes), 8/22/2013 7:40 AM)
    Install J-Micron storage driver:

    Name    Standard SATA AHCI Controller
    Manufacturer    Standard SATA AHCI Controller
    Status    OK
    PNP Device ID    PCI\VEN_197B&DEV_2363&SUBSYS_100C3842&REV_02\4&2A72BAF0&0&00E1
    Memory Address    0xF3CFE000-0xF3CFFFFF
    IRQ Channel    IRQ 17
    Driver    c:\windows\system32\drivers\storahci.sys (6.3.9600.16384, 105.34 KB (107,872 bytes), 8/22/2013 7:40 AM)
    Name    Standard Dual Channel PCI IDE Controller
    Manufacturer    (Standard IDE ATA/ATAPI controllers)
    Status    OK
    PNP Device ID    PCI\VEN_197B&DEV_2363&SUBSYS_100C3842&REV_02\4&2A72BAF0&0&01E1
    I/O Port    0x0000AF00-0x0000AF07
    I/O Port    0x0000AE00-0x0000AE03
    I/O Port    0x0000AD00-0x0000AD07
    I/O Port    0x0000AC00-0x0000AC03
    I/O Port    0x0000AB00-0x0000AB0F
    IRQ Channel    IRQ 18
    Driver    c:\windows\system32\drivers\pciide.sys (6.3.9600.16384, 14.34 KB (14,688 bytes), 8/22/2013 8:22 AM)
      My System SpecsSystem Spec

  5. #5

    Posts : 21
    Windows 8.1 Pro w/ Media Center

    Double checking:

    For Intel we're talking about the Intel® Rapid Storage Technology (Intel® RST) RAID Driver


    I don't have an issue with the DVD drive not reading disc.

    I'm hesitant about deleting drivers that appear to have been shipped with the Windows 8 installation. (I've never installed Roxio or Rovi)

    And I gotta use JMicron's driver. Hope it works with Windows 8...they still don't say their driver supports Window 7
      My System SpecsSystem Spec

  6. #6

    Posts : 1,883

    Quote Originally Posted by illutian View Post
    I don't have an issue with the DVD drive not reading disc.
    You would have, if you followed instructions needed.
      My System SpecsSystem Spec

  7. #7

    Posts : 21
    Windows 8.1 Pro w/ Media Center

    Hmm, I see...I think.

    Deleting that driver breaks the DVD.

    And I'm a fool for not saying my Mobo.

    MOBO: EVGA X58 Classified

    so...Intel's latest drivers won't work for me.

    ...found, Intel's latest drivers that still support the X58
    Last edited by illutian; 08 Feb 2014 at 00:02.
      My System SpecsSystem Spec

  8. #8

    Posts : 21
    Windows 8.1 Pro w/ Media Center


    I haven't had any BSoD, but then I've only initiated a power down sequence twice.

    This last one still took a fairly long time to power down, roughly 35 seconds....on a SSD.

    I'm not sure if the BSoD error code, or lack of, was stated in the Windows Debugger. But it's a Driver Power State Failure; with the PCI.sys being the likely culprit.

    Some additional info:

    I highly doubt the RAMdisk is causing this as I've had this issue for well over 8 months. And the RAMdisk was added last week (as of this post).
      My System SpecsSystem Spec

[BSoD] Windows 8.1 - On Power Down (Restart or Shutdown)
Related Threads
Hi guys, I'm having big trouble with my lenovo laptop. At first I'm always getting a BSOD DPSF (ntoskrnl.exe) when restarting or shutting down the laptop. Second, when I try to install/uninstall drivers or just scan for hardware changes nothing happens. I waited 3 hours the most and it...
Hello My computer (Lenovo Thinkpad Helix 3679CTO) is a month old and a bunch of the drivers have gone out of whack. I believe this is my fault due to force shutting down while the computer was updating. I am trying to reset the computer to factory settings but my computer is incapable of...
I updated to 8.1 today. Now I am facing BSOD on shutdown and very long boot time. I am unable to install nVidia driver properly as it gets stuck. Same goes for updating Intel RST. Unable to open safe mode as that requires a restart. (Shift+F8 doesn't work) msinfo get stuck at Printing. Unable...
Hi I bought my laptop about 3 months ago i got BSOD relating event 41 task 63 kernel power many times and got twice BSOD today it really made me frustrated please help
I'm hoping to get a little bit of help with my BSOD error. I've read through some posts with similar errors and I've done my best to try some of the basic solutions for this (i.e., update drivers) but can't seem to pin down the actual problem. I woke up this morning and I had a Driver Power...
every time I shut down the computer there is a page fault in non paged area error, and then the computer restarts love to know why. any help would be great thanks :D
Solved BSOD after regular shutdown and restart in BSOD Crashes and Debugging
Hi all - whenever I shut down my Alienware M14X, all seems fine. However, when I turn it on again the next time, I get an "IRQ is less than or equal to" error. The laptop crashes, restarts, and works again, until I shut it down and start it up - and it all happens again. Dump files attached -...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook