Windows 8 and 8.1 Forums

BSOD from 0 to 20 times a day, since upgrading Laptop

  1. #11

    Posts : 15
    Windows 8.1

    I've run both memtests v4 and v5 without any issues. So I reinstalled from scratch (again) but with UEFI enabled this time. Unfortunately I couldn't find a Windows 8 ISO, so i'm still running 8.1. Damn manufacturers for not providing installation disks while the recovery DVD did not boot at all.

    However this time I've not installed the bridged network from VirtualBox as it seemed to cause the issue. I've seen report that it was the culprit amongst other things and you confirmed it with your analysis of the dumps. Not sure what is the purpose of this driver as the VM and Android emulators are working properly and are able to connect to the Internet!?

    I've installed all up-to-date drivers, one by one and rebooted every time it asked, then installed Windows updates and then my softwares.

    So far so good since this morning, but I'll report back in a week if it is stable. The Ubuntu VM actually crashed for the first time, but it didn't create a BSOD this time.

    Thanks Anshad for your insight and prompt help on this matter!

    And more importantly, Happy New Year!

      My System SpecsSystem Spec

  2. #12

    Posts : 15
    Windows 8.1

    BSODs with Verifier enabled (default settings)

    I've run with Verifier enabled and today's BSODs are included. Note the first 2 BSODs were running without (one from yesterday and one early today).

    I used dumpchk on last build, but it only gives me the faulty driver: NVidia. Any further info can be retrieved from that? Such as what failure the Verifier discovered?

    Got multiple BSODs after rebooting always from Verifier minutes after booting, whereas I ran all morning without any issues!? I was only running dumpchk with later BSODs!

    I disabled NVidia GFX (laptop has also an Intel 4600!) and Verifier to be able to use the laptop.
      My System SpecsSystem Spec

  3. #13


    So if i understand correctly, the system worked fine for almost one day without any crashes when you re-installed the OS. Then BSOD started again after installing the softwares. Can you remember when the BSOD started (after installing a particular software , ie VBox or some other app) ?.

    None of the Verifier enabled dumps directly blames Nvidia driver. However it is the only driver repeatedly seen on the raw call stack. So i would suggest checking for an updates version from NVIDIA Driver Downloads - Automatically Detect NVIDIA Products

    Also how many passes completed with Memtest before you stopped it ?.
      My System SpecsSystem Spec

  4. #14

    Posts : 15
    Windows 8.1

    Actually I reinstalled everything yesterday. Worked fine, had the VM crash onces without BSOD, then continued working with VBoxes all over, Eclipse. A BSOD yesterday while unattended. Then I worked this morning without any issues. I probably enabled Verifier after yesterday's BSOD.

    Everything was fine until the first BSOD occured end of the morning. And from now on, I can not activate the NVidia driver without an nearly immediate BSOD created by Verifier.

    I've submitted the whole file to NVidia too, in case they can work on it.

    I disabled Verifier, but didn't reboot and updated NVidia with latest beta version of their driver. The installation didn't finish but nearly as soon as the NVidia driver was reactivated, got a BSOD. Upon reboot (thinking Verifier was disabled) I proceeded with my work without VBoxes at all. Got another BSOD from Verifier!? Disabled again, I'm about to reboot to get it disabled (for good hopefully).

    I'll try to run without NVidia driver for a few days, but I'll need it soon to work on some videos (use it for GPU calculations only, no games).

    In previous experiences, the BSODs may not occur for a couple of days, but then all of a sudden it starts happening a few times in a row, then stops for another bunch of hours or days... I haven't "detected" any particular trend actually. Whether I use VBoxes (or VMWare previously) or uninstall them, BSODs will eventually reoccur.

    I probably reinstalled VBox after the first BSOD, thinking what the heck it crashes with or without it?! And I really need to run those VBoxes for my work.

    But honestly I'm not sure of anything any more.

    Anyway, I'll run one more tests, uninstall VirtualBox, enable Verifier and the NVidia driver again to see what happens. However those last BSODs occured without VBox running (but maybe some VBox driver were still loaded?).
      My System SpecsSystem Spec

  5. #15

    Posts : 15
    Windows 8.1

    Here are the last 2 BSODs dumps without VirtualBox installed. First one with Verifier, second without. Both BSODS within minutes after boot.

    Again, disabled NVidia driver so that I can use the computer. Anything useful in those dumps I could share with NVidia or use to disable specific components of the NVidia driver? Should I also send those 2 dumps to NVidia or the last one posted here are good enough?

    Using dumpchk I get only this:

    #1 with Verifier
    BugCheck C4, {f6, 2e8, ffffe00002ad5080, fffff8000677fa6d}
    Probably caused by : nvlddmkm.sys ( nvlddmkm+9aa6d )

    #2 without Verifier
    BugCheck A, {ffffe008027cd172, 2, 0, fffff802c9f9ba4d}
    Probably caused by : ntkrnlmp.exe ( nt! ?? ::FNODOBFM::`string'+2b8ad )

    Is that all we can get from those dumps?

    Thanks for your help and attention. And sorry for the many questions, I'm a developer however I'm not sure what information can best help you or Nvidia (to help me obviously).
      My System SpecsSystem Spec

  6. #16

    Posts : 15
    Windows 8.1

    Just a quick note on VirtualBox, I no longer install its Network Bridge driver, which was the culprit of some of the BSODs and has been reported to cause issues on many others web sites. I've been using it since my last post and had no issues so far, running 3 Android VBs and one Ubuntu. NVidia driver is still disabled.
      My System SpecsSystem Spec

  7. #17


    Nvidia seems to be blamed only on the Verifier enabled dumps. So far Nvidia is not blamed in any of the usual crash dumps created by Windows itself. So i think it is better to turn off the Verifier and let Windows to create normal crash dumps which may help us identifying a pattern.

    In fact, there is a pattern can be seen in the last crashes. All the normal crash dumps are bugcheck 0xA and there seems to be some sort of network activities going on every time. For your information, here is the edited version of last crash dump.

    BugCheck A, {ffffe008027cd172, 2, 0, fffff802c9f9ba4d}
    Probably caused by : ntkrnlmp.exe ( nt! ?? ::FNODOBFM::`string'+2b8ad )
    kd> dps ffffd00020b01000 ffffd00020b07000
    ffffd000`20b06790  ffffe008`027cd172
    ffffd000`20b06798  fffff800`0259d9eeUnable to load image athwbx.sys, Win32 error 0n2
    *** WARNING: Unable to verify timestamp for athwbx.sys
    *** ERROR: Module load completed but symbols could not be loaded for athwbx.sys
    ffffd000`20b067a0  ffffe000`05142138
    ffffd000`20b067a8  ffffe000`000003e8
    ffffd000`20b067b0  00000000`00000003
    ffffd000`20b067b8  fffff802`ca5989d5 hal!HalpApicTimerArm+0x41
    ffffd000`20b067c0  ffffffff`00001000
    ffffd000`20b067c8  ffffe000`00459010
    ffffd000`20b067d0  ffffd000`20b06800

    Atheroz wireless driver is present in all the last crash dumps. Before, it was the "VBox" networking driver and the "Atheroz" WLAN driver. Perhaps it might be a user mode network related program which is causing the crashes. So i would suggest uninstalling all network related programs as a test ( download managers, torrent clients , IP Camera software etc).

    Also it seems there are four memory sticks in your system and they are not the same. I would suggest removing the two 4GB sticks with different part numbers and only use the two 8GB sticks (which are same part numbers) to rule out the possibilities of compatibility issues.
      My System SpecsSystem Spec

  8. #18

    Posts : 15
    Windows 8.1

    I originally wanted to replace the Atheros card with an Intel 6300 card at some point in time, but tested an USB TrendNet adapter first and issue persisted.

    I don't have any network related program running or installed, no download manager, no torrent or IP Camera in this last reinstall.

    I'll start by removing the 2x4GB memory sticks just to be sure, however they are all the same speed, but not sure if they have the same CLKs, will check at the same time. And the memtests that took hours to complete did not reveal any issues. So is it really worth removing them?

    What I don't understand is why by just enabled NVidia driver there's this BSOD about Atheros driver going on within minutes!? Could it be the Nvidia driver/software doing some bad networking activities. Since I've disabled it, I've not experienced any further issues!

    And if it's NVidia software doing bad network activities, it could be any app for that matter, even simply browsing the web could lead to this!! Right?

    Can you help me get those stack trace locally, I tried running kd, but it fails with a win32 error 0n2, "file not found" trying to open \\.\com1 ?
      My System SpecsSystem Spec

  9. #19


    I don't use KD (command line debugger). What i regularly use is Windbg (same but with GUI) . To dump the raw stack, we need to know the base and limit pointers of the stack. It can be obtained from the thread info by executing !thread command. The below example will illustrate it for you. This is one of the earlier crash dump i randomly picked.

    *                                                                             *
    *                        Bugcheck Analysis                                    *
    *                                                                             *
    Use !analyze -v to get detailed debugging information.
    BugCheck 1E, {ffffffffc0000005, fffff8038126751f, 1, 28c}
    Probably caused by : memory_corruption
    Followup: memory_corruption
    1: kd> !thread
    GetPointerFromAddress: unable to read from fffff8038155d000
    THREAD ffffd000201f3340  Cid 0000.0000  Teb: 0000000000000000 Win32Thread: 0000000000000000 RUNNING on processor 1
    Not impersonating
    GetUlongFromAddress: unable to read from fffff803814ac310
    Owning Process            fffff803815563c0       Image:         <Unknown>
    Attached Process          ffffe0000040a900       Image:         System
    fffff78000000000: Unable to get shared data
    Wait Start TickCount      0            
    Context Switch Count      887851         IdealProcessor: 1             
    ReadMemory error: Cannot get nt!KeMaximumIncrement value.
    UserTime                  00:00:00.000
    KernelTime                00:00:00.000
    Win32 Start Address nt!KiIdleLoop (0xfffff80381361790)
    Stack Init ffffd00020dedc90 Current ffffd00020dedc20
    Base ffffd00020dee000 Limit ffffd00020de8000 Call 0
    Priority 0 BasePriority 0 UnusualBoost 0 ForegroundBoost 0 IoPriority 0 PagePriority 0
    Child-SP          RetAddr           : Args to Child                                                           : Call Site
    ffffd000`20dec6b8 fffff803`813e3e9e : 00000000`0000001e ffffffff`c0000005 fffff803`8126751f 00000000`00000001 : nt!KeBugCheckEx
    ffffd000`20dec6c0 fffff803`813651ed : fffff803`81513000 fffff803`81210000 0003ece8`00781000 00000000`00000000 : nt!KiFatalExceptionHandler+0x22
    ffffd000`20dec700 fffff803`812eb595 : 00000000`00000000 ffffd000`20dec830 ffffd000`20ded658 00000000`00000000 : nt!RtlpExecuteHandlerForException+0xd
    ffffd000`20dec730 fffff803`812ec45b : ffffd000`20ded658 ffffd000`20ded360 ffffd000`20ded658 00000000`00000001 : nt!RtlDispatchException+0x455
    ffffd000`20dece30 fffff803`813698c2 : ffffd000`20ded540 ffffd000`20ded550 ffffe000`08035c70 ffffe000`072493e0 : nt!KiDispatchException+0x61f
    ffffd000`20ded520 fffff803`81368014 : 00000000`00000001 ffffd000`201e7180 00000000`00000200 ffffd000`20ded700 : nt!KiExceptionDispatch+0xc2
    ffffd000`20ded700 fffff803`8126751f : 00000000`00000000 fffff803`81267199 00000000`0000bf20 ffffd000`201ec5c0 : nt!KiPageFault+0x214 (TrapFrame @ ffffd000`20ded700)
    ffffd000`20ded890 fffff803`812667b7 : ffffd000`201e7180 ffffd000`201e7180 00000001`3baf70ef 00000000`00000000 : nt!KeAccumulateTicks+0x1af
    ffffd000`20ded920 fffff803`81265f80 : ffffd000`201e7180 ffffd000`20dedb4c ffffd000`20dedc10 ffffd000`20dedb58 : nt!PpmIdleExecuteTransition+0x5d7
    ffffd000`20dedb10 fffff803`813617bc : ffffd000`201e7180 ffffd000`201e7180 ffffd000`201f3340 00000000`00000001 : nt!PoIdle+0x270
    ffffd000`20dedc60 00000000`00000000 : ffffd000`20dee000 ffffd000`20de8000 00000000`00000000 00000000`00000000 : nt!KiIdleLoop+0x2c
    1: kd> dps ffffd00020de8000 ffffd00020dee000
    ffffd000`20de8000  ????????`????????
    ffffd000`20de8008  ????????`????????
    ffffd000`20de8010  ????????`????????
    ffffd000`20de8018  ????????`????????
    ffffd000`20de8020  ????????`????????
    ffffd000`20dec6b8  fffff803`813e3e9e nt!KiFatalExceptionHandler+0x22
    ffffd000`20dec6c0  00000000`0000001e
    ffffd000`20dec6c8  ffffffff`c0000005
    ffffd000`20dec6d0  fffff803`8126751f nt!KeAccumulateTicks+0x1af
    ffffd000`20dec6d8  00000000`00000001
    ffffd000`20dec6e0  00000000`0000028c
    ffffd000`20dec6e8  fffff803`812eacff nt!RtlpGetStackLimits+0x23
    ffffd000`20dec6f0  ffffe000`03982101
    ffffd000`20dec6f8  fffff803`813651ed nt!RtlpExecuteHandlerForException+0xd
    ffffd000`20dec700  fffff803`81513000 nt!BcpCursor <PERF> (nt+0x303000)
    ffffd000`20dec708  fffff803`81210000 nt!_guard_check_icall_fptr <PERF> (nt+0x0)
    ffffd000`20dec710  0003ece8`00781000
    ffffd000`20dec718  00000000`00000000
    ffffd000`20dec720  ffffd000`20dec7d0
    ffffd000`20dec728  fffff803`812eb595 nt!RtlDispatchException+0x455
    ffffd000`20dec730  00000000`00000000
    ffffd000`20dec738  ffffd000`20dec830
    ffffd000`20dec740  ffffd000`20ded658
    ffffd000`20dec748  00000000`00000000
    ffffd000`20dec750  00000000`00000000
    ffffd000`20dec758  ffffd000`00000001
    ffffd000`20dec760  ffffe000`06d98020
    ffffd000`20dec768  fffff800`01980960 nwifi!FilterSendNetBufferLists
    ffffd000`20dec770  00000000`00000000
    ffffd000`20dec778  ffffd000`20dedc60
    ffffd000`20dec780  fffff803`81210000 nt!_guard_check_icall_fptr <PERF> (nt+0x0)
    ffffd000`20dec788  00000000`00000000
    ffffd000`20dec790  ffffe000`023c89b0
    ffffd000`20dec798  fffff803`8148f53c nt!RtlpSparseBitmapCtxUnlockShared+0x4a290
    ffffd000`20dec7a0  00000000`00000000
    ffffd000`20dec7a8  fffff803`81520560 nt!BcpCursor <PERF> (nt+0x310560)
    ffffd000`20dec7b0  ffffd000`20decd00
    ffffd000`20dec7b8  ffffd000`20de8000
    ffffd000`20dec7c0  ffffd000`20ded658
    ffffd000`20dec7c8  ffffd000`20dee000
    ffffd000`20dec7d0  fffff803`813617bc nt!KiIdleLoop+0x2c
    ffffd000`20dec7d8  fffff803`81210000 nt!_guard_check_icall_fptr <PERF> (nt+0x0)
    ffffd000`20dec7e0  fffff803`81520560 nt!BcpCursor <PERF> (nt+0x310560)
    ffffd000`20dec7e8  ffffd000`20dedc60
    ffffd000`20dec7f0  ffffe000`023c89b0
    ffffd000`20dec7f8  ffffd000`20dec830
    ffffd000`20dec800  fffff803`813e3e7c nt!KiFatalExceptionHandler
    ffffd000`20dec808  fffff803`8148f53c nt!RtlpSparseBitmapCtxUnlockShared+0x4a290
    ffffd000`20dec810  ffffd000`20decd00
    ffffd000`20dec818  ffffd000`00000000
    ffffd000`20dec820  ffffd000`20dece60
    ffffd000`20dec828  00000000`00000001
    ffffd000`20dec830  00000000`00000000
    ffffd000`20dec838  fffff800`00ec4604 ndis!ndisSendPacketsWithPause+0x244 ( Wifi related driver)
    ffffd000`20dec840  ffffe000`086b0e10
    ffffd000`20dec848  ffffe000`08035ea0
    ffffd000`20dec850  ffffe000`023c8c80
    ffffd000`20dec858  ffffe000`06dab2a0
    ffffd000`20dec860  00001f80`0010000f
    ffffd000`20dec868  ffffe000`01e10010
    ffffd000`20dec870  00010097`0018c908
    ffffd000`20dec878  ffffd000`20dec910
    ffffd000`20dec880  ffffe000`086b0e10
    ffffd000`20dec888  00000000`00000000
    ffffd000`20dec890  00000000`00000000
    ffffd000`20dec898  00000000`00000001
    ffffd000`20dec8a0  00000000`00000001
    ffffd000`20dec8a8  ffffe000`08a590b0
    ffffd000`20dec8b0  ffffe000`060f5b30
    ffffd000`20dec8b8  00000000`00000000
    ffffd000`20dec8c0  ffffd000`201e7180
    ffffd000`20dec8c8  ffffd000`20dedc90
    ffffd000`20dec8d0  00000000`00000000
    ffffd000`20dec8d8  ffffd000`201f3340
    ffffd000`20dec8e0  ffffe000`0111b080
    ffffd000`20dec8e8  ffffd000`00000000
    ffffd000`20dec8f0  ffffe000`060f5b30
    ffffd000`20dec8f8  fffff800`04004aa4Unable to load image VBoxNetFlt.sys, Win32 error 0n2
    *** WARNING: Unable to verify timestamp for VBoxNetFlt.sys
    *** ERROR: Module load completed but symbols could not be loaded for VBoxNetFlt.sys
    ffffd000`20dec900  ffffd000`00000000
    ffffd000`20dec908  00000000`00000001
    ffffd000`20dec910  fffff803`81210000 nt!_guard_check_icall_fptr <PERF> (nt+0x0)
    ffffd000`20dec918  ffffe000`0040a900
    ffffd000`20dec920  ffffd000`201ed2c0
    ffffd000`20dec928  00000000`00000000
    ffffd000`20dec930  fffff800`012ba180 tcpip!Ipv4Global ​ (another network related driver)
    ffffd000`20dec938  00000000`00000000
    ffffd000`20dec940  00000000`00000000
    ffffd000`20dec948  ffffe000`00001f80
    ffffd000`20dec950  ffffe000`07249306
    ffffd000`20dec958  00000000`00000000
    ffffd000`20dec960  ffffd000`20ded210
    ffffd000`20dec968  0000bb01`b3c20002

    Please continue to use the system with Nvidia disabled and make sure whether it is playing a role in the crashes or not.
      My System SpecsSystem Spec

  10. #20

    Posts : 15
    Windows 8.1

    Just to keep you posted, I ran all the VBoxes I could and also some memtests simultaneously to consume all memory, 512MB left for an hour, memtest running, Ubuntu compiling the whole Android sources, me browsing the web from the 3 Android emulators and Eclipse rebuilding my apps constantly. No BSOD. Found the Ubuntu experience quite lagging on Windows manipulations, because NVidia card was disabled I suppose.

    Nevertheless, I then rebooted the laptop, removed the 2 sticks and checked their CLK: one is CLK 9-9-9-28 and the other 11-11-???, both 1600MHz. Doesn't sound good, but it's a very recent hardware and should handle that properly?

    After reboot, enabled Nvidia driver again and started Ubuntu inside VirtualBox. First thing I noticed, it's much smoother, eg Nvidia driver are definitely being used now!

    After 20 minutes, no reboot as earlier, but haven't started everything yet, and sometimes I don't get any BSOD for a "long" time (2 days at the very best so far).

    Quote Originally Posted by Anshad Edavana View Post

    I don't use KD (command line debugger). What i regularly use is Windbg (same but with GUI) . To dump the raw stack, we need to know the base and limit pointers of the stack. It can be obtained from the thread info by executing !thread command. The below example will illustrate it for you. This is one of the earlier crash dump i randomly picked.
    EDIT: Just received your new post while writing this post, will give it a go with next BSOD, thanks so much for the info!
      My System SpecsSystem Spec

Page 2 of 3 FirstFirst 123 LastLast
BSOD from 0 to 20 times a day, since upgrading Laptop
Related Threads
We are at a complete loss to know what to do about this problem. We are considering a fresh install of Windows, but don't want to do this without trying to solve things first, in case it is a hardware problem. This is related to another thread here (see link below) but I've started a new thread...
I want to upgrade my VAIO laptop SVS13's HDD to a 256gb ssd. it has Windows 8.1 on it, and what I want to do is backup only a couple files but move most of my data from my old booting HDD that I'm using now. Would this process I'm describing work? So I would basically take out my hdd, put it in the...
I've just purchased this stupid piece of junk and it's always at 99% disk, which makes it run like, well, a stupid piece of junk. It has decent specs (it's an asus tp550ld, with i7-4500U, and 8 gb of 1600 MHz ram, and a GeForce 820m), but struggles to do the simplest of tasks, such as opening new...
Laptop crashing few times every day in BSOD Crashes and Debugging
Hello, my new laptop is crashing multiple times every day. It freezes, reboots itself or I get BSoD. I use it mostly for playing League of Legends and watching videos on Youtube , but it crashes on everything. I tried to reinstall Windows 8.1 (OS I had when I bought laptop), reinstall all drivers,...
Hi guys! First post, and I expect making alot more. Glad to be apart of the community, and I hope not to break any rule. First of all, here's my laptop's specs (ASUS N53Jq-SX145V): Operating System: Windows 7 Home Premium 64 bit CPU: Intel i7 740QM (1.73GHz, Turbo2.93G, 6MB) Memory:...
hello helping many times i should reinstall windows or other os or how much time i can formate my pc? is this any harfull effect by installing windows many tmes( i did 30 times till today). some of my fren tell me there is certiain coating or layering in the harddisk which may break...
My toshiba laptop will seem to just randomly freeze up whenever it feels like, the periods between freezes can vary anywhere from 5 minutes to 3 or 4 hours so its completely random and it does not seem to happen when I'm doing a specific task, I can be watching a video, browsing the internet or...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook