Windows 8 and 8.1 Forums


BSOD:system_exception_thread_not_handled & bad_pool_caller

  1. #1


    Posts : 8
    Win 8.1 64 bit

    BSOD:system_exception_thread_not_handled & bad_pool_caller


    Hi all,
    Recently updated win 8 to 8.1 and a week later on, I'm getting BSOD on bootup.
    Initially I got system_exception_thread_not_handled and in automatic repair it rolled back few of the installed updates. But no use.
    Now, sometimes I get system_exception_thread_not_handled and sometimes bad_pool_caller.

    If I first boot in safe mode and then boot normally, then its booting up OK.

    Its driving me nuts. Please help.

    BTW, SF diagnostics generated multiple .dmp files. Is there a s/w to read the dmp file?

    Attached SF.

      My System SpecsSystem Spec

  2. #2


    Hi

    Almost all crash dumps seems to blame "Realtek Card Reader" driver as the reason behind the crashes.

    Code:
    BugCheck C2, {7, 1205, d5fe5, ffffe00004138780}
    
    
    *** WARNING: Unable to verify timestamp for RtsP2Stor.sys
    *** ERROR: Module load completed but symbols could not be loaded for RtsP2Stor.sys
    fffff80197129340: Unable to get special pool info
    fffff80197129340: Unable to get special pool info
    GetUlongFromAddress: unable to read from fffff801971c4208
    Probably caused by : RtsP2Stor.sys ( RtsP2Stor+35dd3 )
    Driver Reference Table - RtsP2Stor.sys

    Please follow the below steps.

    1. Update card reader driver.

    Uninstall the currently installed "Realtek Card Reader" driver from "Control Panel --> Programs" completely and reboot the system. Now download and install PCIE RTL8402/RTL8411 card reader driver for XP/Win7/Win8/Win8.1 from the below link.

    Realtek

    2. Update system BIOS.

    Lenovo recommends updating BIOS to the latest version to improve Windows 8.1 compatibility. Download and run the BIOS update utility to do that.

    BIOS Update : http://download.lenovo.com/ibmdl/pub...s/g3uj14us.exe

    Readme : http://download.lenovo.com/ibmdl/pub...s/g3uj14us.txt

    Report how the system works now. If the issue continues, upload the latest crash dumps.
      My System SpecsSystem Spec

  3. #3


    Posts : 8
    Win 8.1 64 bit


    Anshad, Thanks a ton.
    After uninstalling PCIe card reader the boot time BSOD is gone for two days now.

    However I'm now facing different issue.
    Most likely the wlan is dependent on PCIe card reader and my wifi gone kaput after uninstall of PCIe card.
    The driver you suggested - PCIE RTL8402/RTL8411 - is not proper I guess coz after installing it, still the PCIe card reader was undetected. I just checked my type and realized it should be RTS and not RTL. So I downloaded and installed PCIE RTS5229 card reader driver for XP/Win7/Win8/Win8.1. Now the card reader is detected ok. But I'm back to the boot BSOD.
    As of now I have just disabled the PCIe card reader driver for booting and my wlan is still non-function.
    I guess RealTek need to come up with fix for this issue.

    Anyways thanks a lot for your help.

    PS: BTW, the dmp files created by SF tool, how can we read it? Is there a software / tool for it? Can you please tell the location where I can download the same.
      My System SpecsSystem Spec

  4. #4


    Hi

    To read the crash dumps we need "Windows Debugger" or "Windbg". Explaining how to read crash dumps are out of the scope of this thread but i will post some links which will b very helpful to beginners.

    User-friendly: Analyzing your first BSoD! - Windows 7 Help Forums

    How I Debug Blue Screen Crashes - Windows 7 Help Forums


    Since the BSOD returned after updating the driver, please rerun the diagnostic tool and post the zip with next reply. I hope we can sort it out.
      My System SpecsSystem Spec

  5. #5


    Posts : 8
    Win 8.1 64 bit


    Anshad, thanks for pointing out the "how to debug" thread.
    I set up the debugger and could load the dmp file.
    The latest driver for realtek pcie card reader too has same issue:
    Code:
    BugCheck C2, {7, 1205, d5f7e, ffffe00003f74a90}
    
    
    *** WARNING: Unable to verify timestamp for RtsP2Stor.sys
    *** ERROR: Module load completed but symbols could not be loaded for RtsP2Stor.sys
    GetPointerFromAddress: unable to read from fffff803357c3150
    GetUlongFromAddress: unable to read from fffff803357c3208
    Probably caused by : RtsP2Stor.sys ( RtsP2Stor+37fa8 )
    I sent mail to RealTek support.
    Is it possible that some other issue is preempting the card reader driver to screw up?
      My System SpecsSystem Spec

  6. #6


    Is it possible that some other issue is preempting the card reader driver to screw up?
    Yes, it is possible. May be some other rogue driver which is sharing some system resources could be corrupting the card reader driver and forcing it to crash. In that case, we should update all the outdated drivers as a test. Please upload the latest crash dump and i will post the list of outdated drivers to update.
      My System SpecsSystem Spec

  7. #7


    Posts : 8
    Win 8.1 64 bit


    OK - here is the latest SF zip.
    All the dumps point to only one: RealTek card reader RtsP2Stor.sys.
    There is one dump on WLAN driver - but thats not during boot up. It happened in-between things and is one-off occurrence I guess.
      My System SpecsSystem Spec

  8. #8


    Hi

    Realtek card reader and wireless adapter drivers seems to be up to dated. So let us try updating the remaining drivers.

    Realtek LAN : Realtek


    Microsoft Mouse driver : Software Downloads | Microsoft Hardware

    Current version seems to be pre-Win8 so may cause compatibility issues.

    Code:
    NuidFltr.sys                Sat Apr  9 04:28:16 2011 (4D9F9308)
    Microsoft Intellipoint mouse driver
    http://www.carrona.org/drivers/driver.php?id=NuidFltr.sys

    If the BSOD continues, please enable "Driver Verifier" by following instructions from the below link.

    Driver Verifier - BSOD related - Sysnative Forums

    This will stress the drivers and force BSOD when a violation is found. After you got two or three crashes, rerun the tool and upload the new dumps.
      My System SpecsSystem Spec

BSOD:system_exception_thread_not_handled & bad_pool_caller
Related Threads
BSOD every 10 min ! bad_pool_caller in BSOD Crashes and Debugging
Hello everyone, I'm having big troubles with my computer, I can't manage to use it more than 10 minutes since it keeps having BSODs.. I'm using Windows 8.1, and, during the time I wrote those few lines, it already restarted 3 times !! Here are specy snapshot, dump files and I used...
Bsod: Bad_pool_caller in BSOD Crashes and Debugging
Hi there, I'm a bit new to this.. I keep getting BAD_POOL_CALLER BSOD's in the past day or so. I don't think it's anything new I've installed... Here's an attached minidump of the crash just a few minutes ago. I attached it in a zip file because it was telling me I couldn't open it without admin...
Solved system_exception_thread_not_handled in BSOD Crashes and Debugging
Hi all, I'm getting the above error and consequent BSOD but ONLY at initial start up if the pc has been powered down for some time i.e overnight. I don't get it at any other time, the pc restarts fine after the initial crash, and it never does it whilst using the pc. The only other error shown...
BSOD Bad_pool_caller & others in BSOD Crashes and Debugging
Hi, I hope someone can help me..I am getting the BSOD just from today on my brand new toshiba l850 windows 8. Only been used for 1 week! Started with bad pool caller, which is now frequent. I have also had memory_management? (could be wrong..was memory something!) and ntfs file system as my BSOD...
BSoD bad_pool_caller in BSOD Crashes and Debugging
check my error please :( BSoD make me crazy :confused: here my minidump
Bsod - bad_pool_caller in BSOD Crashes and Debugging
I have started getting lots of BSODs of different kinds mostly BAD_POOL_CALLER. Computer worked fine two days ago. Happens every 5 min.
Solved Bsod bad_pool_caller win 8 in BSOD Crashes and Debugging
Hi, I am currently experiencing a BSOD error and the error is BAD_POOL_CALLER. According to the guidelines in previous posts I am uploading my system memory dump file from C:\Windows\Minidump. Please go thru it and tell me what i should do. Many thnks in advance.
Eight Forums Android App Eight Forums IOS App Follow us on Facebook