Windows 8 and 8.1 Forums

System crash on Boot Camp 5 related to atikmpag.sys

  1. #1

    Posts : 19
    Windows 8.1 Enterprise x64

    System crash on Boot Camp 5 related to atikmpag.sys

    Hi everybody, I'm experiencing Windows 8 crashes almost every time I start programs that require heavy video-processing (e.g.: games). The problem also happens, even if rarely, at random.

    This is a Speccy log of my system, that is running with Boot Camp 5.0.

    Operating System
        Windows 8 Enterprise N 64-bit
        Intel Core i7 2630QM @ 2.00GHz    74 °C
        Sandy Bridge 32nm Technology
        8.00GB Dual-Channel DDR3 @ 666MHz (9-9-9-24)
        Apple Inc. Mac-94245A3940C91C80 (U2E1)    35 °C
        Color LCD (1680x1050@60Hz)
        256MB ATI AMD Radeon HD 7400M Series (Microsoft Corporation - WDDM v1.20) (Apple Computer)
    Hard Drives
        466GB Hitachi HTS725050A9A362 ATA Device (SATA)    39 °C
    Optical Drives
        MATSHITA DVD-R UJ-8A8 ATA Device
        Cirrus Logic CS4206B (AB 29)
    This is the debug trace of MEMORY.DMP obtained with WinDbg.

    Microsoft (R) Windows Debugger Version 6.2.9200.20512 AMD64
    Copyright (c) Microsoft Corporation. All rights reserved.
    Loading Dump File [C:\Windows\MEMORY.DMP]
    Kernel Bitmap Dump File: Only kernel address space is available
    Symbol search path is: srv*f:\symbols\websymbols*
    Executable search path is: 
    Windows 8 Kernel Version 9200 MP (8 procs) Free x64
    Product: WinNt, suite: TerminalServer SingleUserTS
    Built by: 9200.16628.amd64fre.win8_gdr.130531-1504
    Machine Name:
    Kernel base = 0xfffff802`a3875000 PsLoadedModuleList = 0xfffff802`a3b41a20
    Debug session time: Tue Aug 13 08:53:46.736 2013 (UTC + 1:00)
    System Uptime: 0 days 14:10:24.425
    Loading Kernel Symbols
    Loading User Symbols
    Loading unloaded module list
    *                                                                             *
    *                        Bugcheck Analysis                                    *
    *                                                                             *
    Use !analyze -v to get detailed debugging information.
    BugCheck 116, {fffffa800cabb010, fffff88004c92efc, 0, 2}
    Probably caused by : atikmpag.sys ( atikmpag!ProxyCollectDbgInfo+0 )
    Followup: MachineOwner
    6: kd> !analyze -v
    *                                                                             *
    *                        Bugcheck Analysis                                    *
    *                                                                             *
    Attempt to reset the display driver and recover from timeout failed.
    Arg1: fffffa800cabb010, Optional pointer to internal TDR recovery context (TDR_RECOVERY_CONTEXT).
    Arg2: fffff88004c92efc, The pointer into responsible device driver module (e.g. owner tag).
    Arg3: 0000000000000000, Optional error code (NTSTATUS) of the last failed operation.
    Arg4: 0000000000000002, Optional internal context dependent data.
    Debugging Details:
    fffff880`04c92efc 4055            push    rbp
    BUGCHECK_STR:  0x116
    PROCESS_NAME:  System
    fffff880`099e8838 fffff880`040e952b : 00000000`00000116 fffffa80`0cabb010 fffff880`04c92efc 00000000`00000000 : nt!KeBugCheckEx
    fffff880`099e8840 fffff880`040e7c78 : fffff880`04c92efc fffffa80`0cabb010 fffff880`099e8949 00000000`000000cd : dxgkrnl!TdrBugcheckOnTimeout+0xef
    fffff880`099e8880 fffff880`041bb608 : fffffa80`0cabb010 fffff880`099e8949 00000000`000ebc0f 00000000`00000002 : dxgkrnl!TdrIsRecoveryRequired+0x168
    fffff880`099e88b0 fffff880`041ea539 : 00000000`00000000 fffff780`00000320 00000000`00000000 fffffa80`076e2010 : dxgmms1!VidSchiReportHwHang+0x438
    fffff880`099e89b0 fffff880`041e8a49 : fffffa80`00000002 fffffa80`076e2010 fffffa80`076e2450 fffffa80`076e2450 : dxgmms1!VidSchiCheckHwProgress+0xe5
    fffff880`099e8a00 fffff880`041b3fe5 : ffffffff`ff676980 00000000`00000001 fffff880`099e8b69 fffffa80`076e2010 : dxgmms1!VidSchiWaitForSchedulerEvents+0x20d
    fffff880`099e8aa0 fffff880`041e8646 : 00000000`00000000 fffffa80`0c45b010 fffffa80`0a17c5a0 fffffa80`076e2010 : dxgmms1!VidSchiScheduleCommandToRun+0x289
    fffff880`099e8bd0 fffff802`a38a1fd9 : fffffa80`076e32c0 fffffa80`076e2010 fffff880`00b4ff40 00000000`02deee0d : dxgmms1!VidSchiWorkerThread+0xca
    fffff880`099e8c10 fffff802`a39567e6 : fffff880`00b44180 fffffa80`076e32c0 fffff880`00b4ff40 fffffa80`075b7940 : nt!PspSystemThreadStartup+0x59
    fffff880`099e8c60 00000000`00000000 : fffff880`099e9000 fffff880`099e3000 00000000`00000000 00000000`00000000 : nt!KiStartSystemThread+0x16
    STACK_COMMAND:  .bugcheck ; kb
    fffff880`04c92efc 4055            push    rbp
    SYMBOL_NAME:  atikmpag!ProxyCollectDbgInfo+0
    FOLLOWUP_NAME:  MachineOwner
    MODULE_NAME: atikmpag
    IMAGE_NAME:  atikmpag.sys
    FAILURE_BUCKET_ID:  0x116_IMAGE_atikmpag.sys
    BUCKET_ID:  0x116_IMAGE_atikmpag.sys
    Followup: MachineOwner
    I also attached the SF Diagnostic Tool log (I hope nothing went wrong because the tool is sometimes unresponsive with all those popups gaining focus on top of each other).

    As you may see, it looks like a video card problem (atikmpag.sys). I think in cases like this the first thing to try is updating the drivers but unfortunately, since I'm running Windows on Boot Camp, it looks like there aren't suitable drivers apart from the ones I'm already using. Are there any bullets I can fire before the standard format-and-see-what-happens or send-the-computer-to-support? Many thanks in advance!
    Last edited by st1led; 17 Aug 2013 at 10:46.

      My System SpecsSystem Spec

  2. #2

    Posts : 19
    Windows 8.1 Enterprise x64

    Small update: I'm now 99% sure it's a video card/drivers problem, since I disabled the video card from the Device Manager and the problem doesn't appear anymore.

    One more thought: should I perhaps post this issue in the Apple forums?
      My System SpecsSystem Spec

  3. #3

    Posts : 5,139
    Win8.1Pro - Finally!!!

    STOP 0x116 troubleshooting: Video TDR Timeout - 0x116 + 0x117 - Sysnative Forums

    Hardware diagnostics: Hardware Diagnostics
    Concentrate on the video tests - but make sure to monitor them in case of overheating (I'm wary of the Mac's cooling abilities).

    As it's running Windows, I'd suspect that you can update the video drivers from the AMD/ATI website (but laptop graphics drivers may not be available). Maybe these will work: AMD Catalyst
      My System SpecsSystem Spec

  4. #4

    Posts : 19
    Windows 8.1 Enterprise x64

    Thank you for your support, time for few results and recent findings.

    I tried the video-card diagnostics, and this is what happens:

    • FurMark: the test runs for 8-10 seconds, then I see a lot of artifacts in the video, and the computer hangs and automatically restarts / needs to be manually rebooted. I have no clue where the program saves the execution logs (they are not in the folder where it's installed, nor there is any option specifying it), so I can't post them. The test runs at 6-8 fps, and the computer crashes when the GPU is at ~70°C. It's pretty much what happens after few seconds with every program requiring complex video processing, be it 3D Mark, a video game, sometimes even VLC or flash/shockwave. It could be overheating, but it really happens even after few seconds the computer is freshly started. If I'm lucky, the screen just fizzles up and de-centers with horizontal lines (see attachment), so I can still somehow interact with it. Logging off windows and then logging in again (sometimes changing the desktop resolution is enough), temporarily fixes the problem, perhaps because the drivers are un-loaded and then re-loaded again. The problem of course starts showing off again upon stressful GPU usage. If I'm not lucky, then it's just either blue screen, or auto-reboot, or freeze with corrupted images on the screen.
    • Artifact Locator: the test runs without any errors, but some tests can't be performed since it says the program is not compatible with Windows x64
    • Video Memory Stress Test: the test runs without any errors, albeit some tests are not supported:

    WARNING: Your card can be not compatible with this test! If multiple errors will found, try test with onscreen buffer usage or wthout of ignoring colors bit mask.
    Changing video mode to 640x480x16...OK
    [26/08/2013 12:40:31] Test started for "Primary Display Driver (AMD Radeon HD 6490M)"...
    Trying 16bpp RGB:565 mode...OK
    Trying 16bpp RGB:555 mode...OK
    Trying 16bpp BGR:565 mode...NOT SUPPORTED (Code: 80004001)
    Trying 32bpp RGB:888 mode...OK
    Trying 32bpp BGR:888 mode...NOT SUPPORTED (Code: 80004001)
    [26/08/2013 13:21:45] Pass completed (0 errors found).
    As for downloading ATI drivers, I have no way to download the notebook ones. The only thing I can seem to install is the ATI Mobility Radeon Verification Tool, that once executed reports:

    “AMD Catalyst Mobility cannot be downloaded due to incompatible  hardware/software on your computer. Your computer does not contain a  proper graphics adapter.”
    I only managed to install the latest beta drivers (AMD Catalyst Control Center 13.8 version 2013.0815.818.13017) and re-run the tests, unfortunately with the same results.
    Last edited by st1led; 26 Aug 2013 at 07:15.
      My System SpecsSystem Spec

  5. #5

    Posts : 5,139
    Win8.1Pro - Finally!!!

    Our tests/procedures are designed for Windows systems. Apply uses drivers and hardware that may/may not be totally compatible with these things (but they mostly are).

    For example, many of the bootable diagnostics can't be run on an Apple system because there aren't any touchpad/keyboard drivers loaded for the Linux based tests (such as Seatools or MemTest86+)

    We take what we can get when it comes to Apple hardware. In this case I have to suspect problems with your graphics adapter. Since the drivers won't install (and the Furmark test failed), I have to suspect the graphics card itself (hardware).

    Since it does work with no drivers installed (when you disabled it in the Device Manager) - I have to suspect that it's a higher level function that's not working properly.

    I recall an issue (recently) which may have explained this - but can't recall exactly what it was. It was a relatively new function that was implemented in video drivers and it was within the last 2 weeks (at a guess). When I have time I'll search all my posts to see if there's a clue there - and will post back when I'm done....
      My System SpecsSystem Spec

  6. #6

    Posts : 5,139
    Win8.1Pro - Finally!!!

    Found it!!! Acer 6930G with FX770M video_tdr_failure

    Look for any new features on the AMD/ATI drivers that resembles the nVidia PowerMizer ( NVIDIA PowerMizer Technology | NVIDIA ). It downclocks the GPU in order to save battery life.

    A quick search of the web shows that there is such a feature for AMD/ATI GPU's - but I wasn't able to locate it.
      My System SpecsSystem Spec

  7. #7

    Posts : 19
    Windows 8.1 Enterprise x64

    I see, thanks for the hint. Where exactly should I look for this settings? The only thing that comes to my mind is within the ATI Catalyst Control Center, and the closest thing there is the AMD PowerPlay™ Technology. Anyway, when I open the tab, the lists show up as blank and there is really no option I can work on (screen attached). It looks like my video card doesn't support this feature, even if I think it definitely should like it says in the AMD page: AMD PowerPlay

    Were you referring to something else?

    Attachment 26858
      My System SpecsSystem Spec

  8. #8

    Posts : 5,139
    Win8.1Pro - Finally!!!

    I'm not a graphics expert. I'd suggest that you post over in the Graphics Cards forum here: Graphic Cards - Windows 8 Forums FYI - at times the staff will take your new post and return it here, with no explanation. If this happens, just post back and we'll develop an alternate suggestion (?ATI forums?).
      My System SpecsSystem Spec

  9. #9

    Posts : 19
    Windows 8.1 Enterprise x64

    I just posted the issue there. I'll come back if there are any other sensible news. Thank you again for your support!
      My System SpecsSystem Spec

  10. #10

    Posts : 19
    Windows 8.1 Enterprise x64

    Still, no news from any side... I guess that's better than bad news, but at this point I think the only thing left is to send it to the tech support, since I suspect a hardware problem.
      My System SpecsSystem Spec

Page 1 of 2 12 LastLast
System crash on Boot Camp 5 related to atikmpag.sys
Related Threads
Hey guys, I need some help. I am the same person who posted a thread about needing drivers for Windows 7 after dual booting it with my preinstalled copy of Windows 8. So, I was on Windows 7 today, and my screen randomly blinked on and off for 5 seconds, and then came up with a message saying my...
Hi everybody, I posted this issue in the BSOD section, but have been suggested to post it here instead. My system is a Windows 8 x64 Pro with Boot Camp 5 running on a 2011 Macbook Pro. I'm experiencing Windows crashes and distorted screen images with artifacts (see attachment #1) almost every...
Happy New Year to All. We are going to have an incredibly exiting new year's eve. :D We'll be watching Times Square midnight two hours earlier. I am live on my Win8 lappy having connected to this machine using RDC on my Win7 Boot Camp installation. I ended up on the Win8 Desktop since the Win8...
I was FORCED to install Windows 8 to my IMac 24 inch running Mountain Lion OS via Parallels 8 for the following reason. I receive an error message stating that some files cannot be moved and that I must create a single partition formatted Mac OS X Journal Extended. In short. the Windows 8 partition...
I was FORCED to install Windows 8 to my IMac 24 inch running Mountain Lion OS via Parallels 8 for the following reason. I receive an error message stating that some files cannot be moved and that I must create a single partition formatted Mac OS X Journal Extended. In short. the Windows 8 partition...
Strange boot problems (related to video card?) in BSOD Crashes and Debugging
Hello everybody, Yesterday I installed windows 8 on my 4 year old Acer Aspire 5920G laptop (still runs many recent games decently), dual booted with Vista (OEM) and W7. W8 was installed succesfully and it worked as it should, but when I let the system do a performance rating the screen went...
Windows 8 on a Mac: why Microsoft should write its own Boot Camp | ZDNet
Eight Forums Android App Eight Forums IOS App Follow us on Facebook