Windows 8 and 8.1 Forums


BSOD when plugging in a USB device.

  1. #1


    Posts : 11
    windows 8 64bit

    BSOD when plugging in a USB device.


    So i"m having a problem. Every time i plug in a USB device or an external hard drive. Anything trough a usb port my pc BSOD"s. I will give you a copy of an event log so you can tell me what do you think.

    - System
    - Provider
    [ Name] Microsoft-Windows-Kernel-Power
    [ Guid] {331C3B3A-2005-44C2-AC5E-77220C37D6B4}
    EventID 41
    Version 3
    Level 1
    Task 63
    Opcode 0
    Keywords 0x8000000000000002
    - TimeCreated
    [ SystemTime] 2013-07-18T12:15:41.299863300Z
    EventRecordID 41729
    Correlation
    - Execution
    [ ProcessID] 4
    [ ThreadID] 8
    Channel System
    Computer athlon64
    - Security
    [ UserID] S-1-5-18

    - EventData
    BugcheckCode 0
    BugcheckParameter1 0x0
    BugcheckParameter2 0x0
    BugcheckParameter3 0x0
    BugcheckParameter4 0x0
    SleepInProgress 0
    PowerButtonTimestamp 0
    BootAppStatus 0

      My System SpecsSystem Spec

  2. #2


    Posts : 1,093
    Windows 8 Pro Windows 8.1 Preview


    Give us a screenshot of your device manager with the USB information extended as shown:

    Attachment 24989
      My System SpecsSystem Spec

  3. #3


    Posts : 11
    windows 8 64bit


    Quote Originally Posted by JustATest View Post
    Give us a screenshot of your device manager with the USB information extended as shown:

    Attachment 24989
    Here:

    ImageShack® - Online Photo and Video Hosting
      My System SpecsSystem Spec

  4. #4


    Posts : 1,093
    Windows 8 Pro Windows 8.1 Preview


    Initially, I don't see anything (obviously) wrong with that USB view; however, knowing that something is wrong, I have to ask the following additional questions:

    Did it ever work?
    Can you associate anything you did coincident with the problem starting?
    Is it all USB ports (including the USB 3.0 ports as well)?
    Do you have a USB hub attached or do you just direct connect to each port?

    In addition to answering the questions above, I would also try right clicking on each USB Enhanced Host Controller and uninstalling it. Then reboot and it will reinstall the previously deleted controller. Repeat for the next controller until all three are done. If still not fixed, I would then do the USB 3.0 controller using the same procedure. Note that one of those controllers will probably disable your USB mouse when you uninstall it so you may be forced to just shut it down and then power it up again. Let us know.
      My System SpecsSystem Spec

  5. #5


    Posts : 11
    windows 8 64bit


    Yes it worked.
    Nope, i can"t
    Yes it is.
    I tried direcct connecting to the motherboard and trough the frontpannel. Same thing.

    I will try that tomorrow.
      My System SpecsSystem Spec

  6. #6


    Posts : 1,093
    Windows 8 Pro Windows 8.1 Preview


    Thanks for answering the questions so quickly. Give the uninstalls a try. I have more ideas waiting in the wings if that doesn't work.
      My System SpecsSystem Spec

  7. #7


    Posts : 1,093
    Windows 8 Pro Windows 8.1 Preview


    One more thing, can you give me your system specs so I review your configuration and BIOS options please?
      My System SpecsSystem Spec

  8. #8


    Posts : 11
    windows 8 64bit


    ASRock 890gx ex3. Phenom 1055t (3.8Ghz OC) , 4x4Gb kingston HyperX 1600mhz, gtx660ti , corsair tx650. Kingston HyperX 120Gb. 2x2Tb wd greens. 1 X 1TB seagate barracuda 7200.14.

    BIOS options are not the problem. It used to work with the same settings i have now.
      My System SpecsSystem Spec

  9. #9


    Posts : 1,093
    Windows 8 Pro Windows 8.1 Preview


    Ok then, I won't bother looking at you configuration or BIOS but I was actually more interested in trying to identify those 3 unknown devices in device manager. Moreover, I also have a few rigs with ASRock mobos and I am certain that a few of those unknown devices are being caused by unneeded (eg, unused) options that are set in the BIOS. Anyway, let's just stick to the USB issue; however, it might have helped to disable the USB 3.0 controller in the BIOS and then try testing the USB 2.0 ports and/or vice-versa. Maybe you have developed a hardware issue of sorts.
      My System SpecsSystem Spec

  10. #10


    Posts : 11
    windows 8 64bit


    I went to BIOS. Tried disabling USB 3.0 and played with some other settings. Nothing helps. Reinstalled USB drivers. Nothing.
    When i plug in my usb it registers it, opens it and then crashes after about 10-15 seconds. I don"t get it.
      My System SpecsSystem Spec

Page 1 of 3 123 LastLast
BSOD when plugging in a USB device.
Related Threads
Yesterday my computer suddenly had a bluescreen named MEMORY_MANAGEMENT. I tried to restart my computer but it would keep crashing when starting. Here is what I have narrowed down so far. My secondary 3TB GPT internal hard drive I use for storing my libraries and the page file causes the...
Hi, Wondering if anyone can help me solve why my audio goes every time I plug in my mouse or external hard drive into one of the usb ports. The only way I can get audio back is by restarting the computer. I'm running Windows 8 on ASUS UX32VD. I've gone into Sound settings, Communications...
Title, occurs when I plug in my deathadder I don't have another mouse to test. The laptop is a aspire v3 772g and I recently reinstalled windows which made no difference. I've tried reinstalling completely the mouse drivers to no avail. If I boot up with the mouse not plugged in everything...
Solved BSOD when removing and adding any USB device in BSOD Crashes and Debugging
Hi I've been having a problem lately with my drivers i think, whenever i remove or add a USB device my computer crashes with the BSOD and says "KERNEL_SECURITY_CHECK_FAILURE". I've tried some of the common fixes around the forums but they don't seems to work.If it helps I have my dump files here...
I have the asus s400ca it has the microphone and headphone in the same jack. My headphones are fine in any other laptop but when I plug them into my new asus I hear very loud static even when playing music. It came with via hd audio and I can specify any other information if necessary, please...
BSOD after plugging in hard drive in BSOD Crashes and Debugging
Hello. I have Windows 8 installed on my SSD and I thought I'd plug in my HDD as well. I started up the PC, the HDD was found and there were no problems. But it only took about 5 minutes and I got a BSOD. I don't know if this had to something to do with the HDD or if it might be due to...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook