Windows 8 and 8.1 Forums

bad_pool_caller

  1. #1


    Posts : 1
    Windows 8 Pro

    bad_pool_caller


    Hello everyone,

    i have the same problem as so often described...
    bad_pool_caller

    See attached file

    Pleas help!

      My System SpecsSystem Spec

  2. #2


    Posts : 250
    Windows 7 Home Premium 64 Bit


    Hi and welcome to Eight forums.

    You might want to see if updating the Apple Mac HAL Driver driver helps.
    If not, delete it completely from the system.

    Link: Driver Reference Table - MacHALDriver.sys

    Code:
    ********************************************************************************                                                                             *
    *                        Bugcheck Analysis                                    *
    *                                                                             *
    *******************************************************************************
    
    
    Use !analyze -v to get detailed debugging information.
    
    
    BugCheck C2, {d, 85e91f48, 20206f49, b793749}
    
    
    Unable to load image \??\C:\Windows\system32\drivers\MacHALDriver.sys, Win32 error 0n2
    *** WARNING: Unable to verify timestamp for MacHALDriver.sys
    *** ERROR: Module load completed but symbols could not be loaded for MacHALDriver.sys
    Probably caused by : MacHALDriver.sys ( MacHALDriver+14b9 )
    
    
    Followup: MachineOwner
    ---------
    
    
    0: kd> !analyze -v
    *******************************************************************************
    *                                                                             *
    *                        Bugcheck Analysis                                    *
    *                                                                             *
    *******************************************************************************
    
    
    BAD_POOL_CALLER (c2)
    The current thread is making a bad pool request.  Typically this is at a bad IRQL level or double freeing the same allocation, etc.
    Arguments:
    Arg1: 0000000d, type of pool violation the caller is guilty of.
    Arg2: 85e91f48
    Arg3: 20206f49
    Arg4: 0b793749
    
    
    Debugging Details:
    ------------------
    
    
    
    
    FAULTING_IP: 
    nt!IopCompleteRequest+a5
    8186e9df 8d4308          lea     eax,[ebx+8]
    
    
    BUGCHECK_STR:  0xc2_d
    
    
    CUSTOMER_CRASH_COUNT:  1
    
    
    DEFAULT_BUCKET_ID:  WIN8_DRIVER_FAULT
    
    
    PROCESS_NAME:  Bootcamp.exe
    
    
    CURRENT_IRQL:  1
    
    
    IRP_ADDRESS:  8639cee8
    
    
    DEVICE_OBJECT: 861ff790
    
    
    LAST_CONTROL_TRANSFER:  from 81a23f00 to 8193d76c
    
    
    STACK_TEXT:  
    a8cf7bd4 81a23f00 000000c2 0000000d 85e91f48 nt!KeBugCheckEx
    a8cf7c68 8186e9df 85e91f48 00000000 77493399 nt!ExDeferredFreePool+0x10b8
    a8cf7d1c 8187ca81 8639cf28 a8cf7d68 a8cf7d70 nt!IopCompleteRequest+0xa5
    a8cf7dc0 a6ffa4b9 00000000 861ff790 85fd010e nt!IopfCompleteRequest+0x663
    WARNING: Stack unwind information not available. Following frames may be wrong.
    a8cf7de0 81898ba8 861ff790 0000003c 85fd0100 MacHALDriver+0x14b9
    a8cf7dfc 81ae0f4c 8639cfbc 8639cf28 85fd59d0 nt!IofCallDriver+0x3f
    a8cf7e50 81ae09c1 861ff790 00000000 91d33e01 nt!IopSynchronousServiceTail+0x121
    a8cf7ef0 81ae05f9 861ff790 8639cf28 00000000 nt!IopXxxControlFile+0x3ac
    a8cf7f24 819b233c 00000220 00000000 00000000 nt!NtDeviceIoControlFile+0x2a
    a8cf7f24 77186954 00000220 00000000 00000000 nt!KiFastCallEntry+0x12c
    0013f40c 00000000 00000000 00000000 00000000 0x77186954
    
    
    
    
    STACK_COMMAND:  kb
    
    
    FOLLOWUP_IP: 
    MacHALDriver+14b9
    a6ffa4b9 ??              ???
    
    
    SYMBOL_STACK_INDEX:  4
    
    
    SYMBOL_NAME:  MacHALDriver+14b9
    
    
    FOLLOWUP_NAME:  MachineOwner
    
    
    MODULE_NAME: MacHALDriver
    
    
    IMAGE_NAME:  MacHALDriver.sys
    
    
    DEBUG_FLR_IMAGE_TIMESTAMP:  4d81c6e1
    
    
    FAILURE_BUCKET_ID:  0xc2_d_MacHALDriver+14b9
    
    
    BUCKET_ID:  0xc2_d_MacHALDriver+14b9
    
    
    Followup: MachineOwner
    ---------
    
    
    0: kd> lmvm MacHALDriver
    start    end        module name
    a6ff9000 a6ffc280   MacHALDriver T (no symbols)           
        Loaded symbol image file: MacHALDriver.sys
        Image path: \??\C:\Windows\system32\drivers\MacHALDriver.sys
        Image name: MacHALDriver.sys
        Timestamp:        Thu Mar 17 14:31:29 2011 (4D81C6E1)
        CheckSum:         00012D92
        ImageSize:        00003280
        Translations:     0000.04b0 0000.04e4 0409.04b0 0409.04e4
      My System SpecsSystem Spec

bad_pool_caller
Related Threads
Solved bad_pool_caller in BSOD Crashes and Debugging
My computer was in standby last night and when I woke up it was displaying this. So it turned itself on just to crash. Very microsoft-like. But this started last night before that as well. I left my computer for a few minutes to watch TV and when I came back it showed this BSoD. Restarted, did...
bad_pool_caller in BSOD Crashes and Debugging
Ive been getting a bad_pool_caller BSOD for awhile now when trying to alt+tab between games and Mozilla.
Bad_Pool_Caller in BSOD Crashes and Debugging
Good Morning folks, I've a problem about the button sleep. It's not working properly. Whenever I pressed it, the screen will eventually dim and after a few minutes it will restart. Also when I used the wireless mobile broadband it will automatically (BSOD). What can I do to resolved this...
Solved Bad_pool_caller in BSOD Crashes and Debugging
Hello everyone, Got this PC a couple of moths ago, was playing BF3 and I got a BSOD with BAD_POOL_CALLER. I don't really know if I should be worried. Anyways thanks alot, I believe I have attached the files. Edit : I have posted a new SF Diagnostic, if you don't know why, please see...
bad_pool_caller in BSOD Crashes and Debugging
Man, seems like a lot of these lately. Bad_pool_caller Dump attached :)
Bad_Pool_Caller in BSOD Crashes and Debugging
I just bought my new laptop yesterday and I keep getting this error. Here are the files
bad_pool_caller in BSOD Crashes and Debugging
Hi, I've had the error listed in the title. I've uploaded the file. Can anyone tell me what happened?
Eight Forums Android App Eight Forums IOS App Follow us on Facebook