Windows 8 and 8.1 Forums

BSOD, attempting to narrow down - Possible Memory Corrupt.

  1. #1

    Posts : 2
    Windows 8

    BSOD, attempting to narrow down - Possible Memory Corrupt.


    So I've been suffering some seemingly random BSoDs for a while now. I figured a fresh install of the OS (Win8) would assist, and it has helped significantly - but, recently I've been getting the occasional hard reset without the ability to dump any info.

    I did some driver updating and, finally, I've got it to where it'll actually produce a BSoD. Haha, I'm open to the possibility it could be RAM issues, and I'm going to do a MemTest + swap out this 8 gig stick for the stock sticks this came with to test as well, but if anyone notices any glaring issues and/or conflicting drivers, I'd be much obliged.

    Currently, the error given is SPECIAL_POOL_DETECTED_MEMORY_CORRUPTION, blaming ntoskrnl.exe. I've run into the crashing (specific instances off the top of my head): rarely when gaming, once when logging in, and most recently, when trying to run Razor's cute Game Booster program. I frequently crash however, when running my heavy texture mod laden Elder Scrolls V: Skyrim install.

      My System SpecsSystem Spec

  2. #2

    Posts : 5,139
    Win8.1Pro - Finally!!!

    Only 1 memory dump - not a lot of info to go on (I did read where you were having trouble generating memory dumps). If you are using a disk cleaning program, please stop while we're troubleshooting.

    I do not recommend using wireless USB network devices. Especially in Win7/Win8 systems.
    These wireless USB devices have many issues with Win7(and I suspect with Win8) - using Vista drivers with them is almost sure to cause a BSOD.
    Should you want to keep using these devices, be sure to have Win7/Win8 drivers - DO NOT use Vista drivers!!!
    An installable wireless PCI/PCIe card that's plugged into your motherboard is much more robust, reliable, and powerful.
    WinRing0x64.sys is found in the Stack Text. It's a driver associated with RealTemp and Corsair Link2 (the latter has been seen to have BSOD issues with Win8 on one occasion). In this case it's associated with the Razer GameBooster program. Please uninstall it - it ain't all that cute, is it? :0)

    Please update these older drivers. Links are included to assist in looking up the source of the drivers. If unable to find an update, please remove (un-install) the program responsible for that driver. DO NOT manually delete/rename the driver as it may make the system unbootable! :

    WinRing0x64.sys Sat Jul 26 09:29:37 2008 (488B26C1)
    many different programs that center around the using of the WinRing libraries (RealTemp, Corsair Link2 (known BSOD issues w/Win8), etc)

    SaiU0CCC.sys Fri Apr 23 06:59:27 2010 (4BD17D8F)
    Unknown driver - suspect it's part of Saitek device (Saitek HDD Filter Driver)

    SaiK0CCC.sys Fri Apr 23 06:59:33 2010 (4BD17D95)
    Unknown driver - suspect it's part of Saitek device (Saitek HDD Filter Driver)

    netr7364.sys Tue Oct 4 02:14:37 2011 (4E8AA44D)
    Ralink RT2501/RT2573/T2601/RT2671 Wireless Adapter (you may have a different manufacturer)

    The following is for informational purposes only.
    **************************Mon Jan 14 01:31:38.950 2013 (UTC - 5:00)**************************
    Loading Dump File [C:\Users\John\_jcgriff2_\dbug\__Kernel__\011313-31187-01.dmp]
    Windows 8 Kernel Version 9200 MP (4 procs) Free x64
    Built by: 9200.16461.amd64fre.win8_gdr.121119-1606
    System Uptime:1 days 20:08:54.636
    *** WARNING: Unable to verify timestamp for WinRing0x64.sys
    *** ERROR: Module load completed but symbols could not be loaded for WinRing0x64.sys
    Probably caused by :WinRing0x64.sys ( WinRing0x64+1407 )
    BugCheck C1, {fffff98035832ff0, fffff98035832ff4, a90004, 24}
    Arg1: fffff98035832ff0, address trying to free
    Arg2: fffff98035832ff4, address where bits are corrupted
    Arg3: 0000000000a90004, (reserved)
    Arg4: 0000000000000024, caller is freeing an address where bytes after the end of the allocation have been overwritten
    BUGCHECK_STR:  0xC1_24
    PROCESS_NAME: GameBooster.ex
    FAILURE_BUCKET_ID: 0xC1_24_VRF_WinRing0x64+1407
    3rd Party Drivers:
    The following is for information purposes only.
    Any drivers in red should be updated or removed from your system. And should have been discussed in the body of my post.
    **************************Mon Jan 14 01:31:38.950 2013 (UTC - 5:00)**************************
    WinRing0x64.sys             Sat Jul 26 09:29:37 2008 (488B26C1)
    SaiU0CCC.sys                Fri Apr 23 06:59:27 2010 (4BD17D8F)
    SaiK0CCC.sys                Fri Apr 23 06:59:33 2010 (4BD17D95)
    netr7364.sys                Tue Oct  4 02:14:37 2011 (4E8AA44D)
    HECIx64.sys                 Mon Jul  2 18:14:58 2012 (4FF21D62)
    Rt630x64.sys                Mon Jul 30 12:03:12 2012 (5016B040)
    RTKVHD64.sys                Tue Sep  4 06:22:35 2012 (5045D66B)
    intelppm.sys                Mon Nov  5 22:55:02 2012 (50988A16)
    PSKMAD.sys                  Wed Nov  7 02:56:06 2012 (509A1416)
    NNSPrv.sys                  Fri Nov  9 04:01:20 2012 (509CC660)
    NNSAlpc.sys                 Fri Nov  9 04:04:27 2012 (509CC71B)
    NNSTlsc.sys                 Fri Nov  9 04:06:46 2012 (509CC7A6)
    NNSStrm.sys                 Fri Nov  9 04:10:24 2012 (509CC880)
    NNSHttp.sys                 Fri Nov  9 04:15:59 2012 (509CC9CF)
    NNSPicc.sys                 Fri Nov  9 04:18:16 2012 (509CCA58)
    NNSProt.sys                 Fri Nov  9 04:21:41 2012 (509CCB25)
    NNSIds.sys                  Fri Nov  9 04:29:10 2012 (509CCCE6)
    NNSPop3.sys                 Fri Nov  9 04:36:55 2012 (509CCEB7)
    NNSSmtp.sys                 Fri Nov  9 04:44:36 2012 (509CD084)
    psinknc.sys                 Fri Nov  9 12:40:10 2012 (509D3FFA)
    PSINAflt.sys                Fri Nov  9 12:41:09 2012 (509D4035)
    PSINFile.sys                Fri Nov  9 12:41:51 2012 (509D405F)
    PSINProc.sys                Fri Nov  9 12:42:22 2012 (509D407E)
    PSINProt.sys                Fri Nov  9 12:42:54 2012 (509D409E)
    nvlddmkm.sys                Fri Nov 30 22:24:02 2012 (50B97852)
      My System SpecsSystem Spec

  3. #3

    Posts : 2
    Windows 8

    Thanks Usasma,

    Unfortunately, for the short term, not using the USB network device is not an option. However, after getting rid of the plague that was GameBooster, I went ahead and unplugged the USB device from its extension hub and plugged it directly into the computer. So far, no blue screens of death at all - but I was still running into a hard reset issue when running games and such. Seemingly at random, too.

    Namely, I was noticing occasional visual artifacts on a fairly new card (pink squares.) Did some research, did some testing, etc. Narrowed it down to the following.

    1.] Wasn't the card itself. Not overheating (40C under load, plenty good for a 560GTX), and after running several tests, didn't appear to be hardware.
    2.] Apparently, NVidia's 310.xx series have had various issues. I downgraded to 306.97.
    3.] Finally, after checking around, I noticed newer releases of my same card (a Twin Frozr II with a stock overclock) come with slightly updated vBios, but all they change are the stock voltage. So I upped the voltage from .975, to 1.025.

    All instability and hard resets have seemingly disappeared. Of course, I'll still be testing to see if anything does manifest, but it certainly seems like when they originally released this card, they put in a pretty nice stock cooling solution, but didn't up the voltage to match the clocks. So when a game really stresses the card, it tried to reach clocks the .975 voltage couldn't back in my machine, leading to the hard reset. This explains why less intensive games, like League of Legends, didn't do this.

    Huge kudos for the help usasma.
      My System SpecsSystem Spec

  4. #4

    Posts : 5,139
    Win8.1Pro - Finally!!!

    I'm glad that you figured it out.
    Thanks for letting us know - it'll help others who come looking for help with similar issues!
      My System SpecsSystem Spec

BSOD, attempting to narrow down - Possible Memory Corrupt.
Related Threads
Solved Several Corrupt files causeing BSOD in BSOD Crashes and Debugging
I have a brand new clean install of windows 8.1 64 bit pro. I have corrupt system files and it's causing several BSODs. So far the list is: Ntfs_File_System Bad_Pool_Header Critical_Structure_Corruption System_Service_Exception Pfn_List_Corrupt I've run dism /online /cleanup-image...
Semi Random BSOD, PFN LIST CORRUPT & Others in BSOD Crashes and Debugging
Hi, my computer had been troubling me for a while and so to eliminate possible variables I got new hard drivers and reinstalled Windows fresh. However to my surprise the BSOD's seemed to have actually gotten worse, to at least once to several times per day. I went with option 2 from the...
Long and Narrow in Browsers & Mail
Hello Every One.Just occasionally I receive mail quite large in written word and it arrives like this. As you may imagine it takes up a lot space.
PFN List Corrupt BSOD in BSOD Crashes and Debugging
I am having problems with recurrent BSOD caused by error PFN List Corrupt. I have used Memtest86 showing no memory problems after 3 passes (10 hours). I am new to the site so I hope I am doing things correctly. I appreciate any help you can give me. I have attached the collected information. Thank...
BSOD Memory.dmp in BSOD Crashes and Debugging
Hello, I followed your 'Debugging' steps and this is what I end up with: and the attached file, of course. I'll appreciate your help!!
My system was updated to Windows 8 From XP early in January however recently (the past week or so) I have been getting bsod 's. The media players we have tried always eventually go bsod. Windows media player 11 and GOM player. This suggests to me an audio issue with a driver etc. I have checked...
Attempting to repair loop after BSOD in BSOD Crashes and Debugging
Hi all Am currently overseas with my laptop and suddenly I had BSOD and my laptop rebooted. Then it started to repair and it came to a page saying it cannot find the problem to repair. The option to start in safe mode ends up attempting to repair.. I'm currently trying the 'refresh your pc'...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook