Windows 8 and 8.1 Forums


BSOD when pluging flash memory

  1. #1

    BSOD when pluging flash memory


    Hello,

    W8 instalation was done successfully. All functions working properly. Even Hw manager shows that here is no problem.

    Problem starts when Im trying to use my flash memory pen (they r working properly in other w8 or w7 pc).

    I have three usb 2 and one usb 3 (express card). No issue when plug flash to usb3 but when Im trying to use flash stick in any of remaining three usb 2 port I getting restart of laptop (HP Probook 4320s, i5, 8GB). When Im pluging usb modem, mouse or HDD there is no any issue.

    Any help please? Looks like that my usb 2 port doesnt like memory stick...

      My System SpecsSystem Spec

  2. #2


    bangalore
    Posts : 634
    Windows 8.1 professional x64 + WMC
      My System SpecsSystem Spec

  3. #3


    ok, here we go...
    thx

    problém was solved later, so I deleted a files...
    Last edited by Stechino; 10 Dec 2012 at 19:06.
      My System SpecsSystem Spec

  4. #4


    bangalore
    Posts : 634
    Windows 8.1 professional x64 + WMC


    Code:
    ********************************************************************************                                                                             *
    *                        Bugcheck Analysis                                    *
    *                                                                             *
    *******************************************************************************
    
    
    Use !analyze -v to get detailed debugging information.
    
    
    BugCheck 19, {20, fffffa8009a4c740, fffffa8009a4c800, c0c0004}
    
    
    Probably caused by : storport.sys ( storport!RaidCompleteRequestEx+51 )
    
    
    Followup: MachineOwner
    ---------
    
    
    2: kd> !analyze -v
    *******************************************************************************
    *                                                                             *
    *                        Bugcheck Analysis                                    *
    *                                                                             *
    *******************************************************************************
    
    
    BAD_POOL_HEADER (19)
    The pool is already corrupt at the time of the current request.
    This may or may not be due to the caller.
    The internal pool links must be walked to figure out a possible cause of
    the problem, and then special pool applied to the suspect tags or the driver
    verifier to a suspect driver.
    Arguments:
    Arg1: 0000000000000020, a pool block header size is corrupt.
    Arg2: fffffa8009a4c740, The pool entry we were looking for within the page.
    Arg3: fffffa8009a4c800, The next pool entry.
    Arg4: 000000000c0c0004, (reserved)
    
    
    Debugging Details:
    ------------------
    
    
    
    
    BUGCHECK_STR:  0x19_20
    
    
    POOL_ADDRESS: GetPointerFromAddress: unable to read from fffff80322171168
    GetUlongFromAddress: unable to read from fffff803221711f8
     fffffa8009a4c740 Nonpaged pool
    
    
    CUSTOMER_CRASH_COUNT:  1
    
    
    DEFAULT_BUCKET_ID:  WIN8_DRIVER_FAULT
    
    
    PROCESS_NAME:  AHDDC2_Service
    
    
    CURRENT_IRQL:  1
    
    
    IRP_ADDRESS:  000000000806a289
    
    
    LAST_CONTROL_TRANSFER:  from fffff8032208bb95 to fffff80321e95740
    
    
    STACK_TEXT:  
    fffff880`08dfa5a8 fffff803`2208bb95 : 00000000`00000019 00000000`00000020 fffffa80`09a4c740 fffffa80`09a4c800 : nt!KeBugCheckEx
    fffff880`08dfa5b0 fffff803`21ecf359 : fffffa80`09a4c750 fffffa80`09a8d080 fffffa80`06b59c00 fffff803`20206f49 : nt!ExDeferredFreePool+0xfdd
    fffff880`08dfa690 fffff803`21ecda1a : 00000000`0806a301 fffff880`08dfa7b0 fffff880`08ea1290 00000000`00000000 : nt!IopCompleteRequest+0x79
    fffff880`08dfa760 fffff880`00a42131 : fffff880`08ea1290 00000000`00000000 fffff880`08ea1000 fffffa80`09a064a0 : nt!IopfCompleteRequest+0xa5a
    fffff880`08dfa840 fffff880`00a68a84 : fffffa80`079f51a0 00000000`20206f49 00000000`00000000 fffffa80`00000000 : storport!RaidCompleteRequestEx+0x51
    fffff880`08dfa910 fffff880`00a44b5d : 00000000`00000000 fffffa80`09a066c0 fffffa80`09a066c0 fffffa80`08abfe10 : storport!RaidAdapterDeviceControlIrp+0x23f14
    fffff880`08dfa990 fffff803`2227a44f : fffffa80`08abfe10 fffff880`08dfacc0 fffffa80`08abffb8 fffff880`00000000 : storport!RaDriverDeviceControlIrp+0x8d
    fffff880`08dfa9d0 fffff803`2227add6 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : nt!IopXxxControlFile+0x7dd
    fffff880`08dfab60 fffff803`21e94753 : fffff880`08dfac50 00000000`00000000 00000000`00000000 00000000`0262e878 : nt!NtDeviceIoControlFile+0x56
    fffff880`08dfabd0 00000000`77b32ad2 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : nt!KiSystemServiceCopyEnd+0x13
    00000000`0262f128 00000000`00000000 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : 0x77b32ad2
    
    
    
    
    STACK_COMMAND:  kb
    
    
    FOLLOWUP_IP: 
    storport!RaidCompleteRequestEx+51
    fffff880`00a42131 8bc7            mov     eax,edi
    
    
    SYMBOL_STACK_INDEX:  4
    
    
    SYMBOL_NAME:  storport!RaidCompleteRequestEx+51
    
    
    FOLLOWUP_NAME:  MachineOwner
    
    
    MODULE_NAME: storport
    
    
    IMAGE_NAME:  storport.sys
    
    
    DEBUG_FLR_IMAGE_TIMESTAMP:  5010ab51
    
    
    BUCKET_ID_FUNC_OFFSET:  51
    
    
    FAILURE_BUCKET_ID:  0x19_20_storport!RaidCompleteRequestEx
    
    
    BUCKET_ID:  0x19_20_storport!RaidCompleteRequestEx
    
    
    Followup: MachineOwner
    ---------
    Is there any specific driver for your flash memory pen?
      My System SpecsSystem Spec

  5. #5


    Hi, no really. I try three different memory sticks (kingston, tdk and some noname). In all cases BSOD. I can just see for one second (maybe less) like explorer open window and than blue crash. When I plug any different type of devices via usb 2.0 as hdd or mobile broadband stick there is no problem. Im using these flash memories on different pc (os) and there is no problem, just w8 stacks.
    Strange that memory sticks only...

    There is as well e-sata port which is working fine with external hdd, even usb 3.0 (express micro card) is working properly.
      My System SpecsSystem Spec

  6. #6


    Additional information (repetition): - other devices like mobile with sd memory, mobile broadband stick with memory card, external hdd, bluetooths, etc. are working fine when they are connected to USB 2.0


    So, the problem is just when I plug in any memory flash usb stick (doesn't matter if they are branded or noname, even capacity has no influence) to USB ports. BSOD and restart following this operation and I'm really sad.

    Looks like that my notebook doesn't like to work with mass storage devices...

    Please help me gents.
      My System SpecsSystem Spec

  7. #7


    Here we go!

    as there is no answer and I'm feeling like a slave of Microsoft (to be honest, it was no bug of Microsoft) so, I have to study how to debug dmp. Then I found simillar output in different dmp file as bagavan. But I was looking closely to processes.

    Please refer to PROCESS_NAME: AHDDC2_Service.

    Directly to topic --> AHDDC2_Service.exe Windows process - What is it?

    I found that this application from Ashampoo company called HDD2 control makes my crazy! Im using a lot of products from them under W8 without problem but this one somehow maneged BSOD of W8.

    After un-installation of this monitoring tool I have to say: W8 is more stable than I was thinking of.

    Thank you to this forum I know how to debug (selfstudy) and I found myself what was a problem.

    Finally, please dont use Ashampoo HDD2 even is supported under W8, https://www.ashampoo.com/en/usd/pin/...-HDD-Control-2

    Thank you, Stechino
      My System SpecsSystem Spec

BSOD when pluging flash memory
Related Threads
Flash memory is not accessible in Drivers & Hardware
Flash Memory ScanDisk Cruzer Blade 8 GB Tried to open Flash Memory , i found error message that it's not accessible , size of it is Zero !! also it's RAW drive how to fix it ? Kindly be notified that there is date in flash memory and it's important to me ( Formatting isn't solution)
Solved BSOD Memory.dmp Error? in BSOD Crashes and Debugging
Hey, I am trying to fix a friends Laptop for her, she keeps getting what I presume is BSOD in Windows 8(I haven't any experience with Windows 8) I have tried to look at the dump file but I have struggled to open it, so If I attach it here I would appreciate any help I can be given, cheers! ...
Memory Dump BSOD (help!) in BSOD Crashes and Debugging
Hi there, I have been getting memory dump crashes (bsod and auto restarts) for the past week, this ONLY happen when I am running the game "final fantasy XIV". I have uploaded my files in a zip as per the FAQ thread. I look forward to your help! Fluxing.
Read more at: Flash successor announced | ZDNet
BSOD Memory.dmp in BSOD Crashes and Debugging
Hello, I followed your 'Debugging' steps and this is what I end up with: http://i.imgur.com/fKon6xU.jpg and the attached file, of course. I'll appreciate your help!!
My new Laptop is coming soon. It has • Windows 8 64bits 8GB DDR3 System Memory (2 Dimm) 750GB 5400 rpm Hard Drive Questions: Can I use Flash memory card instead of DVD's to make Recovery Factory image? If so, would 32 GB memory card suffice? Is flash card better than DVD...to keep. I...
I've been looking at the Surface Pro and other tablet/laptop convertible machines fitted with Win 8. The top-end models usually offer only flash memory in stead of a hard drive. The standard 128 GB flash memory available seems hopelessly inadequate for storing Win 8, a full range of programs and a...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook