Windows 8 and 8.1 Forums


BSOD on shutdown. DRIVER_POWER_STATE_FAILURE

  1. #1


    Posts : 2
    Windows 8

    BSOD on shutdown. DRIVER_POWER_STATE_FAILURE


    Lenovo W520 Laptop.
    Recently upgraded from Windows 7 to 8
    BSOD did not happen on 7.

    The crashes usually follow the same pattern:
    • The laptop goes to sleep after an extended period of inactivity, usually me going to lunch.
    • After waking the machine, the wireless mouse and keyboard are not responsive
      • Mouse and KB are Logitech, using the unifying receiver.

    • The native keyboard and trackpad on the laptop still work. I use those to reboot the computer.
    • The reboot appears to hang for several minutes.
    • BSOD


    Once or twice it has crashed on shutdown during a normal shutdown, meaning a shutdown where the wireless mouse and keyboard are still working fine.

    I have updated every driver I can find after this started happening. I've also updated the Logitech Unifying Software.

    • BIOS
    • Chipset
    • Audio
    • Card Reader
    • Fingerprint Reader
    • Mouse & Keyboard (the native ones, and the logitech setpoint drivers for the wireless ones)
    • Wireless
    • Storage (I think this is the eSATA port)
    • Video


    I have a coworker with (theoretically) identical hardware who also performed the same OS upgrade and is not experiencing the same problems.

    Any and all help is greatly appreciated.

      My System SpecsSystem Spec

  2. #2


    bangalore
    Posts : 634
    Windows 8.1 professional x64 + WMC


    The latest BSOD refers to Logitech Equad USB Driver.
    I know that you have updated to the latest one available..

    Did you try installing those drivers in compatibility mode

    Code:
    *                                                                             **                        Bugcheck Analysis                                    *
    *                                                                             *
    *******************************************************************************
    
    
    Use !analyze -v to get detailed debugging information.
    
    
    BugCheck 9F, {4, 12c, fffffa801a9f9040, fffff803fd158800}
    
    
    Can't retrieve thread context, Win32 error 0n30
    *** WARNING: Unable to verify timestamp for LEqdUsb.Sys
    *** ERROR: Module load completed but symbols could not be loaded for LEqdUsb.Sys
    Probably caused by : LEqdUsb.Sys
    
    
    Followup: MachineOwner
    ---------
    
    
    0: kd> !analyze -v
    *******************************************************************************
    *                                                                             *
    *                        Bugcheck Analysis                                    *
    *                                                                             *
    *******************************************************************************
    
    
    DRIVER_POWER_STATE_FAILURE (9f)
    A driver has failed to complete a power IRP within a specific time (usually 10 minutes).
    Arguments:
    Arg1: 0000000000000004, The power transition timed out waiting to synchronize with the Pnp
    	subsystem.
    Arg2: 000000000000012c, Timeout in seconds.
    Arg3: fffffa801a9f9040, The thread currently holding on to the Pnp lock.
    Arg4: fffff803fd158800, nt!TRIAGE_9F_PNP on Win7
    
    
    Debugging Details:
    ------------------
    
    
    Can't retrieve thread context, Win32 error 0n30
    
    
    DRVPOWERSTATE_SUBCODE:  4
    
    
    DRIVER_OBJECT: fffffa800b480b20
    
    
    IMAGE_NAME:  LEqdUsb.Sys
    
    
    DEBUG_FLR_IMAGE_TIMESTAMP:  50583e54
    
    
    MODULE_NAME: LEqdUsb
    
    
    FAULTING_MODULE: fffff88004a14000 LEqdUsb
    
    
    CUSTOMER_CRASH_COUNT:  1
    
    
    DEFAULT_BUCKET_ID:  WIN8_DRIVER_FAULT
    
    
    BUGCHECK_STR:  0x9F
    
    
    PROCESS_NAME:  System
    
    
    CURRENT_IRQL:  2
    
    
    STACK_TEXT:  
    fffff880`1e2ca4c0 fffff803`fd2ab43c : fffffa80`00000001 00000000`00000000 00000000`00000000 00000000`00000000 : nt!KiSwapContext+0x76
    fffff880`1e2ca600 fffff803`fd2a762f : fffffa80`0bbf2ba0 fffff8a0`025a2010 00000000`00000000 fffffa80`0bbf2cf0 : nt!KiCommitThreadWait+0x23c
    fffff880`1e2ca6c0 fffff803`fd589dea : fffff880`1e2ca790 fffffa80`00000000 00000000`c0000000 fffff880`009c7100 : nt!KeWaitForSingleObject+0x1cf
    fffff880`1e2ca750 fffff803`fd69a76c : 00000000`00000017 fffff880`1e2ca819 fffffa80`0b327730 fffffa80`0b1a9720 : nt!IopSynchronousCall+0x122
    fffff880`1e2ca7c0 fffff803`fd69bc25 : fffff8a0`150a7f70 00000000`00000308 fffffa80`0b1a9720 00000000`00000000 : nt!IopRemoveDevice+0x100
    fffff880`1e2ca880 fffff803`fd69a575 : fffffa80`0b327730 00000000`00000000 fffff8a0`159a1a01 fffff880`1e2ca930 : nt!PnpSurpriseRemoveLockedDeviceNode+0x15d
    fffff880`1e2ca8d0 fffff803`fd69a465 : 00000000`00000000 00000000`00000000 fffff8a0`159a1ad0 fffffa80`0b327730 : nt!PnpDeleteLockedDeviceNode+0x59
    fffff880`1e2ca910 fffff803`fd698747 : 00000000`00000000 fffff880`1e2caa70 fffff8a0`0044adc0 00000000`00000003 : nt!PnpDeleteLockedDeviceNodes+0xa1
    fffff880`1e2ca970 fffff803`fd68cb3d : fffff880`1e2cab88 00000000`00000000 fffff8a0`14537d00 fffff8a0`00000000 : nt!PnpProcessQueryRemoveAndEject+0x647
    fffff880`1e2caae0 fffff803`fd586185 : fffff8a0`150a7f70 00000000`00000000 00000000`00000001 00000005`adcb9100 : nt!PnpProcessTargetDeviceEvent+0xa1
    fffff880`1e2cab20 fffff803`fd2ba641 : fffffa80`1a9f9040 fffff8a0`0044adc0 fffff803`fd585ea0 fffffa80`19989c40 : nt!PnpDeviceEventWorker+0x2e5
    fffff880`1e2cab80 fffff803`fd229625 : 00000000`00000001 00000000`00000080 fffff803`fd2ba500 fffffa80`1a9f9040 : nt!ExpWorkerThread+0x142
    fffff880`1e2cac10 fffff803`fd267e56 : fffff880`02ea5180 fffffa80`1a9f9040 fffffa80`1a9b8040 fffffa80`06ce3040 : nt!PspSystemThreadStartup+0x59
    fffff880`1e2cac60 00000000`00000000 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : nt!KiStartSystemThread+0x16
    
    
    
    
    STACK_COMMAND:  kb
    
    
    FOLLOWUP_NAME:  MachineOwner
    
    
    FAILURE_BUCKET_ID:  0x9F_4_IMAGE_LEqdUsb.Sys
    
    
    BUCKET_ID:  0x9F_4_IMAGE_LEqdUsb.Sys
    
    
    Followup: MachineOwner
    ---------
      My System SpecsSystem Spec

  3. #3


    Posts : 2
    Windows 8


    What do you mean by install them in compatibility mode? How do I do that? I still have the .exe that installed the driver.
      My System SpecsSystem Spec

BSOD on shutdown. DRIVER_POWER_STATE_FAILURE
Related Threads
Hi guys, I'm having big trouble with my lenovo laptop. At first I'm always getting a BSOD DPSF (ntoskrnl.exe) when restarting or shutting down the laptop. Second, when I try to install/uninstall drivers or just scan for hardware changes nothing happens. I waited 3 hours the most and it...
Bsod driver_power_state_failure in BSOD Crashes and Debugging
Hello, Recently I've had a few driver power state failure BSODs - no pattern, just occasionally crashing while I'm using my laptop. SF Debug files are attached. Any help would be appreciated.
I updated to 8.1 today. Now I am facing BSOD on shutdown and very long boot time. I am unable to install nVidia driver properly as it gets stuck. Same goes for updating Intel RST. Unable to open safe mode as that requires a restart. (Shift+F8 doesn't work) msinfo get stuck at Printing. Unable...
I swapped my motherboard/CPU, and mostly got away without having to reinstall windows, save this BSOD that occurs whenever I shutdown or restart my computer. The computer hangs up on the "Shutting Down" or "Restarting" screen for a significant period of time before producing this BSOD. It seems to...
Solved BSOD on DRIVER_POWER_STATE_FAILURE (9f) in BSOD Crashes and Debugging
Hey guys. After about 2 solid days of scouring the web for solutions to this, nothing I've done has worked. I know it has to be a driver issue, and I suspect there's something that wasn't uninstalled properly (or hasn't been updated, but I can't find new updates) Here's the debug output,...
Driver_power_state_failure bsod in BSOD Crashes and Debugging
So, I'm in need of help. Not sure where else to look, I googled for days but still can't find the answer. Attached are the 2 most recent dump files. the 44-01 is the one i get most often, the other one pops up once in a while. So basically the 44-01 happens 90% of the time after the computer...
Solved BSOD driver_power_state_failure in BSOD Crashes and Debugging
First of all, my apologies if the file I attached doesn't work. I left the computer alone for 10 minutes (big mistake) while Windows 8 Log Collector was finishing and when I returned, BSOD again. When I turned on my computer again, the W8 folder was there on the desktop. Please tell me if it...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook