Windows 8 and 8.1 Forums


BSOD on every cold Boot: KERNEL_DATA_INPAGE_ERROR

  1. #1


    Posts : 2
    Windows 8 Pro 64-bit

    BSOD on every cold Boot: KERNEL_DATA_INPAGE_ERROR


    I'm baffled by the constant BSODs I'm getting on every cold boot. It doesn't give any useful information beyond the error itself : KERNEL_DATA_INPAGE_ERROR.

    With much difficulty (mucking around with symbols and paths!) I was able to run WinDbg and open the crash dump but the output doesn't help at all. Hoping you guys might be able to lend a hand; I've attached all the analysis files from the SF diagnostic tool.

    A little background on the system - was running fine before on Windows 7 without a single BSOD (hence I'm thinking its not a hardware problem) and it all started after I upgraded to Windows 8 and somewhere along the way while I was progressively loading up the various drivers for M/B, SSD, devices and office and image processing (lightroom) software.

    I'm afraid I can't pinpoint exactly when it started because I didn't notice it at first as I always switch on my PC, do something else and come back -to find the green box saying something like there was an error bla bla bla, would you like to send to microsoft. I only later realised it on a day I switched it on a waited for it to startup while sitting at the PC. Oh well...!

      My System SpecsSystem Spec

  2. #2


    Posts : 2
    Windows 8 Pro 64-bit


    Just reporting back... Turned out that there was something up with my MBR on the OS Disk (Intel SSD). Running ChkDsk /f /r fixed it after a boot-time scan (that hung precariously at 29% for some nail biting moments). So far no BSODs after that.
      My System SpecsSystem Spec

  3. #3


    Posts : 9
    Windows 8 64bit


    Hey ThaBuzzed, Did this end up permanently fixing your issue? I've got the same problem but my 29% never resumes and system just reboots.
      My System SpecsSystem Spec

  4. #4


    Japan
    Posts : 43
    Windows 8.1 Build 9431


    Quote Originally Posted by ThaBuzzed View Post
    I'm baffled by the constant BSODs I'm getting on every cold boot. It doesn't give any useful information beyond the error itself : KERNEL_DATA_INPAGE_ERROR.

    With much difficulty (mucking around with symbols and paths!) I was able to run WinDbg and open the crash dump but the output doesn't help at all. Hoping you guys might be able to lend a hand; I've attached all the analysis files from the SF diagnostic tool.

    A little background on the system - was running fine before on Windows 7 without a single BSOD (hence I'm thinking its not a hardware problem) and it all started after I upgraded to Windows 8 and somewhere along the way while I was progressively loading up the various drivers for M/B, SSD, devices and office and image processing (lightroom) software.

    I'm afraid I can't pinpoint exactly when it started because I didn't notice it at first as I always switch on my PC, do something else and come back -to find the green box saying something like there was an error bla bla bla, would you like to send to microsoft. I only later realised it on a day I switched it on a waited for it to startup while sitting at the PC. Oh well...!
    Its probably nothing to do with your rig. Its more likely to do with what Microsoft churn out.


    I get the same BSoD message time and time again on a very high end Haswell i7 Desktop rig with a GTX 780; on Windows 8.1 x64 with all updates; and I have tried all the drivers and BIOS/Chipset updates three months can cope with.


    Although the BSoD is not really frequent (the issue returns form time to time [no matter how many updates and fixes]); it does seem to be when I have MS Explorer running with Firefox and Google Chrome.


    Its like they code to smack each other in the face, but hit the customer.


    MS Windows 8.1 Pro should have a preventative measure to STOP THE BSoD BEFORE IT HAPPENS.
      My System SpecsSystem Spec

BSOD on every cold Boot: KERNEL_DATA_INPAGE_ERROR
Related Threads
Hi, Recently upgraded my PC from AMD to Intel, i.e I went from an 8350 to a 4790k. Obviously, the motherboard was changed and the upgrade went very well, no issues at all. (Maximus VII Ranger). However, about 2 weeks after the upgrade I started having this issue, when I boot from cold I get a...
Hello all, I bought a new gaming laptop from Maingear a few months ago and since the day it arrived, it has been giving me BSOD's on almost every single cold boot, either immediately after I get to the desktop, or very shortly after the boot is complete and everything is loaded. I've read the...
BSOD on Cold Boot (Please Help) in BSOD Crashes and Debugging
Hi I have built my own pc last week-(I5 3750k, Cm 212 Plus EVO, Gigabyte GA-Z77X-UD4H, Corsair 8Gb Vengeance LP, Corsair AX 850w, Windows 8 x64) It has been working fine until the last few days. :cry: I get BSOD dpc watchdog violation on start up. If i restart the system it some time goes to...
Solved New Laptop BSOD on Cold Boot in BSOD Crashes and Debugging
Background - - Bought open box HP G7-2535 -RAM upgraded from 4 to 8 - AMD A8 Quad Core Processor Every cold boot I get this screen, then everything else works fine. Did BIOS memory check which also came back fine. Please help, scratching my head. Also not sure if it's normal, but the laptop...
BSOD on every cold boot. in BSOD Crashes and Debugging
Hi there... After scouring threads and trying all fixes suggested I'm giving up and posting my own. The issue: Every boot after computer has been off for more than a minute produces a BSOD with KERNEL DATA INPAGE ERROR code. What I've tried: Windows reinstall - issue persists Drivers -...
BSOD on a cold boot! After BSOD works fine! in BSOD Crashes and Debugging
Since getting my custom built PC, I have a BSOD that occurs after about 2 minutes of getting past the welcome screen and I only have this BSOD on a cold boot. If you could please help me and give me some advice on what i should do I would be extremely grateful! I originally posted this BSOD on...
Solved BSoD persistent within 5 minutes of cold boot in BSOD Crashes and Debugging
One week-old install of Win Pro 8 as upgrade over Win 7 Pro 64-bit. All drivers updated to latest via Dell, nVidia card via nVidia site. McAfee stripped off, Win Defender only. BSoD with DPC_WATCHDOG_VIOLATION within 5 mins of power-up, persistent failure. Dump attached; grateful for your...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook