Windows 8 and 8.1 Forums


Bluescreen Error 9F caused by hal.dll

  1. #31


    Posts : 4
    Windows 7


    im glad your bsod is solved too

      My System SpecsSystem Spec

  2. #32


    Unfortunately the original BSOD occurred again. I have attached the minidump. I actually put in my replacement motherboard a few days back. So it seems to be unrelated to any motherboard components. I would appreciate if anyone can tell me if this minidump provides any new clues.

    I'm thinking of now removing other components from my computer including my Hauppauge PCIE tv tuner, and my pcie firewire card (the latter is disabled in device manager, but I may remove it anyway). Besides that I can remove my video card (but I have also changed that recently from a NVIDIA model to ATI) so I'm pretty sure it cant be that since the error occurred with both video cards in and with both motherboards.

    The only other component is memory. I will rerun memtest overnight and see what turns up. But like I said earlier it did one pass fine, but I'll do six passes as recommended. Theres really nothing else in my computer besides hard drives and dvdrom drives. And at least the dvd rom drives had no problem with my old setup. The hard drives are SMART status ok.

    Just looking at components, my top potential culprits are either the tv tuner or memory. Can software cause this issue?

    I really appreciate everyones help.

    Edit: added minidump attachment
      My System SpecsSystem Spec

  3. #33


    Posts : 197
    Win 8 Enterprise RTM


    This is a power state error (0x9f bug check code). You do not need to physically remove anything from your system; Disabling their drivers in the device manager will very likely do the job.

    The last posted minidump was a 0x9f but was non-specific.
      My System SpecsSystem Spec

  4. #34


    Quote Originally Posted by jmv2009 View Post
    This is a power state error (0x9f bug check code). You do not need to physically remove anything from your system; Disabling their drivers in the device manager will very likely do the job.

    The last posted minidump was a 0x9f but was non-specific.
    Thanks. I will disable the tv tuner in device manager. This is a pretty frustrating problem. I don't quite recall having so much trouble solving an issue like this one. I wish the BSOD would occur more frequently making it easier to troubleshoot.
      My System SpecsSystem Spec

  5. #35


    Unfortunately another BSOD even after I disabled the tv tuner in device manager. It is another 0x9f. Please let me know if the minidump provides any additional details. I am at a loss as to what is causing this. Any other ideas? Thanks again for your help.
      My System SpecsSystem Spec

  6. #36


    Fairfield County, CT
    Posts : 348
    Windows 7 SP1


    Code:
     Microsoft (R) Windows Debugger Version 6.2.9200.20512 AMD64
    Copyright (c) Microsoft Corporation. All rights reserved.
    
    
    Loading Dump File [C:\Users\Richard\Desktop\112112-6531-01.dmp]
    Mini Kernel Dump File: Only registers and stack trace are available
    
    Symbol search path is: SRV*c:\symbols*http://msdl.microsoft.com/download/symbols
    Executable search path is: 
    Windows 8 Kernel Version 9200 MP (8 procs) Free x64
    Product: WinNt, suite: TerminalServer SingleUserTS
    Built by: 9200.16442.amd64fre.win8_gdr.121023-1503
    Machine Name:
    Kernel base = 0xfffff802`bd477000 PsLoadedModuleList = 0xfffff802`bd741ae0
    Debug session time: Wed Nov 21 19:21:30.489 2012 (UTC - 5:00)
    System Uptime: 0 days 5:23:16.134
    Loading Kernel Symbols
    ...............................................................
    ................................................................
    ................................................................
    ......
    Loading User Symbols
    Loading unloaded module list
    ......................
    *******************************************************************************
    *                                                                             *
    *                        Bugcheck Analysis                                    *
    *                                                                             *
    *******************************************************************************
    
    Use !analyze -v to get detailed debugging information.
    
    BugCheck 9F, {3, fffffa800c7ab060, fffff802bd2687e0, fffffa801ab35150}
    
    Probably caused by : Unknown_Image ( ANALYSIS_INCONCLUSIVE )
    
    Followup: MachineOwner
    ---------
    
    0: kd> !analyze -v
    *******************************************************************************
    *                                                                             *
    *                        Bugcheck Analysis                                    *
    *                                                                             *
    *******************************************************************************
    
    DRIVER_POWER_STATE_FAILURE (9f)
    A driver has failed to complete a power IRP within a specific time (usually 10 minutes).
    Arguments:
    Arg1: 0000000000000003, A device object has been blocking an Irp for too long a time
    Arg2: fffffa800c7ab060, Physical Device Object of the stack
    Arg3: fffff802bd2687e0, nt!TRIAGE_9F_POWER on Win7, otherwise the Functional Device Object of the stack
    Arg4: fffffa801ab35150, The blocked IRP
    
    Debugging Details:
    ------------------
    
    
    DRVPOWERSTATE_SUBCODE:  3
    
    DEBUG_FLR_IMAGE_TIMESTAMP:  0
    
    FAULTING_MODULE: fffff802bd40b000 hal
    
    CUSTOMER_CRASH_COUNT:  1
    
    DEFAULT_BUCKET_ID:  WIN8_DRIVER_FAULT
    
    BUGCHECK_STR:  0x9F
    
    PROCESS_NAME:  System
    
    CURRENT_IRQL:  2
    
    TAG_NOT_DEFINED_c000000f:  FFFFF802BD26EFB0
    
    STACK_TEXT:  
    fffff802`bd2687a8 fffff802`bd60761e : 00000000`0000009f 00000000`00000003 fffffa80`0c7ab060 fffff802`bd2687e0 : nt!KeBugCheckEx
    fffff802`bd2687b0 fffff802`bd607651 : fffffa80`14617960 fffffa80`15d4ac70 fffff802`bd268939 fffff802`bd51d5c6 : nt!PopIrpWatchdogBugcheck+0xe2
    fffff802`bd268810 fffff802`bd51e724 : fffffa80`15d4ac70 fffffa80`15d4ab00 fffff802`bd268b18 fffff880`009c7180 : nt!PopIrpWatchdog+0x32
    fffff802`bd268860 fffff802`bd51ee15 : 00000000`00000000 00000000`00004648 00000000`00140001 00000000`00000057 : nt!KiProcessExpiredTimerList+0x214
    fffff802`bd2689a0 fffff802`bd51ecc8 : fffff802`bd76d180 fffff802`bd76ff80 00000000`0000000d 00000000`000b4a3f : nt!KiExpireTimerTable+0xa9
    fffff802`bd268a40 fffff802`bd5186f6 : fffffa80`00000000 00001f80`00ff00ff 00000000`00000000 00000000`00000002 : nt!KiTimerExpiration+0xc8
    fffff802`bd268af0 fffff802`bd51d4ba : fffff802`bd76d180 fffff802`bd76d180 00000000`00183de0 fffff802`bd7c7880 : nt!KiRetireDpcList+0x1f6
    fffff802`bd268c60 00000000`00000000 : fffff802`bd269000 fffff802`bd263000 00000000`00000000 00000000`00000000 : nt!KiIdleLoop+0x5a
    
    
    STACK_COMMAND:  kb
    
    SYMBOL_NAME:  ANALYSIS_INCONCLUSIVE
    
    FOLLOWUP_NAME:  MachineOwner
    
    MODULE_NAME: Unknown_Module
    
    IMAGE_NAME:  Unknown_Image
    
    FAILURE_BUCKET_ID:  0x9F_3_ACPI_ANALYSIS_INCONCLUSIVE
    
    BUCKET_ID:  0x9F_3_ACPI_ANALYSIS_INCONCLUSIVE
    
    Followup: MachineOwner
    ---------
    Not much more than we had before
      My System SpecsSystem Spec

  7. #37


    Posts : 197
    Win 8 Enterprise RTM


    Please review the following list:

    fffff880`01ecb000 fffff880`01ed5000 speedfan speedfan.sys Fri Mar 18 17:08:46 2011 (4D83838E)
    fffff880`03e5f000 fffff880`03e66000 lmimirr lmimirr.sys Wed Apr 11 00:32:45 2007 (461C108D)
    fffff880`04a82000 fffff880`04a8e000 ElbyCDIO ElbyCDIO.sys Thu Dec 16 23:58:13 2010 (4D0A9985)
    fffff880`04b9c000 fffff880`04bb1000 SRTSPX64 SRTSPX64.SYS Tue Nov 15 23:30:55 2011 (4EC2E81F)
    fffff880`05b0c000 fffff880`05b0df80 AiChargerPlus AiChargerPlus.sys Thu Apr 19 03:17:35 2012 (4F8F67AF)
    fffff880`05dea000 fffff880`05df9000 VClone VClone.sys Sat Jan 15 17:21:04 2011 (4D31C970)
    fffff880`06875000 fffff880`068a1000 bcbtums bcbtums.sys Thu Jan 26 19:49:03 2012 (4F21A01F)
    fffff880`0a546000 fffff880`0a54d000 RaInfo RaInfo.sys Fri Jan 04 19:57:14 2008 (477E818A)
    fffff880`06875000 fffff880`068a1000 bcbtums bcbtums.sys Thu Jan 26 19:49:03 2012 (4F21A01F)
    fffff880`0afdc000 fffff880`0afe5000 ALSysIO64 ALSysIO64.sys Sun Jul 10 02:27:45 2011 (4E18F201)



    They are third party and older than July 2012.
      My System SpecsSystem Spec

  8. #38


    Fairfield County, CT
    Posts : 348
    Windows 7 SP1


    If not already tried, go with a clean boot and see how it works. Then you can uninstalal the appropriate software
      My System SpecsSystem Spec

  9. #39


    Thanks jmv2009 and richc46. I'll try to find updates for those drivers you listed. As a last resort I'll do a clean boot and working from there enabling drivers and services one at a time.
      My System SpecsSystem Spec

Page 4 of 4 FirstFirst ... 234
Bluescreen Error 9F caused by hal.dll
Related Threads
BSOD error 0x0000009f caused by ntoskrnl.exe in BSOD Crashes and Debugging
Hello! My first BSOD occured on my 1-month-old ASUS GL551JM laptop while I was opening the Task Manager. It was running on battery while I was playing Don't Starve Together on Steam. I closed Don't Starve Together and plugged in the charger. 5 minutes later, I noticed the computer being a little...
Bluescreen Error after few hours in BSOD Crashes and Debugging
Hello Guys, i have a problem with my new Gamer Laptop (MSI GE70 2Pe Apache Pro) and get all day after few hours a bluescreen with different errors. INTERRUPT_EXCEPTION_NOT_HANDLED or an IQRL_ Error.. The last error is that 56373 I asked MSI but they didn't known how to solve that problem.....
I believe it's a problem with the amd driver but was unsure on what to do, will attach minidump and sf files. This forum has been very helpful to me in the past and I know it will be and thank you for all of your help. The computer has rebooted from a bugcheck. The bugcheck was: 0x00000124...
Windows 8.1 unknown bluescreen error in BSOD Crashes and Debugging
Hey guys, Just joined these forums because I have had ongoing bluescreen and freezing issues with windows 8.1, I just flashed the bios on my system to the recent version to eliminate that as the issue. I would appreciate any help, seems to be no rhyme or reason to my crashes.
BlueScreen Error on Windows 8 in BSOD Crashes and Debugging
Hi guys, i have a problem with my desktop PC: a week ago i've installed some new components on my desktop (motherboard, video card, RAM and power source). I've also installed an new operating system - Windows 8, and components drivers (video, audio, ethernet) - all up-to-date, compatible with...
Solved 8.1 updated caused error in logilda.dll in Windows Updates & Activation
After upgrading to 8.1, this morning, when I booted up I would get an error about the Logitech updater. I tried several things to get rid of it, as suggested on searches, but none would get rid of the error. I finally deleted the logilda.dll with my Win Patrol. Here was the error message. ...
Bluescreen error 0xC000021A in BSOD Crashes and Debugging
Hello, I have installed Windows 8 Pro on my PC and on my Laptop. The problem is since yesterday the laptop ist showing the error 0XC000021A. It only writes that my PC ran into a problem and needs to restart. After a restart it just writes the system must be recovered and if I click on "Recover" it...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook