Windows 8 and 8.1 Forums


Windows 8 BSoD after install, page_fault_by_nonpaged_area

  1. #1


    Posts : 3
    windows 7 x64

    Windows 8 BSoD after install, page_fault_by_nonpaged_area


    Hi everyone,

    Im attempting to install Windows 8 x64 edition onto my Windows 7 using the "keep files, settings and programs" feature. I have tried 3 installs and i keep getting BSoD.

    On my third attempt i was able to note down the error code, which was "PAGE_FAULT_BY_NONPAGED_AREA"

    The install seems to go fine, it the getting devices ready goes up to 100%, the getting ready goes to 100%. The BSoD seems to happen after its last automatic reboot.

    After the BSoD the computer restarts and then restores my previous edition of windows, Windows 7.


    I have followed the instructions and uploaded a BSoD log. I have also uploaded another zip file that has the logs from the "C:\$WINDOWS.~BT\Sources" Panther and logs and memdump from the Rollback folder.

    Thank you in advance.

    Edi: i forgot to mention that before the install the logmein was uninstalled, and the logmein folder in program files (x86) was deleted.
    Last edited by theninety; 06 Nov 2012 at 16:35. Reason: renamed zip file, added extra info.deleted attachments

      My System SpecsSystem Spec

  2. #2


    There are no minidump and I've never looked at a memdump file before, but here are the results for it.

    Code:
    *******************************************************************************
    *                                                                             *
    *                        Bugcheck Analysis                                    *
    *                                                                             *
    *******************************************************************************
    
    Use !analyze -v to get detailed debugging information.
    
    BugCheck 50, {fffff8037447bd40, 0, fffff88003720293, 2}
    
    *** WARNING: Unable to verify timestamp for RapportPG64.sys
    *** ERROR: Module load completed but symbols could not be loaded for RapportPG64.sys
    
    Could not read faulting driver name
    Probably caused by : RapportPG64.sys ( RapportPG64+4293 )
    
    Followup: MachineOwner
    ---------
    
    1: kd> !analyze -v
    *******************************************************************************
    *                                                                             *
    *                        Bugcheck Analysis                                    *
    *                                                                             *
    *******************************************************************************
    
    PAGE_FAULT_IN_NONPAGED_AREA (50)
    Invalid system memory was referenced.  This cannot be protected by try-except,
    it must be protected by a Probe.  Typically the address is just plain bad or it
    is pointing at freed memory.
    Arguments:
    Arg1: fffff8037447bd40, memory referenced.
    Arg2: 0000000000000000, value 0 = read operation, 1 = write operation.
    Arg3: fffff88003720293, If non-zero, the instruction address which referenced the bad memory
        address.
    Arg4: 0000000000000002, (reserved)
    
    Debugging Details:
    ------------------
    
    
    Could not read faulting driver name
    
    READ_ADDRESS: GetPointerFromAddress: unable to read from fffff80274758168
    GetUlongFromAddress: unable to read from fffff802747581f8
     fffff8037447bd40 Nonpaged pool
    
    FAULTING_IP: 
    RapportPG64+4293
    fffff880`03720293 8b07            mov     eax,dword ptr [rdi]
    
    MM_INTERNAL_CODE:  2
    
    DEFAULT_BUCKET_ID:  WIN8_DRIVER_FAULT
    
    BUGCHECK_STR:  AV
    
    PROCESS_NAME:  System
    
    CURRENT_IRQL:  0
    
    TRAP_FRAME:  fffff880009a8dc0 -- (.trap 0xfffff880009a8dc0)
    NOTE: The trap frame does not contain all registers.
    Some register values may be zeroed or incorrect.
    rax=fffff8027447dde0 rbx=0000000000000000 rcx=00000000ffffdf42
    rdx=0000000000000000 rsi=0000000000000000 rdi=0000000000000000
    rip=fffff88003720293 rsp=fffff880009a8f50 rbp=fffff880009a9150
     r8=c5000160d4800001  r9=fffff8a0000054f0 r10=fffff8027484c3e0
    r11=fffff880009a8f98 r12=0000000000000000 r13=0000000000000000
    r14=0000000000000000 r15=0000000000000000
    iopl=0         nv up ei ng nz na po nc
    RapportPG64+0x4293:
    fffff880`03720293 8b07            mov     eax,dword ptr [rdi] ds:00000000`00000000=????????
    Resetting default scope
    
    LAST_CONTROL_TRANSFER:  from fffff802745eb024 to fffff8027447d040
    
    STACK_TEXT:  
    fffff880`009a8bd8 fffff802`745eb024 : 00000000`00000050 fffff803`7447bd40 00000000`00000000 fffff880`009a8dc0 : nt!KeBugCheckEx
    fffff880`009a8be0 fffff802`744b7b6f : 00000000`00000000 fffff803`7447bd40 fffffa80`036ed3c0 fffff802`747ce541 : nt! ?? ::FNODOBFM::`string'+0x32e9e
    fffff880`009a8c80 fffff802`7447aaee : 00000000`00000000 fffffa80`053305c0 00000000`00000000 fffff880`009a8dc0 : nt!MmAccessFault+0x54f
    fffff880`009a8dc0 fffff880`03720293 : fffff8a0`00000000 00000000`00000000 fffff880`0372b290 fffff880`009a8fa4 : nt!KiPageFault+0x16e
    fffff880`009a8f50 fffff8a0`00000000 : 00000000`00000000 fffff880`0372b290 fffff880`009a8fa4 fffff803`7447bd40 : RapportPG64+0x4293
    fffff880`009a8f58 00000000`00000000 : fffff880`0372b290 fffff880`009a8fa4 fffff803`7447bd40 fffff880`03721ff0 : 0xfffff8a0`00000000
    
    
    STACK_COMMAND:  kb
    
    FOLLOWUP_IP: 
    RapportPG64+4293
    fffff880`03720293 8b07            mov     eax,dword ptr [rdi]
    
    SYMBOL_STACK_INDEX:  4
    
    SYMBOL_NAME:  RapportPG64+4293
    
    FOLLOWUP_NAME:  MachineOwner
    
    MODULE_NAME: RapportPG64
    
    IMAGE_NAME:  RapportPG64.sys
    
    DEBUG_FLR_IMAGE_TIMESTAMP:  4f1fba0a
    
    FAILURE_BUCKET_ID:  AV_RapportPG64+4293
    
    BUCKET_ID:  AV_RapportPG64+4293
    
    Followup: MachineOwner
    ---------
    It seems to be blaming Trusteer Rapport, so it would be worth uninstalling it and trying the upgrade again.
      My System SpecsSystem Spec

  3. #3


    Posts : 3
    windows 7 x64


    Will try now. Thank you.

    Edit: Worked perfectly! Booted into windows 8 fine! just had to install WLAN drivers for my usb after ^_^ Then ESET wasnt allowing any inbound traffic in windows 8 so i had to uninstall that as well!
    Last edited by theninety; 06 Nov 2012 at 16:34.
      My System SpecsSystem Spec

Windows 8 BSoD after install, page_fault_by_nonpaged_area
Related Threads
BSOD's after windows 8.1 Update 1 install in BSOD Crashes and Debugging
Hello guys, I have installed windows 8.1 Update 1 after lots of issues and now this update has become a nightmare now .I have been getting BSOD from them when I play some game (Steam Dota ) most of times was getting this BSOD KERNAL DATA INPAGE ERROR ( volmgmrx.sys) Please check my mini...
BSOD after clean Windows 8.1 install in BSOD Crashes and Debugging
So last night I decide to do a clean install to Windows 8.1, I have't installed much except for drivers, Google Chrome, Skype, and League of Legends. And I have had no problems out of it all day with playing LoL while on Skype. But i just got this BSOD not too long after one of my LoL games ended....
BSOD every time I try and install Windows 8.1 in BSOD Crashes and Debugging
Well I have had this machine for a while (Lenovo ThinkPad Tablet X201) and it came with Windows 7. I upgraded the RAM to 8 GB with cheap RAM from Ebay and it worked fine. I installed Windows 8 and very often get BSOD for Bad Pool Caller and not being able to write to blah blah, when I googled it...
windows 8.1 X64 freash install BSOD in BSOD Crashes and Debugging
hello, I have MSI laptop GT70-20D all my drivers are updated to work with windows 8.1 from offical MSI site & I have my laptop running smooth once I leave it on for downloading my windows BSOD :cry:. please I need a tech advise.
BSOD on Windows 8 fresh install in BSOD Crashes and Debugging
I just got three 320GB Seagate drives setup in RAID 0 for Linux, and I decided to also reinstall Windows 8 on my SSD since it started lagging and running slower than normal. While trying to install Win8, right after selecting a disk/partition to install to, I got a BSOD about an error in a nonpaged...
Windows 8 BSOD after fresh install in BSOD Crashes and Debugging
I have been getting a random BSOD on a fresh Windows 8 install. It doesn't seem to happen at any given time. Sometimes its right after startup and sometimes in the middle of the night when nothing is happening. I have attached my dumps if anyone can help read them. I have tried to look at them...
Solved BSOD Errors on new Windows 8 Install in BSOD Crashes and Debugging
Hello! First time poster here and I do hope I've done this correctly! I've just installed windows 8 and am getting seemingly random BSODs. No problems before on Windows 7 so i'm hoping its just a driver issue, however i'm not sure which Driver could be causing the problem. I've updated Windows...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook