Windows 8 and 8.1 Forums


Strange: IE10 x86 and x64 'About' Look Identical In Win 8 Pro x64 RTM

  1. #1


    Toronto, Canada. Born in the U.K.
    Posts : 691
    Win 10 Pro + Win 7 Ult SP1 (x64)

    Strange: IE10 x86 and x64 'About' Look Identical In Win 8 Pro x64 RTM


    Also it appears that the 64-bit one is default which I don't want. There used to be a way of selecting between the 2 versions of IE but not as far as I can find.

    BTW I'm talking about iexplore in the 2 Program Files folders. Not the dreaded Metro one which I'm trying to avoid.

    Ideas or does it matter?

      My System SpecsSystem Spec

  2. #2


    Redmond
    Posts : 651
    Windows 8.1 x64


    IE 64bit runs by default in "metro" in Windows 8 x64 given the fact that no add-ons (other than the special flash add-on) can run in the new IE make 32bit unnecessary there, and you will get the 32bit tabs inside the 64bit IE desktop browser frame container by default.

    Understanding Enhanced Protected Mode - EricLaw's IEInternals - Site Home - MSDN Blogs

    Not sure why you'd want to change that behavior either, as it provides a good mix of security and performance.
      My System SpecsSystem Spec

  3. #3


    Toronto, Canada. Born in the U.K.
    Posts : 691
    Win 10 Pro + Win 7 Ult SP1 (x64)


    Thanks for the response. Rather technical stuff to absorb for me, but makes sense, sort of. So basically the fact that only one IE is mentioned anywhere, including default programs, there's no need to worry about it. Just 'go with the flow' so to speak. LOL

    (I had even installed some software to give me a start menu and in there only one is listed although I see one in each Program Files x64 and x86) folder.

    On Vista and 7 x64 I wanted to change that behaviour simply because certain add-ons, Flash being one of them, didn't work in x64. So that obviously isn't an issue with 8.

    Thanks again.
      My System SpecsSystem Spec

  4. #4


    Redmond
    Posts : 651
    Windows 8.1 x64


    No worries - and yes, you really can't force one or the other. If you try to run the 32bit browser, it'll close it and start it as a 64bit frameproc, so even if you could get both icons it wouldn't do you any good .
      My System SpecsSystem Spec

  5. #5


    Toronto, Canada. Born in the U.K.
    Posts : 691
    Win 10 Pro + Win 7 Ult SP1 (x64)


    In a way that's a plus I suppose.
      My System SpecsSystem Spec

Strange: IE10 x86 and x64 'About' Look Identical In Win 8 Pro x64 RTM
Related Threads
I have 2 identical HP i5 desktops running 8.1 which was updated from 8. I want to put a cloned drive from computer A in the other computer B so they will appear identical with all the apps etc. I am told that I will get a configuration error in computer B because the product key in BIOS won't...
I logged onto my chrome and made a second user in the users section in the settings so that i could have my personal things and business related info on separate "accounts". Now that i have deleted the second user, the open chrome icon is still separate from the pinned icon. I'm pretty sure it's...
Hey guys, today I just found my 2 ram modules hidden in my drawers, since these 2 are the same as the 2 I am using along with 2 other modules, I decided to install the 4 identical ram modules(GEIL 1D DDR2 800mhz). Initially, I had 2 ramaxel 1g 667mhz and 2 GEIL 1G DDR2 800mhz. When I did this,...
Strange behaviour with IE10 in General Support
I have bought three Windows 8 64 bit machines and upgraded them all to Windows Pro. The three machines are different makes. All three machines have been added to our domain, and I am a domain admin. I have been trying to navigate to a secure site on a https address, one machine goes there...
Have windows 8 on a new computer, something strange is going on with IE10....so far only two sites it's happening on it gmail and facebook. With gmail - I'll go in, look at my mail, delete it, etc but then within about 5 minutes there it all is again, in my inbox showing as new mail? What the...
Strange IE10 problem in Browsers & Mail
For some reason I can't fathom, IE10 works perfectly well from my Classic Shell Desktop, but not from the Tiled Start Screen. Same with Skype. Something to do with accounts? I'm logged in as Administrator, signing in with my MS account. Can this be reset somewhere? I think I'm going off windows...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook