Windows 8 and 8.1 Forums


Chrome not working properly after factory restore.

  1. #1


    Posts : 16
    Windows 8.1

    Chrome not working properly after factory restore.


    Did a factory restore of my laptop today, Lenovo Y410p running Windows 8, 64-bit. Updated all my drivers first. Installed Chrome, the latest version. My extensions are constantly crashing. Loading pages takes a long time, some pages don't even load at all, and most of the time I have to hit enter repeatedly in the address bar for a site to load up. There is no issue with my internet, that is fine. Opening a new tab or new page usually gives me the "He's dead, Jim!" crash screen, which I have to refresh many times until the page finally loads. I don't understand what is wrong, I did a full restore and properly installed the latest version of chrome, what could be the issue?

      My System SpecsSystem Spec

  2. #2


    Posts : 4
    Windows 8.1


    Seems like there is something left after the restore that is causing it. I'd use RevoUninstaller with advanced mode to completely uninstall Chrome, and then run CCleaner afterwards. Then try installing Chrome again. I had a similar issues, and this process fixed it.
      My System SpecsSystem Spec

  3. #3


    Posts : 16
    Windows 8.1


    Thanks for the response. I actually tried a different fix, something to do with disabling the Chrome AppContainer, which seems to have done the trick. Will try your method if the problem pops up again, thanks!
      My System SpecsSystem Spec

Chrome not working properly after factory restore.
Related Threads
Hi I'm having trouble restoring an acer laptop to factory settings. I just purchased the laptop 3 days ago. I'm having multiple issues with it so I want to return it. #1 - Control panel freezes when I open it. #2 - the audio service is not running #3 - I cannot access the Update & Recovery...
Grandson's Hp 2000 notebook all screwed up so I conducted a restore to day one. Done all the updates and updated to windows 8.1 Everything working great. Only thing I can find that's not normal (to me) is that I now have 6 partitions. Not sure about what to do with that. Ron
So this is what happened: I was using ccleaner to uninstall some software that I thought I didn't need. Apparently, I accidentally uninstalled one of the system files I believe. Now, when I rebooted it, there is no taskbar (just blue and the place where you have a clock is white and blank) and...
I have never posted on a forum tho i read and educate myself from them all the time. However i really would like to get this process below correct because i dont want to corrupt any hardware from bad drivers. I purchased an ACER ASPIRE V5-571P and have had nothing but issues with windows 8. I...
Solved Create Factory Restore Disc? in Installation & Setup
Is it possible to create restore discs that return the PC back to factory state (just out of box, never turned on)? Thanks!
Restore to factory settings in Installation & Setup
I've got a Gateway laptop that is not able to boot Windows, so I'd like to restore it to factory defaults. I've looked at the tutorials here https://www.eightforums.com/tutorials/4692-system-restore-how-do-windows-8-a.html and here ...
Hello, I was trying windows 8 developer preview for my all in one desktop dell inspiron one. It works great, but I would like to reinstall windows 7 64 bit (because it can run the programs I need for school) The problem is that the original did not come with a Win 7 OS installation disc. It did...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook