Windows 8 and 8.1 Forums


Certain pages won't load in any browsers

  1. #1


    Posts : 3
    Windows 8.1

    Certain pages won't load in any browsers


    Hi everyone,

    I spent an entire day browsing thru other topics with the same problem and I tried all the solutions that were listed, but to no avail - using win 8.1, certain sites just will not load in any browsers (tried Firefox, Opera, Chrome, IE) on my desktop pc. Usually they get stuck at "connecting to.. (site)" and then time out and once in a while (in about once every 50 timeouts) result an xml parsing error ("unexpected parser state")

    Examples of the sites that won't load:
    answers.microsoft.com
    videos on vimeo.com
    any of the podcasts from The YoGPoD
    avast.com

    Some clues that might help finding the problem:
    -It's probably not the router or the ISP since all the other devices (a laptop and a tablet with win8.1 and an android phone) load the same sites without any problems, even if I connect the laptop via the same ethernet cable to the router
    -I'm able to load the sites via proxy
    -The sites won't load in windows safe mode or firefox safe mode either

    A list of things that I tried but didn't work:
    -full system scan with multiple antivirus and anti-malware programs, and then disabling all the firewall and antivirus protection
    -updating drivers
    -changing the MTU size
    -ipconfig release, dns flush and winsock reset in the command line
    -using Google's public dns (8.8.8.8/8.8.4.4) and opendns
    -creating a new windows user account
    -restarting the router, updating the firmware, changing the ethernet cable
    -disabling IPv6

    I'm getting really desperate and any kind of help would be deeply appreciated.
    Thanks in advance!

      My System SpecsSystem Spec

  2. #2



    Trying to Sith things out
    Bamberg Germany
    Posts : 2,290
    Windows 10 Pro 64 bit


    Check your add-ons(Silverlight-Flash player-that evil JAVA, Active X filtering and tracking protection)
      My System SpecsSystem Spec

  3. #3


    Posts : 375
    Win 8.1 64bit


    I'm able to load the sites via proxy

    Any possibility of local government ban ? Also, check with your ISP.
      My System SpecsSystem Spec

  4. #4


    Posts : 3
    Windows 8.1


    Quote Originally Posted by Cliff S View Post
    Check your add-ons(Silverlight-Flash player-that evil JAVA, Active X filtering and tracking protection)
    Tried it, didn't seem to work but thank you for the idea!

    Any possibility of local government ban ? Also, check with your ISP.

    Quote Originally Posted by torre View Post
    I'm able to load the sites via proxy
    Any possibility of local government ban ? Also, check with your ISP.
    The sites load on the same network on different devices, so i don't think it's ISP or country-related. But thanks for the suggestion!
      My System SpecsSystem Spec

  5. #5


    Trnava
    Posts : 683
    Win 8.1.1 Pro x64


    You do not mention, if you have checked HOSTS file?

    %SystemRoot%\System32\drivers\etc\hosts
      My System SpecsSystem Spec

  6. #6


    Posts : 3
    Windows 8.1


    Quote Originally Posted by TairikuOkami View Post
    You do not mention, if you have checked HOSTS file?

    %SystemRoot%\System32\drivers\etc\hosts
    Oh right, the hosts file, i forgot to mention, but I cleaned it. Thanks for the advice though!

    Anyway, I decided to do a reset because this thing has been bothering me way much more than it should have - i really hope that should turn out okay. Thanks everybody for your answers!
      My System SpecsSystem Spec

  7. #7


    Trnava
    Posts : 683
    Win 8.1.1 Pro x64


    How to Use Traceroute to Identify Network Problems

    What about traceroute? Input into CMD:

    tracert vimeo.com
      My System SpecsSystem Spec

Certain pages won't load in any browsers
Related Threads
Help, Help.I have Windows 8.1 - Google Chrome will not load pages at all.I bought this computer brand new about 1 month ago. Google chrome browser was working great until the day before yesterday - all of a sudden, will no longer load pages.Help - am overwhelmed with all of the posts about 8.1...
Hello everyone, im new here. I have a problem with my new laptop i have recently bought. Dell Inspiron 7537 15inch OS 8.1 (after upgrade from 8.0) 16gb RAM, Samsung SSD SM 841 256gb. Lets go to the point - When i try to load a page, usually i have to refresh that page, because i get an error like...
Kept ignoring prompts to upgrade to 8.1. Finally went ahead and did it and now neither IE or Chrome will load web pages. The programs themselves open but nothing happens. Not even a "can't load page" message. I am connected to the internet and I tried a few apps that seemed to work as normal. I've...
Hi all, apparently I have a pretty common problem but none of the solutions I have found seem to work. Here's the issue. Since upgrading to windows 8.1 I have been having issues with my internet connection. I can be browsing the web fine and then all of a I won't be able to load any pages...
Hi all im hoping that someone will be able to help, I have windows 8.1 it was working fine for a good while but now web pages can be slow loading or dont load at all, if i hit F5 some pages will then load. I have googled this problem & tried many different possible solutions but none have worked,...
I've got a new desktop which is connected to my house wifi using an USB adaptor. The signal quality is constantly at 5 bars but I find myself frequently having to refresh multiple times whenever I load a new page on the browser either because it's not loading or pictures or not showing. Pages...
Browser won't load Web Pages in Browsers & Mail
Hi, I have a new Sony Vaio Duo 11 laptop. Up to a few days ago I could connect without any problem to the internet using IE. Suddenly every time I launch Internet Explorer It will not connect to any web page (This page can't be displayed) My connection is through WiFi and the connection is...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook