Windows 8 and 8.1 Forums


Cannot copy images from Chrome/Firefox

  1. #1


    Posts : 4
    Windows 8.1 64-bit

    Cannot copy images from Chrome/Firefox


    I cannot copy images from Chrome/Firefox, Internet Explorer works fine however.
    Copying text from all browsers also works fine, the problem is just images.


      My System SpecsSystem Spec

  2. #2


    Posts : 151
    Win8 Pro


    Try disabling Adblock, then give it a shot. Although I use Adblock and Firefox as well, I myself was able to copy and paste to the clipboard with one caveat - when I initially opened paint, I could not rt.click and paste, I had to use the "Paste" button from the Ribbon bar...which pasted the image. Weirdly, after I pasted it the first time with the button, I was then able to use the rt.click menu to paste.

    If that doesn't work, here is the way I would go about troubleshooting this problem.

    1. Make sure you have the latest versions of your browsers, re-install the latest if you already have it.
    2. Start Firefox in Safe Mode - click the menu button (the three horizontal lines button - top right of browser), then the little help button at the bottom, choose "Restart Firefox with all add-ons disabled". If it works in safe mode, the problem could be an add-on, which you will need to disable one by one to find the culprit through a process of elimination.
    3. Do you have any kind of AV software running? Try disabling it.
    4. Try using "Save Image As..." in the context menu (rt. click menu) - does it work that way?
      My System SpecsSystem Spec

  3. #3


    Adelaide
    Posts : 1,338
    Windows 7 Ultimate SP1 (64 bit), Linux Mint 17.1 MATE (64 bit)

    Firefox Page Info


    In Firefox:

    • Click on the icon at the start of the URL in the Address bar
    • Click the "More Information" button
    • In the "Page Info" window, click the "Media" button
    • Choose the image from the "Address" list

    Click image for larger version

    This method allows you to capture images from sites that have blocked the context menu options.

    Also, have you tried "dragging and dropping" the image from the browser to a folder (or the Desktop)?
      My System SpecsSystem Spec

  4. #4


    Posts : 4
    Windows 8.1 64-bit


    Weird today when I turned my computer on it seems to be working again! I did not notice Adblock was installed on both firefox and chrome, but I shall try disabling it if this happens again in the future! Oh and yes every other context button worked apart from Copy Image.

    Thanks for the help .
      My System SpecsSystem Spec

Cannot copy images from Chrome/Firefox
Related Threads
Firefox and Chrome on an SP3 in Drivers & Hardware
Was told to stay away from those and use Modern IE 11 on Sp3 ad FF and Chrome hammer the battery...true?
Can it be done?
I just got a Dell with Win 8 and touchscreen. It was fine for a couple days. A half hour ago when I started it again I am unable to send email using yahoo mail in either of my browsers. I can check email fine and if I click the email in the inbox I can read it fine. When I click the onscreen right...
New Lenovo Windows 8 laptop...... I added classic shell and I actually have no problems with navigating and it feels fast. I like it. BUT, firefox and chrome will not load web pages properly and sometimes not at all.....I don't notice this happening on IE, but only fox and chrome. What happens...
Hello, I'm having an issue with my computer: After I installed VMware-player and VirtualBox, I started to get this error "The connection Was Reset" (got that on firefox, different name on Chrome since it has an error code, but leads to the same error). Weird thing is that I can still explore some...
Firefox is not showing images in Browsers & Mail
Hello, I got a new Samsung laptop because my other laptop was slow and old. However, there is something strange in this laptop :confused: the images on firefox don't appear all the time. I followed their guide: Cleared cache and cookies, it worked for few hours then images are not loading. ...
I cannot seem to get pinch to zoom to work on the metro version of either Chrome or Firefox. Anyone else find this? Is there something I need to enable?
Eight Forums Android App Eight Forums IOS App Follow us on Facebook