Windows 8 and 8.1 Forums


Specific website blocked on Windows 8.1

  1. #11


    Posts : 10
    Windows 8.1


    Yeah, I had already tuned off Smart Screen, and in FireFox I already set it to not follow system settings when connecting. Still no luck getting the page to load. Is there anything else at the system level that would block a website, like a registry setting or something?

      My System SpecsSystem Spec

  2. #12


    Canada
    Posts : 1,950
    windows 8.1 Update 1 Pro 64bit


    Firefox has an add-on called Blocksite which can block certain websites. Also look for any site quarantined by any security program you have installed be it an AV or malware program.
      My System SpecsSystem Spec

  3. #13


    Posts : 10
    Windows 8.1


    I only have three FireFox add-ons, and none of them are site blockers. I checked my AV again, but like I said earlier, I had tried shutting it off completely to no effect. I even shut off Windows firewall to see if that may have been the culprit.
      My System SpecsSystem Spec

  4. #14


    Canada
    Posts : 1,950
    windows 8.1 Update 1 Pro 64bit


    As a test, restart Firefox in Safe Mode using Help > Restart with Add-ons Disabled In the dialog, click "Start in Safe Mode" (not Reset).
    Any difference?
      My System SpecsSystem Spec

  5. #15


    Posts : 10
    Windows 8.1


    I tried that, no dice. Part of what's driving me crazy is that things would prevent from loading in IE wouldn't have any effect on FireFox, and vice-versa. The only system wide method that I know of is the HOSTS file, and I've ruled it out.
      My System SpecsSystem Spec

  6. #16


    Posts : 2,130
    Windows 8.0 x64


    Just for grins I would do
    nslookup deviantart.com

    in an Admin command prompt on as many devices as you can. See if the IPs returned are all the same.
    If the 8.1 is different you could try flushing the dns cache 3 or 4 times then logging off, and back on.
      My System SpecsSystem Spec

  7. #17


    Posts : 10
    Windows 8.1


    The XP and WIn8 both showed 199.15.160.100
      My System SpecsSystem Spec

  8. #18


    Posts : 2,130
    Windows 8.0 x64


    Quote Originally Posted by burnedblack View Post
    The XP and WIn8 both showed 199.15.160.100
    So much for that theory. Just out of curiosity on W8 try entering this in the browser:
    deviantART: where ART meets application!

    See if it shows anything. I have tried one site that times out or hangs but if I put in the IP instead of the url it works. I have no idea why.
      My System SpecsSystem Spec

  9. #19


    Canada
    Posts : 1,950
    windows 8.1 Update 1 Pro 64bit


    Side Note: regarding automatic reply following this thread from Eight Forums as to the last 2 posts sent (as one message) to me.
    I use Microsoft Outlook:

    " i: This might be a phishing message and is potentially unsafe. Links and other functionality have been disabled. Click here to enable functionality (not recommended) "

    Not sure if this was a hiccup or is there really something weird with the links provided!
      My System SpecsSystem Spec

  10. #20


    Posts : 10
    Windows 8.1


    I tried the DNS and IP address, neither worked. Sometimes on IE it will take you to a Google search page where I can view the cached version, but when you try the live link, you get nothing.
      My System SpecsSystem Spec

Page 2 of 3 FirstFirst 123 LastLast
Specific website blocked on Windows 8.1
Related Threads
I mistakenly told IE 11 to NOT remember a password for one specific web site, and I want to reverse that decision for the site. All other sites that I have saved a password for are working fine, and I also want IE to prompt me to save a password for the one specific site I messed up on! Help?
So I was browsing the web, looking for a way to disable the Start background for a certain user (he keeps toying around with windows 8) and other permissions too. Most things I disabled were meant to be used with gpedit.exe, but I used a user Snap-In in mmc.exe. However, I and some other people...
I have an application that is receiving connections from the internet on port 4443. It was working 100% but stopped all of a sudden. The port forward is correct on my FritzBox 7390 router and my firewall is disabled as well as Bitdefender. I have no AV installed. When I format my pc it works and...
Windows Store blocked by server in Network & Sharing
I am setting up an Acer Iconia that has Windows 8 installed and after setting up the server connection I can't access Windows Store. The message i get is: "Your network proxy doesn't work with Windows Store." I have changed firewall settings to allow the tablet through the firewall but still get...
I have the Windows 8 Consumer build 8250 installed on my Toshiba NETBOOK. Everything is all dandy except certain features on certin websites. I am unable to actually upload pictures to flickr. Like when I click the "Choose files to upload" nothing happens, no box allowing me to choose the...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook