Hi all, apparently I have a pretty common problem but none of the solutions I have found seem to work.

Here's the issue. Since upgrading to windows 8.1 I have been having issues with my internet connection. I can be browsing the web fine and then all of a I won't be able to load any pages other than Google. I have tried the drivers from Realtek, the drivers provided by gigabyte (my motherboard manufacturer), as well as the drivers from Windows. None of these seem to fix the issue.

I also have a Mac, Surface pro 2 (windows 8.1), android phone, and iphone. None of these devices seem to have the issue so I think we can also rule out the router and ISP. I have tried the changing my DNS to and to no avail. Restarting my system seems to fix the issue for a while. Sometimes for hours, sometimes minutes. I have also changed the MTU via cmd to 1492 but after checkingit right now its back to 1500 (The whole MTU bit was new to me but i tried it just to try all the options. I get what it does in the most basic form)

If anyone else knows some way of fixing the issue, please let me know.

Many thanks in advance.

System specs:
Windows 8.1
Motherboard: Gigabyte GA-Z68X-UD3H-B3
Currently installed Lan driver version: 8.30.328.2014