Windows 8 and 8.1 Forums


Webpages take long to load no matter what browser I use

  1. #1


    Posts : 1
    Windows 8.1

    Webpages take long to load no matter what browser I use


    I have Windows 8 and no matter what browser I use, it takes a long time to load any page on a website. It had worked great until about a month ago. We have two other computers in the house (one with XP and one with 7) they seem not to have issues, so I don't think it is a connection issue. The XP is a laptop, the 7 is a desktop. I was wondering if others have had this issue and how did it get solved.

      My System SpecsSystem Spec

  2. #2


    Harrisonburg, Va.
    Posts : 10,488
    Windows 8.1.1 Pro with Media Center


    My pages take a long time to load,but that is because Avast antivirus scans them before allowing them to load.

    Do you use an antivirus that scans them too ?
      My System SpecsSystem Spec

  3. #3


    Quote Originally Posted by David Bailey View Post
    My pages take a long time to load,but that is because Avast antivirus scans them before allowing them to load.

    Do you use an antivirus that scans them too ?
    Avast is not slowing down page loading to any degree that can be seen by naked eye (in my system) but some other AVs may. Some tme ago however I somehow ended up with AVG Page protect (or something of that nature) as an addon to FF and IE and it slowed everything considerably. Funny thing is that I did not have any other AVG products installed. After having a fight of it to remove it (it could be disabled only) everything is back to normal. This page opens in less than 2 seconds with 12/3 Mbps internet connection.
    I'd first do a thorough check for malware, it's probably the reason for slowdowns.
      My System SpecsSystem Spec

  4. #4


    Quote Originally Posted by ssroe View Post
    I have Windows 8 and no matter what browser I use, it takes a long time to load any page on a website. It had worked great until about a month ago. We have two other computers in the house (one with XP and one with 7) they seem not to have issues, so I don't think it is a connection issue. The XP is a laptop, the 7 is a desktop. I was wondering if others have had this issue and how did it get solved.
    You could try flushing dns:
    DNS Resolver Cache - Flush and Reset in Windows
      My System SpecsSystem Spec

  5. #5


    Hafnarfjörður IS
    Posts : 4,376
    Linux Centos 7, W8.1, W7, W2K3 Server W10


    Hi there.

    Check that there isn't a Proxy set in the Internet settings (Tools==>Internet Options==>connections) -- if there is this could force IE to take longer than usual (or other browsers too).

    Cheers
    jimbo
      My System SpecsSystem Spec

Webpages take long to load no matter what browser I use
Related Threads
Hi, so after using google chrome for about a year and having no problems whatsoever, just today I encountered one where the initial startup takes a very long time about 10-15 minutes, and this is only on initial launch, as when I keep chrome open any new chrome windows I launch load normally which...
I'm running windows 8.1 and any webpage that has a .pdf extention will not display. I get a black X in the upper left corner or just a white page. I've tried IE & Firefox neither one will open a PDF. However, I installed Google Chrome and it will open PDF's. Any help? Thanks!
I used to have this problem long time ago, it disappeared, but it came back again. Basically, whenever I load up a webpage, via chrome, internet explorer or anything, sometimes it would fail to go to the website entirely and give me an erorror that the website is not found without even checking...
Hello friends, My internet is currently not loading pages properly since I starting using a Telsta modem that came with the internet bundle (T-Box and Modem set). My D-Link modem stopped working due to old age I guess and doesn't turn on anymore. So I set-up the Telstra modem (with the included...
System tray apps take a long time to load in Performance & Maintenance
Windows 8 boots up pretty quickly, but it takes a notably long time (compare to Windows 7) for it to show up the system tray applications. In Windows 7 it is almost instant. http://www.youtube.com/watch?v=7bhC8Bt2lW0 Is this Microsoft's problem or the app maker's problem? Also, the apps...
Hello, I just built a PC for my boss with Windows 8x64 and he is running into a major issue. No matter what web browser he tries to use (internet explorer, firefox, chrome) he can never load webpages. They constantly time out after attempting to load for several minutes. He definitely...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook