Windows 8 and 8.1 Forums


Google Chrome Pages Do Not Load at All Windows 8.1

  1. #1


    Posts : 4
    Windows 8.1

    Google Chrome Pages Do Not Load at All Windows 8.1


    Help, Help.I have Windows 8.1 - Google Chrome will not load pages at all.I bought this computer brand new about 1 month ago. Google chrome browser was working great until the day before yesterday - all of a sudden, will no longer load pages.Help - am overwhelmed with all of the posts about 8.1 issues.Does anyone have the link to where Microsoft may have posted a fix to this?Thank you so, so much.

      My System SpecsSystem Spec

  2. #2


    Harrisonburg, Va.
    Posts : 10,488
    Windows 8.1.1 Pro with Media Center


    Try uninstalling & reinstalling Chrome.
    It might help.
      My System SpecsSystem Spec

  3. #3


    I never had problems with Chrome on Win 8.1, but what David Bailey said should work.
      My System SpecsSystem Spec

  4. #4


    Posts : 4
    Windows 8.1

    Windows 8.1 - Google Chrome Not Loading Pages


    Thanks all. I tried it - no luck though.This appears to be a complicated issue given all the posts on it.I'm about at my wits end with this thing...
      My System SpecsSystem Spec

  5. #5


    Harrisonburg, Va.
    Posts : 10,488
    Windows 8.1.1 Pro with Media Center


    Have you tried this:

    Click image for larger version
      My System SpecsSystem Spec

  6. #6


    Harrisonburg, Va.
    Posts : 10,488
    Windows 8.1.1 Pro with Media Center
      My System SpecsSystem Spec

  7. #7


    Posts : 2,627
    win8.1.1 enterprise


    hello, does Internet Explorer work for you .
    Google chrome is a 3rd party program and was installed on your Windows ,therefore not a Microsoft problem ,but a google problem ,I don't use chrome now but have used it in the past on win8 with no problems
      My System SpecsSystem Spec

  8. #8


    Joisey
    Posts : 315
    Windows 8.1 consumer 64 bit


    You can reset Chrome back to its initial installed state. Got to Settings, at the bottom of the page click "show advanced settings", and at the very bottom click "reset browser settings".
      My System SpecsSystem Spec

  9. #9


    Posts : 4
    Windows 8.1


    Quote Originally Posted by David Bailey View Post
    Have you tried this:Click image for larger version
    Hi. I can't even get the menu to display like you have it. How do I get this menu to come up?Thanks.
      My System SpecsSystem Spec

  10. #10


    Posts : 4
    Windows 8.1


    David,Thanks. What keystrokes are necessary to get the display menu (in your post above) to display? I can't figure out how to get this to display?
      My System SpecsSystem Spec

Page 1 of 2 12 LastLast
Google Chrome Pages Do Not Load at All Windows 8.1
Related Threads
Hi, so after using google chrome for about a year and having no problems whatsoever, just today I encountered one where the initial startup takes a very long time about 10-15 minutes, and this is only on initial launch, as when I keep chrome open any new chrome windows I launch load normally which...
Hello everyone, im new here. I have a problem with my new laptop i have recently bought. Dell Inspiron 7537 15inch OS 8.1 (after upgrade from 8.0) 16gb RAM, Samsung SSD SM 841 256gb. Lets go to the point - When i try to load a page, usually i have to refresh that page, because i get an error like...
Kept ignoring prompts to upgrade to 8.1. Finally went ahead and did it and now neither IE or Chrome will load web pages. The programs themselves open but nothing happens. Not even a "can't load page" message. I am connected to the internet and I tried a few apps that seemed to work as normal. I've...
Hi all, apparently I have a pretty common problem but none of the solutions I have found seem to work. Here's the issue. Since upgrading to windows 8.1 I have been having issues with my internet connection. I can be browsing the web fine and then all of a I won't be able to load any pages...
I've got a new desktop which is connected to my house wifi using an USB adaptor. The signal quality is constantly at 5 bars but I find myself frequently having to refresh multiple times whenever I load a new page on the browser either because it's not loading or pictures or not showing. Pages...
Hi, not sure if I posted in the right section but just wanted to ask some help on how to fix Chrome as it is taking an unusually long time to load. It started just today a few hours ago when I logged into Facebook here in my laptop, I normally don't use it in my laptop as I just use it on my phone...
Browser won't load Web Pages in Browsers & Mail
Hi, I have a new Sony Vaio Duo 11 laptop. Up to a few days ago I could connect without any problem to the internet using IE. Suddenly every time I launch Internet Explorer It will not connect to any web page (This page can't be displayed) My connection is through WiFi and the connection is...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook