Windows 8 and 8.1 Forums

8.1 slow loading

  1. #1

    8.1 slow loading


    Hi,
    This topic must be located here somewhere as it's such a common problem but I don't see it. Since installing Windows 8.1 (and I can't go back to 8 for various reasons) web pages quite frequently simply hang as they try to connect. I have to wait, at times, for as long as 30 seconds before it loads. Sometimes it even times out. I've noticed many comments re this problem online, with a myriad of possible solutions-too many to investigate/try. When I use Opera, which is going through changes that irritate me hence I'm not going to be using them any longer, the pages load quickly. But certainly not with Firefox-my customary browser.
    The reason that I'm posting this is that one action invariably corrects the problem and loading is immediate. But it's a drag and am hopeful that someone armed with forthcoming info will have some idea as to how to remedy the situation. Sorry, I tend to ramble at times. All I have to do, while the page is trying to connect, is to hit reload. Every time it works! But it's not right to have to do that plus I'm lazy. Does that tell someone anything? Any thoughts? Thanks!

      My System SpecsSystem Spec

  2. #2


    Posts : 2,627
    win8.1.1 enterprise


    hello,and welcome to eightfourms ,did you try disableing all addons and plugins In firefox ,to see if it changes
      My System SpecsSystem Spec

  3. #3


    Quote Originally Posted by caperjack View Post
    hello,and welcome to eightfourms ,did you try disableing all addons and plugins In firefox ,to see if it changes
    Thanks for the welcome and a huge thank you for the suggestion. I disabled around 20 plug ins and add ons and then was able to immediately open the 8 sites that I tried. Yea! Now through the 'ol process of elimination I'll have to discover who the culprits is. Thanks so much!
      My System SpecsSystem Spec

  4. #4


    Posts : 2,627
    win8.1.1 enterprise


    Quote Originally Posted by odeek9 View Post
    Quote Originally Posted by caperjack View Post
    hello,and welcome to eightfourms ,did you try disableing all addons and plugins In firefox ,to see if it changes
    Thanks for the welcome and a huge thank you for the suggestion. I disabled around 20 plug ins and add ons and then was able to immediately open the 8 sites that I tried. Yea! Now through the 'ol process of elimination I'll have to discover who the culprits is. Thanks so much!
    your welcome and yes the process of elimination is next ,add them back one by one ,and some you can decide if you really need them and maybe just delete those
      My System SpecsSystem Spec

8.1 slow loading
Related Threads
Hi there ! I have found little issue, that when i run Windows Explorer and browse folders, it takes very long time to open folder content, about 10 sec. (see picture). That's just when i power on computer or restart, after first slow loading folders, then works fine. I found that on both...
windows 8.1 startup loading too slow in Performance & Maintenance
Hi everyone, I have windows 8.1 professional version x64, upgraded from windows 8, and I made the setup one year ago, when I got this computer, but now slowly, this system turn to be slow when I open my session, and since a few days very slow, like I have to wait at least 5 minutes, can I work...
Hi There!, So the problem is as i said when i play a game like GTA iv first things are workinglike a charm and then after 30 min the textures will load really slowly and that happened like before a week ago, So anyone can help me. Thanks.
Solved Windows 8.1 slow icon loading in Performance & Maintenance
So my problem is, that when I start Windows, my Local Disk D folders (where I keep my pictures, music etc.) loads slowly. Basically when I open this folder, there is no green loading thing, but just some icons don't show up. Some are grey (blank) icons and some are entirely without icons. It...
I am my wits end, all my searches has not picked up anything relevant enough… By “Slow” I mean from 20-30 seconds to X minutes, or never... WIN 8.1.0 STD with IE 11 – and Chrome - under Classic Shell on HP/Compaq Desktop 100 (1,48/8GB) F-Secure 1.99. When disabled for testing, no change...
Hi all!!! I have a problem when i try to go to mp in cod2 is getting very long time to get to the game in mp?? what can the problem be??? i use windows 8.1 with the lates drivers...
Slow Youtube video loading in Browsers & Mail
Hi. I have installed Windows 8 professional. With internet browsers (I mainly use Chrome, but I tried IE too) and metro apps I experience this issue, which is that after watching a couple of youtube clips other youtube clips that I would like to watch takes forever to load. In order to fix this...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook