Windows 8 and 8.1 Forums


Google Chrome on initial startup takes too long to load

  1. #1


    Posts : 5
    Windows 8 Pro 64-bit

    Google Chrome on initial startup takes too long to load


    Hi, so after using google chrome for about a year and having no problems whatsoever, just today I encountered one where the initial startup takes a very long time about 10-15 minutes, and this is only on initial launch, as when I keep chrome open any new chrome windows I launch load normally which is nearly instantly. I have done every procedure here Google Groups though not separately and it still takes an incredibly long time for chrome to load on initial launch. Any help would be greatly appreciated!

      My System SpecsSystem Spec

  2. #2


    Posts : 2,191
    Windows 8.1


    Hello heatman323,

    There's an awful lot to read there so I would suggest that you list the specific things you have tried here to make it easier on those trying to assist you. You might want to also include any additional information that could be considered as a triggering event (such as just downloaded a bunch of Windows Updates, etc). Good luck.
      My System SpecsSystem Spec

  3. #3


    I've been experiencing the same thing on my desktop....on my initial Chrome startup, whether I click on it right after system boots up or 10 minutes later.....it takes it a good 20 seconds to load up. After that it's instantaneous. On my laptop with the same settings (it's synced)....it's fires right up on it's initial startup. So I'm really confused and open for suggestions.
      My System SpecsSystem Spec

  4. #4


    Posts : 5
    Windows 8 Pro 64-bit


    It was when I posted a file on Facebook from dropbox, I'm pretty sure both were first visits here on my laptop as I normally upload/post right after being given the activity(college) on our lab. I remember I shut it down after and the next time I opened my laptop it had the 10 minutes wait on Chrome.

    EDIT : What made it worse is I cant remove/uninstall Chrome as there's an error popping up though I didn't pursue it anymore as I read from other people experiencing the same thing that reinstalling didn't work. Looking to give it a shot though, if anyone knows a safe program that helps uninstall/remove programs please tell, thanks.
      My System SpecsSystem Spec

  5. #5


    Posts : 2,191
    Windows 8.1


    Here is a "manual uninstall" method from the Google Chrome help desk but I would advise a system image backup before attempting this procedure:

    https://support.google.com/chrome/answer/111899?hl=en

    Good luck.
      My System SpecsSystem Spec

  6. #6


    Posts : 5
    Windows 8 Pro 64-bit


    It warned me about modifying Windows Registry, I'm not familiar with it should I proceed to Step 1? Also when it advised me to backup my registry seems the steps for it were for XP user.
      My System SpecsSystem Spec

  7. #7


    Posts : 2,191
    Windows 8.1


    Quote Originally Posted by heatman323 View Post
    It warned me about modifying Windows Registry, I'm not familiar with it should I proceed to Step 1? Also when it advised me to backup my registry seems the steps for it were for XP user.
    Hi heatman323,

    If you are unsure at this point, I would advise you to seek advice from either the Google Help Desk or the Google Forum directly because, if I were in your shoes, and I were uncertain, those two places might be the best resources to get the quickest answer. Normally, I would be able to review the .reg file and advise accordingly; however, I looked at it and it appears to have many unfamiliar complexities. Alternatively, you can leave this thread open for additional input from others users and it would be especially great if one would respond with something like "I tried that fix and it worked for me!" Good luck.
      My System SpecsSystem Spec

  8. #8


    Posts : 5
    Windows 8 Pro 64-bit


    I was already planning to start working on your advice 2cents but I suddenly got Chrome to launch quickly again! It was when I was playing a game(Bastion) and clicked on the link to their soundtrack in game, then I remembered my default browser Chrome takes 10 minutes to launch but to my surprise it launched Chrome within seconds of clicking the link! Now even if I close Chrome it still launches quickly. Thanks though to everyone who offered help, seems clicking a link to initially launch Chrome did the trick
      My System SpecsSystem Spec

  9. #9


    Posts : 1
    Windows 8.1


    Guys, I am having the exact same problem. And I have tried uninstalling and reinstalling it. MANY TIMES !! But it's the same stuff all over again. Can anyone please help me out?? It gets really frustrating !! And it takes a really really long time to uninstal and reinstall too !!

    P.S - I am a bit of noob in all this, so please try and explain your answers in the simplest manner. Thank you
      My System SpecsSystem Spec

Google Chrome on initial startup takes too long to load
Related Threads
Help, Help.I have Windows 8.1 - Google Chrome will not load pages at all.I bought this computer brand new about 1 month ago. Google chrome browser was working great until the day before yesterday - all of a sudden, will no longer load pages.Help - am overwhelmed with all of the posts about 8.1...
Windows takes 1m 20s to load startup items in Performance & Maintenance
Hello I have had my Windows 8.1 Pro x64 install since February. Now I think it is time to deal with this once and for all. I have an extremely powerful computer, 3930k, 64gb ram, RIVE, 840 Pro SSD so hardware is not the problem. I recently got another Windows 8 (enterprise) laptop (not...
Win 8 fails to load 2 apps on initial start up. Razr Game Booster and Acronis Scheduler.If I do an immediate Re Start both apps will load correctly. SFC tells me no problems. Event log says Acronis failed to start, nothing listed for Razr app. Any body run into anything like this ? Any...
Photos app takes too long! in Software and Apps
Hey all, After a clean install of Windows 8 Pro and upgrading to 8.1 Pro immediately after, I noticed that the Photos app takes a very long time to load a photo that I opened from the Desktop. When double clicking a picture from the Desktop, the Photos app splash screen comes up and stays like...
Hi, not sure if I posted in the right section but just wanted to ask some help on how to fix Chrome as it is taking an unusually long time to load. It started just today a few hours ago when I logged into Facebook here in my laptop, I normally don't use it in my laptop as I just use it on my phone...
Windows 8 takes too long to shutdown. in Performance & Maintenance
Windows 8 which I installed recently (from factory recovery image) suddenly now takes too long to shutdown. Around 2 minutes and 20 seconds. I tried disabling and enabling "Fast Startup" but that didn't affect the shutdown time. Also reduced the "WaitToKillServiceTimeout" from 5000ms to 3000ms...
Read more at source: Google Chrome takes spell checking into the cloud | ZDNet
Eight Forums Android App Eight Forums IOS App Follow us on Facebook