Windows 8 and 8.1 Forums


No Internet Browser Works Properly

  1. #11


    Posts : 520
    Windows 8, x64, DP8102 - Win7 Ultimate x64, Dual Boot


    Only when you have legacy computer applications relying on NetBios.

    If you don't have 'em, disable NetBios over Tcpip.

      My System SpecsSystem Spec

  2. #12


    Appelhülsen Germany
    Posts : 189
    Windows 7 and Windows Developer Dual efi boot


    It sounds to me like your internet connection is OK can you download updates to windows?
    Go to Control Panel, Programs, Turn Windows features on or off and check that Microsoft .Net Framework 3.5.1 is enabled

    Click image for larger version
      My System SpecsSystem Spec

  3. #13



    Am I int the right place?
    Helsinki
    Posts : 340
    Windows 7 x64 Home Premium / Commodore OS Vision / Windows 8 Release preview


    What virus control/ firewall do you have, go to the settings of your antivirus program and disable the firewall. After that open your Action center and it will require you to enable windows firewall (enable it and try to connect to internet)
      My System SpecsSystem Spec

Page 2 of 2 FirstFirst 12
No Internet Browser Works Properly
Related Threads
http://i62.tinypic.com/14bl5ee.png http://i57.tinypic.com/5xvsit.png This is weird. I use Firefox as my main browser (but have Internet Explorer as default browser so I can stay in touch mode in Metro Apps), but now I can't launch Internet Explorer directly! It's not listed in the apps list, and...
Good morning everyone, Here is my problem. My web browsers only seem to work when Im downloading something with utorrent. If I stop utorrent from downloading, my browser(chrome) no longer loads a website or loads extremely slow. When Im downloading something on utorrent everything is fine,...
Lately I have a problem with the internet :/ :the pages I try to open are very slow, sometimes I get a blank page (no matter how much I wait) or in the upper left corner appears this : ''https://apiluckyleapnet-a.akamaihd.net/gsrs?is=cbslugp7&bp=BAS&g=52b39c89-a2d0-48f3-827d-a2375fefea83''. Or it...
I recently encountered a problem where my browsers (IE and Firefox) and email stopped working. I know I have an internet connection - I can ping Google for example. And I have other laptops that are working fine. The weird thing is when I reboot I can sometimes use the browser or email but after a...
I've recently upgraded to Window's 8.1 , I'm on my 3rd reinstall but still can't get IE 11 metro functioning properly, the dudes at Microsoft support keep making a mess so I then have to keep reinstalling. Nobody knows how to fix this problem! Every time I start the machine and run IE metro it...
Solved No internet browser works!!! in Browsers & Mail
I have a new Sony Vaio which i bought three weeks ago, and obviously it's loaded with Windows Eight. I'm living in Italy this year for work, and when I bought it I was just at home for the Easter Weekend. I had everything set up on it in-store (Livedrive, Norton, Microsoft Office, Skype, iTunes...
I have just solved the Bad Pool Caller/Header BSOD bug (after corrupt Kaspersky installation). At the same time when the BSODs started to pop up my internet connection stopped to work. I use wifi and it displays that the connection is working. All web browsers cant display pages. Chrome suggests to...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook