Windows 8 and 8.1 Forums


Chrome and mailto link problem

  1. #1

    Chrome and mailto link problem


    Has anyone else been having this problem? I'm using Chrome stable version. For the last month or so, I've been getting this popup almost every time I load Gmail. It happens multiple times per session. It happens if I navigate to Gmail from another page or from a fresh start of the browser. I've tried clearing the cache and disabling all extensions and running Chrome as administrator. It happens in both desktop and Windows 8 mode. It's getting to be really annoying.

    Click image for larger version

      My System SpecsSystem Spec

  2. #2


    Posts : 22,565
    64-bit Windows 10


    Hello Rob,

    You should be able to go into Default Programs and set "Google Chrome" to be the default program with all of it's associations to also make the MAILTO protocol it's default as well.

    Default Programs - Set Your Default Programs in Windows 8


    The only issue is, that with Google Chrome set as the default web browser instead of Internet Explorer, you will no longer have the IE10 Metro tile on the Start screen.

    https://www.eightforums.com/tutorials...ndows-8-a.html

    Hope this helps,
    Shawn
      My System SpecsSystem Spec

  3. #3


    Thanks. Actually it looks like Chrome was already set as default for all of it's available associations, including mailto, but the message still pops up. I also have Gmail chosen as the default handler for mailto in the Chrome settings (Settings/Show advanced settings/Privacy/Content settings/Handlers). However, disabling handlers completely in the Chrome settings seems to have stopped the pop up from appearing.
      My System SpecsSystem Spec

  4. #4


    Posts : 22,565
    64-bit Windows 10


    That's great news.

    I suppose it's due to that the MAILTO protocol is usually associated to an email client program instead.
      My System SpecsSystem Spec

  5. #5


    There must have been something that changed in either a recent Chrome update or Win8 update. I've had that mailto handler setting enabled ever since it was added to Chrome. It was never caused a problem in Win 7, or in Win8 either, up until recently.
      My System SpecsSystem Spec

  6. #6


    Posts : 22,565
    64-bit Windows 10


    That very well could be as well, but glad you got it sorted for now.
      My System SpecsSystem Spec

Chrome and mailto link problem
Related Threads
Hello everyone, When ever I click a mailto link in either Chrome, IE, Firefox and Opera it opens up a new chrome browser window. Before I installed windows 8 I had it opening up Outlook 2010 new email, now it opens up a new Chrome browser window. How do I change it in windows 8 to when I...
Google Chrome problem in Browsers & Mail
Hi guys, I have a problem with Google Chrome, when I try to sign into chrome it comes up saying "the server refused the connection". I have tried resetting chrome to the default settings...no luck with that! I tried un-installing and re-installing Chrome...No luck there either! Any help...
Hi I had a driver problem with tp-link tl wn722n in windows 8. (solved myself but tried all the things on the internet) The errors I got were: Windows encountered a problem installing the driver software for your device Windows found driver software for your device but encountered an error...
Read more at: No text? No problem for Chrome's search by image | Business Tech - CNET News
I have a problem in Google Chrome on the site YouTube see the picture: 13145 The picture on the left you can see I do not see a preview of the videos that Black ... And I can not comment because I click and nothing happens ... I tried to uninstall and re-install chrome and still not working.
Add MAILTO in context menu in Browsers & Mail
By default, windows gave Mail recipient in Send To context menu, but unless you have mail program installed (that can open it using MAPI protocol/link) it's useless. I am using default Microsoft Mail app. Which works on MAILTO protocol/links. I'd like to add MAILTO in my Send To context menu,...
Did anyone noticed the freezing of facebook using chrome latest version running on Windows 8 Professional edition 32bit??? i tried different browser for facebook, like IE10 & FF they run smoothly... is this a problem with win8??? because my friends using win7 they run facebook very smoothly on...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook