Windows 8 and 8.1 Forums


Internet connection ok, browsers (IE, Firefox) won't work

  1. #1


    Posts : 4
    Windows 7 / 8

    Internet connection ok, browsers (IE, Firefox) won't work


    Hi,

    I have a problem that I haven't found a cure for anywhere:

    I have a Sony Vaio with Windows 8 installed, and last night I tried to intall Open Office, Firefox and a program called Paint.net on it. The system wanted to restart, and it installed some updates, but after the updates were installed, the internet connection failed. The modem is fine, all other cpu's and ipads and devices connect normally, but the Windows 8 one won't work, neither on wlan or through ethernet.

    It shows the network ok and connects to it ok, but when I open the browser, nothing happens. And after a while I get the normal error message.

    Anyone who could help me with this one?

      My System SpecsSystem Spec

  2. #2


    Posts : 4
    Windows 7 / 8


    Have done the router re-set thing, and the tcp/ip and winsock reset thing, and almost all other things on earth.

    But maybe it's worth to mention that I have f-secure Anti-virus + firewall installed. Previous to the updates the browsers were working fine, but afterwards, nada.
      My System SpecsSystem Spec

  3. #3


    UK
    Posts : 177
    Win 8


    I guess the updates may have included LAN/WLAN driver updates. Goto settings, control panel, device manager. Expand the Network adapters tree, Right click the LAN/WLAN adaptor and select properties. Select the driver tab, click on roll back driver.

    Hope that helps.
      My System SpecsSystem Spec

  4. #4


    Posts : 4
    Windows 7 / 8


    Thanx,

    but I did that too, didn't help.
      My System SpecsSystem Spec

  5. #5


    UK
    Posts : 177
    Win 8


    Can you ping your router or other pcs on your local network?
      My System SpecsSystem Spec

  6. #6


    Try uninstalling network adapter drivers from Device Manager, reboot and see whether it fixes the problem.
      My System SpecsSystem Spec

  7. #7


    Posts : 4
    Windows 7 / 8


    Problem solved: after doing all that you suggested (thanx!) and much more, it turned out that it was an undetected remnant of the already removed McAfee-software that was causing the problem: apparently some part of McAfee wasn't removed with the rest of the program, and this part had then been activated by the Windows 8 updates to form a firewall that wouldn't allow any internet access at all. Once the remnant was identified and removed the web works fine again.

    Of all things, this was not something I anticipated. But now it's solved.
      My System SpecsSystem Spec

  8. #8


    UK
    Posts : 177
    Win 8


    Moral of the story: Never use McAfee's resource eating bloat ware.
      My System SpecsSystem Spec

Internet connection ok, browsers (IE, Firefox) won't work
Related Threads
Hello, I have just recently installed Windows 8 Pro and have had no problems, except my internet browsers. I am connected to the internet and can use some programs using it such as skype, but none of my browsers will work. (Internet explorer, Google chrome, Firefox.) In google chrome i get...
Hello, I just realized how bad this is for security reasons and many others. Have you ever uninstalled a program or quit something only to have your browser automatically open up and go to a webpage of the software you are uninstalling?!!? are they serious!? How do I control my "own"...
Around a week ago I installed Windows 8.1, and I can't help but think this problem is related to that. My computer (a Toshiba Satellite C855) is apparently connected to the internet, but yesterday I suddenly couldn't browse any websites. I didn't change any settings before this happened. This...
Hey guys! Im not so good with computers, and I could really use all the help with my problem. I keep disconnecting every 3-4 minutes, but only for some seconds. the internet icon always keeps showing that I have internet. I tryed using an other cable but it the problem is still there. It...
My Internet is fine. I can connect with my iPhone, and with Ubuntu OS. It's just the button in the bottom right hand corner (the wireless signal bars) doesn't do anything after I click it on my windows laptop.. It happens every so often disallowing me from connecting to the Internet in times...
My Internet connection icon/button (either on the desktop to the right of the task bar or on the settings when you slide in from right) doesn't work... I mean when I click it it does absolutely nothing. Also, when I open the network and sharing center after clicking change adapter settings it...
Hi! Whenever I try to browse on my laptop, the browsers (all of them - I've tried IE, Firefox, Opera and Chrome) keep on freezing randomly every 20-30 seconds for about 5 seconds. At the same time, I could see the same in steam - the game download speed at the very same moments suddenly drops...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook