Windows 8 and 8.1 Forums


This page can't be displayed IE 10 problem

  1. #21


    Posts : 1
    Windows 8

    New version of the same old problem


    Curious if anyone else has ran into this problem. Same "This page can't be displayed" in IE 10 / Win 8. I built 2 computers that were working fine then also built a Windows Server 2012 Essentials server to connect them too. After running the //server/connect on the clients to connect to the server and the domain, now these computers have this problem. Only on some website though, like Microsoft.com - that's a good one , serves them right. I've tried everything from Microsoft's KB956196 article and none of it helped. What's weird is sometime I can put a site in the trusted zone and it will come up but usually will contain no graphics that should be there, other times they work ok, but then I try something else to get the rest of them to work and the sites in the trusted zone won't work anymore.
    So has anyone else tried server 2012 and had this problem yet and got any ideas on how to fix it?

      My System SpecsSystem Spec

  2. #22


    Posts : 1
    Windows 8.1

    Flush it


    Quote Originally Posted by rwaldon View Post
    Curious if anyone else has ran into this problem. Same "This page can't be displayed" in IE 10 / Win 8. I built 2 computers that were working fine then also built a Windows Server 2012 Essentials server to connect them too. After running the //server/connect on the clients to connect to the server and the domain, now these computers have this problem. Only on some website though, like Microsoft.com - that's a good one , serves them right. I've tried everything from Microsoft's KB956196 article and none of it helped. What's weird is sometime I can put a site in the trusted zone and it will come up but usually will contain no graphics that should be there, other times they work ok, but then I try something else to get the rest of them to work and the sites in the trusted zone won't work anymore.
    So has anyone else tried server 2012 and had this problem yet and got any ideas on how to fix it?

    "ipconfig /flushdns" wait a couple of mins and refresh
      My System SpecsSystem Spec

Page 3 of 3 FirstFirst 123
This page can't be displayed IE 10 problem
Related Threads
I installed some windows 8 updates on Sunday, 12/2. Prior to these updates, IE was working perfectly. Now I get this error: "This page can't be displayed" when launching IE. Also, when launching IE via the new interface, it jumps to the desktop, launches IE and I get the "This page can't be...
IE 11 is slow and tells me this page can not be displayed after clicking on a link. after I click on the link again it usually opens up. sometimes it takes 2 or 3 clicks to open the page. I have used Malware bytes, but have no malware. I think it started after May 5th. Did we get an update on...
This Page Can't Be Displayed in Browsers & Mail
I'm using IE11 on my Window8.1 pc and frequently get the message " This page can't be displayed" on any and every site including eightforums. I found that opening a command prompt and entering the following commands helps (ipconfig /flushdns and hit enter,ipconfig /release and hit enter, ...
I have MSI laptop 17.3" Core i7-3630QM/16GB DDR3/NV GTX 675MX, 4GB, Windows 8.1 upgraded to from win 8. Wifi: Intel Centurino Wireless N2230 Not only on Windows 8.1 but on Windows 8 as well ever since I am on the new system, I get too many times 'This page cannot be displayed'. This happens like...
" Page Cannot be displayed " in Network & Sharing
This may well not be the right place to post this.. this is happening on my pc when I change pages at times.I need to know which of these I should have ticked ? I've gotten a message, " page cannot be displayed ".. with a message to make sure SSL and TSL should be checked. Thanks for your...
Solved Odd Google home page problem. in Browsers & Mail
In Internet settings on the control panel I have google as my home page. The exact address I have it set to is Google , however when I open IE I end up at http://www.google.com/cgi-bin/redirect.ha which is not a functioning page & displays the following message: ...
browsers page display problem in Browsers & Mail
hi i have had this problem for some time now and i think it is related to windows 8 because i never had this problem in windows 7 while surfing the internet, after gathering a bit of cache my browsers stop displaying pages correctly, refreshing doesnt help, although chrome refreshes and starts...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook