Windows 8 and 8.1 Forums


Hyperlinks stopped working in Windows 8 Mail app

  1. #11


    Posts : 12
    Windows 8 64-bit Home Edition


    I'm reviving this thread, because the above suggestion DOES NOT work for me. In fact, I don't even have a CLSID key in the "Classes" folder.

    Instead, on my system, I have a CLSID entry within the "ActivatableClasses" directory.
    It looks like this: HKEY_CURRENT_USER\Software\Classes\ActivatableClasses\CLSID.

    For fun, I tried deleting that entire CLSID folder, and after rebooting, I noticed that *none* of my metro apps opened as a result of my tinkering. Thankfully, I did make a backup and was able to import it back into the registry without problems.

    Still...the solution remains a mystery for me and that is VERY disappointing, because this is one of two metro apps I actually like! (Sports being the other.)

    Come on Microsoft...this is lame.



    My solution is:


    1. open regedit
    2. delete 'HKEY_CURRENT_USER\Software\Classes\CLSID' key. (You may need to do a backup before killing it.)
    3. reboot.


    Enjoy it !

    I also post the solution here:

      My System SpecsSystem Spec

  2. #12


    Posts : 4
    windows 8


    Quote Originally Posted by SimplyShane View Post
    I'm reviving this thread, because the above suggestion DOES NOT work for me. In fact, I don't even have a CLSID key in the "Classes" folder.
    I also post the solution here:
    same for me, however some links work some dont't, but all work on Hotmail or Gmail web interface!!
      My System SpecsSystem Spec

  3. #13


    Posts : 43
    Windows 8.1 Pro 32-bit


    [QUOTE=kitenski;201528]
    Quote Originally Posted by SimplyShane View Post
    In fact, I don't even have a CLSID key in the "Classes" folder.
    Perhaps the HKEY_CURRENT_USER\Software\Classes\CLSID key only exists if Windows 8 was an upgrade install of Windows 7, like mine. Did you guys do a clean install or purchase a PC with Windows 8 pre-installed?
      My System SpecsSystem Spec

  4. #14


    Posts : 4
    windows 8


    [QUOTE=RonnieJP;201704]
    Quote Originally Posted by kitenski View Post
    Quote Originally Posted by SimplyShane View Post
    In fact, I don't even have a CLSID key in the "Classes" folder.
    Perhaps the HKEY_CURRENT_USER\Software\Classes\CLSID key only exists if Windows 8 was an upgrade install of Windows 7, like mine. Did you guys do a clean install or purchase a PC with Windows 8 pre-installed?
    Brand new hp elitepad with win8 pre installed so that could well be it....
      My System SpecsSystem Spec

  5. #15


    Posts : 43
    Windows 8.1 Pro 32-bit


    I think that's likely. I still have problems with some hyperlinks, but only in the Pulse News app. But that could be a problem with the app itself.
      My System SpecsSystem Spec

  6. #16


    Posts : 511
    Windows 10 Pro 64 bit


    I found a work around. Just put a space behind the link. It works. Maybe they will fix it in an update.
      My System SpecsSystem Spec

  7. #17


    Posts : 4
    windows 8


    Yes that seems to work for me as well, I need to reply then put a space after the url, which isn't too user friendly!!
      My System SpecsSystem Spec

  8. #18


    Posts : 1
    Windows 8 8 Pro 64-bit


    I'm having the same problem, it's driving me mad! some URL'S work some don't.

    Is there an easier way to fix this?
      My System SpecsSystem Spec

  9. #19


    Posts : 4
    windows 8


    Quote Originally Posted by Marky67 View Post
    I'm having the same problem, it's driving me mad! some URL'S work some don't.

    Is there an easier way to fix this?
    The easy way is for Microsoft to fix the app!!
      My System SpecsSystem Spec

  10. #20


    Posts : 2
    Windows 8


    Hey, guys, I just registered to say thank you to Allen Kuo for pointing me to the right direction. My problem was that I couldn't authorize a few apps because the buttons were unclickable. So I checked all the CLSID entries I had in that HKCU section, and all of them were from Dropbox except for one that looked like this:

    Code:
    Windows Registry Editor Version 5.00
    
    [HKEY_CURRENT_USER\Software\Classes\CLSID]
    
    [HKEY_CURRENT_USER\Software\Classes\CLSID\{BDDCC68C-9122-898A-C5D9-734DCDF17DF2}]
    @="CEuBVCyBxEIxFBEFmDyEuBAIEuACIxyLJmrxVa"
    
    [HKEY_CURRENT_USER\Software\Classes\CLSID\{BDDCC68C-9122-898A-C5D9-734DCDF17DF2}\Implemented Categories]
    
    [HKEY_CURRENT_USER\Software\Classes\CLSID\{BDDCC68C-9122-898A-C5D9-734DCDF17DF2}\Implemented Categories\{521D1C93-871A-CDE2-277F-3BEA3D5C30C4}]
    @="{7A930663-368F-50AF-5EDB-1AA499C3B7C2}"
    
    [HKEY_CURRENT_USER\Software\Classes\CLSID\{BDDCC68C-9122-898A-C5D9-734DCDF17DF2}\Implemented Categories\{7DC6BA5C-15FB-E0E9-C6F4-225EAD8E207A}]
    @="{856CF99D-2A52-8E4D-9C7F-35076107A4C9}"
    
    [HKEY_CURRENT_USER\Software\Classes\CLSID\{BDDCC68C-9122-898A-C5D9-734DCDF17DF2}\InprocServer32]
    @="ole32.dll"
    
    [HKEY_CURRENT_USER\Software\Classes\CLSID\{BDDCC68C-9122-898A-C5D9-734DCDF17DF2}\Version]
    @="2"
    It looked suspicious enough, so I deleted it, rebooted and voila, everything was clickable once again. Note that my Windows 8 install was clean, so apparently some program created this entry recently, and it looks like some sort of copy-protection or masked trial data entry.

    Thank you again for your help.
      My System SpecsSystem Spec

Page 2 of 4 FirstFirst 1234 LastLast
Hyperlinks stopped working in Windows 8 Mail app

Similar Threads
Thread Forum
nfs mw 1 has stopped working in windows 8 pro
I have windows 8 pro in my desktop.When i started to run nfs mw 1 it opened but while loading for gameplay it stops working and windows says that there is a problem to work the program properly,so i will have to close it.I have tried for all compability mode but its sltill does not work.Please help...
Drivers & Hardware
mail stopped working,
a pop up window says this app can't be activated when VAC is disabled. what is this and how do I fix it?
Browsers & Mail
CTRL ALT DEL has stopped working on Windows 8.1! Plz help!
Okay guys, so i installed Classic Shell on my Windows 8.1 laptop and i kinda didn't like it too much so i uninstalled it. But it has'nt uninstalled completely, when i try running setup again, and choosing the 'remove' option it doesn't uninstall! Anyways, that isn't really the problem, the thing...
Software and Apps
Windows 8 reader - opens PDF but hyperlinks not working..?
The default PDF opener (Windows Reader) opens my PDF fine but the links are just text, they are not hyperlinks. It works fine in 7. Any ideas on how I can get these hyperlinks working?
Software and Apps
hyperlinks suddenly don't open on windows 8.1 mail app
since a week ago i can't open any hyperlink on my windows 8.1 mail app. i connected my google account to it, everything worked fine before. i fount a possible solution to delete CLSID folder from registry but that didn't do the trick. any other suggestions?:huh:
Browsers & Mail
Windows explorer has stopped working
Ever since I installed 8.1, I keep getting the message, "Windows explorer has stopped working and will shut down." It's happened several times in the last hour. Has anyone else run into this.
General Support
Mail and People Apps stopped working
Both the Mail and People Apps have stopped working for me. The were both working yesterday. The Mail App still shows a live tile but when opened gives this super helpful screen. 3967 Has anyone any ideas?
Software and Apps
Eight Forums Android App Eight Forums IOS App Follow us on Facebook