Windows 8 and 8.1 Forums


IE Works in Desktop, but not in Metro

  1. #1


    Posts : 2
    Windows 8 Pro

    IE Works in Desktop, but not in Metro


    I just upgraded a Win 7 64 PC to Win 8 64.

    Internet/IE works fine in desktop mode.

    When I'm in Metro mode, IE, weather panel, news, etc. all don't have an internet connection.

    There is some data in those panels though, so it's getting information somehow.

    Store let me install and app (iHeartRadio), but then the app doesn't seem to have internet access.

    Bing search does return results, but when I click on results and go to IE, I get page can't be displayed error.

    I reset my IE settings when in desktop mode (so no proxies), installed updated networking drivers and I've rebooted my router. I also did reset connection in IE/Metro version.

    Also tried to turn off defender and firewall and same thing.

    Any ideas?

      My System SpecsSystem Spec

  2. #2


    Are you using a Windows Live account to log in with?

    I believe that is the problem, you need to create a Windows Live Account and sign in with it first.
      My System SpecsSystem Spec

  3. #3


    Posts : 26
    Windows 8.1 Pro 64 bit


    Quote Originally Posted by lexluthor View Post
    I just upgraded a Win 7 64 PC to Win 8 64.

    Internet/IE works fine in desktop mode.

    When I'm in Metro mode, IE, weather panel, news, etc. all don't have an internet connection.

    There is some data in those panels though, so it's getting information somehow.

    Store let me install and app (iHeartRadio), but then the app doesn't seem to have internet access.

    Bing search does return results, but when I click on results and go to IE, I get page can't be displayed error.

    I reset my IE settings when in desktop mode (so no proxies), installed updated networking drivers and I've rebooted my router. I also did reset connection in IE/Metro version.

    Also tried to turn off defender and firewall and same thing.

    Any ideas?
    I am having the exact same problem with Win 8 64. I am logged in with my Windows Live Account.

    Has anyone observed the same behavior? Any suggestions?
      My System SpecsSystem Spec

  4. #4


    Posts : 2
    Windows 8 Pro 64Bit (Upgraded from 7 HP 64Bit)


    Hey, same thing here.
    Upgraded last night from 7HP to 8 Pro, and IE 10 only works in desktop mode. chrome on the other hand works great on the new interface. still can't figure out whats wrong here... :/
      My System SpecsSystem Spec

  5. #5


    Posts : 22,564
    64-bit Windows 10


    For the Metro IE10 issue alone, you will need to have IE10 set as the default program to have IE10 Metro available on the Start screen. If IE10 is not the default program, then you will just have the IE10 desktop version on the Start screen instead of the Metro version. You do not need to be signed into a Microsoft account to be able to use IE10 Metro. It works with both a local or Microsoft account.

    For the other issue, I'm thinking it's related to it being an upgrade instead of clean install of Windows 8. You might see if resetting Windows 8 may help. This is basically the same as a clean install, so be sure to backup anything that you do not want to lose first.

    Hope this helps,
    Shawn
      My System SpecsSystem Spec

  6. #6


    Posts : 2
    Windows 8 Pro 64Bit (Upgraded from 7 HP 64Bit)


    Hey,

    i just came across this page:
    Launch Options for Internet Explorer 10 on Windows 8 - IEBlog - Site Home - MSDN Blogs

    i followed the steps, and yes the ie10 worked on the metro. BUT, once i changed the settings and gave him to be the default browser, the chrome started working only on desktop, and vise versa, depending on which one is set as default.

    THAT SUCKS. i kinda loved the ne metro style, it's awesome. BUT i do need to work on some sites with IE, but most of the time i'm like Chrome better. hope to find a way to make them both run on metro.

    Edit:

    Another link showing the problem and claims there is no way to have 2 browsers working on metro -

    https://www.eightforums.com/tutorials...ndows-8-a.html
    Last edited by Brink; 01 Jan 2013 at 14:39. Reason: updated with tutorial link for more info
      My System SpecsSystem Spec

  7. #7


    Posts : 26
    Windows 8.1 Pro 64 bit


    Quote Originally Posted by Silver0066 View Post
    Quote Originally Posted by lexluthor View Post
    I just upgraded a Win 7 64 PC to Win 8 64.

    Internet/IE works fine in desktop mode.

    When I'm in Metro mode, IE, weather panel, news, etc. all don't have an internet connection.

    There is some data in those panels though, so it's getting information somehow.

    Store let me install and app (iHeartRadio), but then the app doesn't seem to have internet access.

    Bing search does return results, but when I click on results and go to IE, I get page can't be displayed error.

    I reset my IE settings when in desktop mode (so no proxies), installed updated networking drivers and I've rebooted my router. I also did reset connection in IE/Metro version.

    Also tried to turn off defender and firewall and same thing.

    Any ideas?
    I am having the exact same problem with Win 8 64. I am logged in with my Windows Live Account.

    Has anyone observed the same behavior? Any suggestions?
    I fixed the Metro Problem. Apparently Kaspersky and Avast need to be uninstalled/reinstalled when you do an upgrade. Other antivirus programs may also.

    When I uninstalled Kaspersky, I was immediately able to connect my Metro apps. Still works after reinstalling. I received this info from another thread.
      My System SpecsSystem Spec

  8. #8


    Posts : 1
    Windows 8


    I've had the same problem multiple times, with no apparent cause. Finally found a fix. It essentially uninstalls/reinstalls IE, thus fixing the broken link to the Metro tile.

    Windows Features - Turn On or Off in Windows 8


    From the Start Menu Screen Type in Control.
    Left Click on Control Panel.
    At the Top Right Click on Category and Change it to Large Icons.
    Find and Open Programs and Features .
    Now On the Left of this screen Select Turn Windows Components On or Off .
    Find and Uncheck Internet Explorer 10.
    Agree To the Prompt , Click OK on Windows Features To Begin the Uninstall , Then Select reboot Now once the Uninstaller Completes .

    Once Your Back at the Start Screen after your Reboot. Type in Control
    Left Click on Control Panel.
    At the Top Right Click on Category and Change it to Large Icons.
    Find and Open Programs and Features .
    Now On the Left of this screen Select Turn Windows Components On or Off .
    Find and check Internet Explorer 10.
    Agree To the Prompt , Click OK on Windows Features To Begin the Reinstall , Then Select reboot Now once the Installer Completes .

    Once you are once again back at your Start Screen , Select Desktop.
    click on The Explorer Folder Icon.
    On the Left Click on Local Disk C: or Go to the address bar and Type in C:
    Double Click on Program Files (x86) and then Internet Explorer
    Scroll down until you locate iexplore , Double click on it .
    Once Internet Explorer opens Go to your task bar and Right click on Internet Explorers Icon and Click on Pin to TaskBar.

    Now Test internet Explorers Functionality. Try to Browse to a few pages .

    Close and reopen Internet Explorer on the desktop and When/if Prompted Make it default.

    Try the Touch optimized Version again.
    Last edited by Brink; 01 Jan 2013 at 14:41. Reason: added tutorial link for more info
      My System SpecsSystem Spec

IE Works in Desktop, but not in Metro
Related Threads
So a while back I bought a corsair M90 because I loved the feel of it, however, I immediately regretted my decision. I ran into one specific error which was that my computer would not recognize it. It kept giving me "USB device not recognized" even when I try different ports. I can't even set up or...
So what's been happening is that my desktop and file explore will freeze for 4 or 5 seconds, never counted. but a short time anyways. but yet i can still use my chrome and run a game and switch back and forth between programs just fine. and after it happens once, it doesn't seem to happen again...
This happens on 3 machines I own. Using win 8 I could see all my printers under metro but when I select one (say from iexplorer) I get "there was a problem connection to the printer." I get this no matter what I select, printers, Adobe Pro Creator, Microsoft XPS creator... When I use Desktop,...
Hello everyone, Since I installed some "critical" updates from microsoft, there have been some network problems. The main problem that I noticed was that the ethernet appeared as "limited". Then, as I logged in, internet was actually working fine, but that was in desktop mode. Now, as I try...
Hi, this just started this morning, (ie was working fine when I used it yesterday from my desktop), but when I clicked on the ie icon on my taskbar it tried to go to the following instead of msn.ca (which is still shown as my homepage in tools/internet options) : ...
Hi there this little trick STILL works in W8 RP. If you want the standard RDP --= not the stupid Metro version then simply at the command line - normal user -- not as an administrator enter the command mstsc.exe You get all the options back including the remote computers desktop themes etc...
Hi all This is a copy of a post I made in the W7 Forums but I've been pointed to this Forum (never even knew there was a W8 one yet !!) I've just been playing with the developer edition of W8 download link in the news section of the Forum. if you are like me and HATE those horrible...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook