Windows 8 and 8.1 Forums

unable to mount iso file as i cant change its properties

  1. #1

    Posts : 1
    windows 8

    unable to mount iso file as i cant change its properties

    I am trying to mount a iso file but the mount option does not show up. So I try to change the properties of the file such that it opens with windows explorer. but I am unable to change the properties because I cant find the windows explorer option anywhere to choose. How to browse to windows explorer and choose it such that I get mount option. I am on a windows 2008 server.

      My System SpecsSystem Spec

  2. #2

    Posts : 123

    I don't know about Windows 2008 Server, however Windows prior to Win8 did not have the built-in ability to mount an ISO.
    Try "Virtual CloneDrive" by Slysoft. It's a great product and it's free. SlySoft Virtual CloneDrive
      My System SpecsSystem Spec

  3. #3

    Forever West
    Posts : 592
    WinVista, Win7, Win8.1, Win10, Mac OS X 10.10, Linux Mint 17.1
      My System SpecsSystem Spec

  4. #4

    Posts : 406
    W10 Pro X64

    Good link Berton. I would get 7zip and extract the files
      My System SpecsSystem Spec

  5. #5

    Use ImDisk like a pro. It's a filesystem driver which does a lot more than just mount ISOs,
      My System SpecsSystem Spec

unable to mount iso file as i cant change its properties

Similar Threads
Thread Forum
Unable to unhide in properties some pictures,
somehow I managed to accidently delete a folder of important pictures. So I go to trash can, and highlight and click restore. It goes to my OneDrive file. I click Home, and Move To, My Pictures. I go to My Pictures, and open the folder, and try to share the picture, then I try to edit the picture,...
General Support
VHD or VHDX File - Mount and Attach in Windows 8
How to Mount and Attach a VHD or VHDX File in Windows 8 This tutorial will show you how to mount and attach either a VHD (Virtual Hard Disk) or VHDX (Hyper-V Virtual Hard Disk) file as a drive in the Computer window for all users in Windows 8. Mount and attach is the same. You must be signed...
Couldn't Mount File (Seems New Unknown Kind of Problem)
Hello guys, I'm a new guy here so please forgive me for my title if it's quite unappropriate. Actually I created this account just to ask you about my ISO mounting error that I encountered awhile ago. I already read the rules about creating a thread of a same old topic in here, but seriously I'm...
Couldn't Mount File error- but the iso file was mounted
In Windows 8.1, when I try to use the native ISO mounting function, either from the right-click menu, or by double clicking the iso file, I am getting the error: Couldn't Mount File Sorry, there was a problem mounting the file. Yet most of the time, the virtual CD/DVD drive appears as it ...
Unable to edit MP3 properties in Windows 8
I have just recently acquired a brand new laptop running Windows 8, and I'm experiencing an issue with editing the details of MP3 files. I can right-click any MP3 to open its properties and access the Details tab, but when I click on the fields for the different tags, nothing happens. I don't...
General Support
Not able to mount iso file
Hi, I didn't install any 3rd party app to mount iso. Yesterday, i tried to mount a iso file, it didn't worked. Then googled about it, tried sfc /scannow, no success. Then i checked "Default programs - associate file extension...", there is no entry for .iso. Please help. 27780 Tried Daemon...
Unable to access properties of my network connection.
This is a fairly new install of Windows 8 pro (within the last month), and while trying to set up a static ip up today I found that I was unable to access the network properties or disable the connection in the Network Connections. I am pretty stumped as I am the only user of this computer and from...
Network & Sharing

Eight Forums Android App Eight Forums IOS App Follow us on Facebook