I hae a dell m1710, installed win8 rtm on it.

In win 7 i have 2 options of digital audio out:

1. Turtle Beach Audio Advantage Micro usb with optical S/PDIF out
2. Dell composite video adapter with digital coax out. Sigmatel high definition audio codec

In win 8 i tried first the Audio Advantage Micro usb, had to install with ‘Disable driver signature enforcement‘ then only got stereo despite the card was not recognized by the Turtle Beach software.

Then installed Sigmatel high definition audio codec
Title      : Audio:SIGMATEL STAC 92XX C-Major HD Audio Driver
Version    : A09
OEM Ver    :
Computers  : 130L, MXC051, M1530; 1420, 1501, 1520, 1521, 1720, 1721, B120, B135/1400, ME051, MM061, MP061, MXC061; Latitude:120L , 131L, ATG D630, D420, D430, D520, D530, D531, D620, D630, D630c, D631, D820, D830, XT; Precision:M2300, M4300, M6300, M65, M90; Vostro Notebook:1000, 1400, 1500, 1700; XPS:M1330, M1730, MXC062, MXG061, MXP061
OS         : Windows Vista 32-bit, Windows Vista 64-bit
Languages  : Brazilian Portuguese, Chinese-S, Chinese-T, English, French, German, Japanese, Korean, Spanish
Created    : Thu Nov 29 15:43:53 CST 2007
It looks like it installed ok, the display on the receiver can detect that theres some kind of signal but i get no audio.

I have set it to standard\default, when running tests on it i can hear some low static from the speakers.

Anyone knoqw what the problem could be? Or recopmmend another usb dongle that can take S/PDIF out for digital\surround to receiver?