Windows 8 and 8.1 Forums


No audio output through HDMI port to TV

  1. #1


    Posts : 2
    Windows 8 Release Preview 8400

    No audio output through HDMI port to TV


    Hi there, I'd really appreciate if this could work, the details of my system are as follows:

    Dell XPS L502X
    Nvidia GT 525M

    I have downloaded the Realtek Drivers as mentioned here for the Windows 8 version, plug in the HDMI cable but still the output doesn't go to the TV but sound plays from the laptop speakers.

    Earlier when I used this along with the Win 7 OS, it worked flawlessly. I don't know what the problem is. I've tried uninstalling the windows drivers and then installing Realtek drivers but still doesn't work.

    Any help would be appreciated. I've attached the screenshots of device manager as well along with audio properties.
    Attached Thumbnails Attached Thumbnails New Bitmap Image.bmp  
      My System SpecsSystem Spec

  2. #2


    Posts : 2
    Windows 8 Release Preview 8400


    I've also tried downloading the ATI HDMI driver, I don't know why I don't have an ATI board anyway.. but from this site obviously it says no supporting device was found on the system.
      My System SpecsSystem Spec

  3. #3


    Posts : 30
    Win 8 release canadate


    Right click the sound icon in your tray, select "Playback devices", select your device (probably the name of the TV) and set it to default.

    Note.
    Leave it as the default as Windows will switch back to the computer speakers if the TV is off and back to the TV when you turn it on.
    Last edited by MikeFromHC; 31 Aug 2012 at 12:29 AM.
      My System SpecsSystem Spec

  4. #4


    Posts : 27
    Windows 8 Pro


    I guess it's by design that when the audio is directed to TV, my computer loses its audio. Image someone watching a video streamed from the computer to TV, while I work on something else on the computer, is it possible to output audio to different sources simultaneously and separately?
      My System SpecsSystem Spec




  5. #5


    Posts : 4
    Windows 8.1 Pro 64bit

    No problem with connecting PC to TV via HDMI


    Hi. I have no problem connection my PC to my TV via HDMI. Good picture and sound. But if I want to play another UTube or similar, then there is a good picture, but no sound!
    I then reinstall my Realtec drivers and all is good again. Until I want to use a second time.
    I've tried re-booting both PC and TV, booting up PC with TV turned off and with TV turned on. To no avail.
    I'm going bonkers.
    I am using Windows 8.1 with Intel 2 Core E8500 CPU and 6GB memory.
    Any useful suggestions will be gratefully received!
      My System SpecsSystem Spec

  6. #6



    United States
    Posts : 1,974
    Windows 8.1 Pro 64-bit


    Quote Originally Posted by obraf View Post
    Hi. I have no problem connection my PC to my TV via HDMI. Good picture and sound. But if I want to play another UTube or similar, then there is a good picture, but no sound!
    I then reinstall my Realtec drivers and all is good again. Until I want to use a second time.
    I've tried re-booting both PC and TV, booting up PC with TV turned off and with TV turned on. To no avail.
    I'm going bonkers.
    I am using Windows 8.1 with Intel 2 Core E8500 CPU and 6GB memory.
    Any useful suggestions will be gratefully received!
    HDMI audio is actually a function of the graphics drivers. Sounds like the Realtek audio and HDMI audio aren't communicating properly to switch back. Do you have the latest graphic drivers installed?
      My System SpecsSystem Spec

  7. #7


    Posts : 4
    Windows 8.1 Pro 64bit


    Thanks for your response. Would "ATI Radeon HD 4300/4500 Series" be the graphic card I need to update?
      My System SpecsSystem Spec

  8. #8


    Posts : 4
    Windows 8.1 Pro 64bit


    Hi popeye,
    Yes, I've made sure I have the latest and correct ATI Radeon driver. Still nothing!
      My System SpecsSystem Spec

  9. #9



    United States
    Posts : 1,974
    Windows 8.1 Pro 64-bit


    Well, that is a legacy card and may have issues with 8.1. All I got left is may run this then see what Windows installs at reboot, then re-install driver manually if necessary.

    Display Driver Uninstaller Download version 13.4.0.0

    What driver are you using BTW? I couldn't find any official 8.1 drivers for the 4300/4500 series graphic card.
      My System SpecsSystem Spec

  10. #10


    Posts : 4
    Windows 8.1 Pro 64bit


    Thanks again popeye. I've got it all sussed now. I was installing a more recent Realtec driver but when I installed the correct one for my MB, it's all good.
    Cheers.
      My System SpecsSystem Spec

Page 1 of 2 12 LastLast
No audio output through HDMI port to TV
Similar Threads
Thread Forum
Solved Digital Audio (HDMI) only has 2 channel option Sound & Audio
For those troubled by HDMI Sync Issues, Intel HD/3000/4000 etc Graphic Cards
what is the protocol , port and FQDN used by the Windows 8 store? Network & Sharing
VIA Vinyl VT1708s + 3.5mm Speakers Strange Sound (only HDMI works) Sound & Audio
Monitor Wont detect HDMI Cable (Works With VGA) Drivers & Hardware
Eight Forums Android App Eight Forums IOS App Follow us on Facebook