Windows 8 and 8.1 Forums

Sound Card not working after Windows 8.1 Windows updates.

  1. #1

    Posts : 4
    Windows 8.1

    Sound Card not working after Windows 8.1 Windows updates.


    After the latest lot of Windows Updates for 8.1 my Asus Xonar STX no longer works and I get an error message saying

    "an Asus Xonar STX has been detected but the drivers appear to be corrupt, please try reinstalling them."

    I have tried uninstalling and reinstalling both the card and drivers and the card is still not working.

    It is 100% to do with the latest updates, I have done a system restore to before the updates were applied and my sound card works fine. If I install the updates again, my card stops working, so there is no doubt it is the updates causing the problem.

    There are no driver updates for my sound card either, so it's not driver related. I have also seen several other people with different sound cards on other websites reporting the same thing, so the problem is also not unique to me.

    Does anyone know which update is causing it or if there is a work around?
    I have turned Windows Updates off for now but I don't like having to do this and would rather find a alternative work around or fix.

    Thanks in advance

      My System SpecsSystem Spec

  2. #2

    I haven't seen any where specific updates caused the problem you have. However, I have seen instances where someone has upgraded from Windows 8 to Windows 8.1 and the sound no longer works. I had that problem with one of my recording studio devices ( Roland Octa-Capture), fortunately Roland issued updated Windows 8.1 specific drivers.
      My System SpecsSystem Spec

  3. #3

    Posts : 4
    Windows 8.1

    I'm not sure it is the updates now, I restarted my PC earlier with windows updates turned off and got the same problem.
    I'm still 99% sure it is something to do with Windows though, because if I use a restore point from before I get the problem my sound card works fine.

    I don't know if it is the updates, and even though I have used an earlier restore point whether or not something is still persisting and continuing to cause issues.
    I'm going to try formatting my SSD and doing a fresh install tomorrow, hopefully it fixes the problem. If not then I may be in need of Windows 8.1 specific drivers from Asus. They haven't released an update since the 6th June, which was even before the Windows 8.1 preview was released.


    I may have found the culprit.. seems a program I was using called XonarSwitch which enables you to create different profiles and switch between them using shortcut keys is the problem. Usually this program auto updates, one of the updates must not have updated correctly and got corrupted causing it to mess up the drivers for the sound card itself. After removing XonarSwitch and downloading the latest version instead of letting it auto update seems to have fixed the issue.

    I'll mark this as solved for now

    UPDATE 2

    Even after doing the above XonarSwitch the problem still persists. I have completely removed it now and testing to see if the problem has gone.

    UPDATE 3

    Turns out it's the custom Xonar Uni Drivers and Windows 8.1 no longer recognizes the driver signature and thinks they are harmful. :/

    Oh well, back to the not so good official Asus ones
    Last edited by SieB; 16 Dec 2013 at 05:59.
      My System SpecsSystem Spec

Sound Card not working after Windows 8.1 Windows updates.

Similar Threads
Thread Forum
audio/sound not working after updated my windows
After i installed windows update, i notice that my audio/sound is not coming up again. I've restarted my system countless time, and is still not coming up. Have checked the drivers and everything is ok but i can't play songs. Have tried using media player and xbox, but it couldn't play any file...
Sound & Audio
Windows 8 updates not working
Every time I try to update the 99 updates now, they always get stuck infinitely on 0%, I need suggestions for all the possible fixes. Then when I shutdown my PC it then fails to configure, reverts the changes and then the same problem happens, please help!
Installation & Setup
Sound Card not working
I noticed that my music wasn't playing on itunes and it said that my soundcard was not working properly. When I troubleshoot the 'playing audio', it says that they could not identify the problem. I uninstalled and reinstalled the RealTek HD Audio Driver and still no luck. My computer did run an...
Sound & Audio
Windows Explorer crash + no sound working what-so-ever
Hey guys, since yesterday I have a problem with my sound. So when I restart my system everything works fine. After s few minutes videos e.g. on Youtube stop working (keep on buffering but won't play). From that moment on I can't change the system volume and trying will result in crashing the...
Sound & Audio
Windows 8 not seeing USB sound card after wake from sleep
Hi. I have a home built HTPC running Windows 8 with Windows Media Center. My sound card is a Silverstone EB01 USB DAC (i.e., it's an external USB device). When the computer wakes from sleep, there is no sound. I can fix this by either (a) unplugging and reconnecting the USB connector or (b)...
Sound & Audio
No sound on LeadtekTV card on windows 8
Hi all. I have an old TV tuner, Leadtek TV2000XP Deluxe and the WinFast PVR2 tv software. System is Windows 8 Pro. As I said, the card is old and last drivers were for Vista. But those drivers worked perfectly with Windows 7. Now in Windows 8, I instaleed the same drivers and TV Card is working...
Sound & Audio
Ixtreme X8540 Surround sound not working after Windows 8.
I have tried for some time now to get my surround sound to work on my Packard Bell Ixtreme X8540 since upgrading to Windows 8 via Microsoft's upgrade tool. When I had Vista installed, there was an icon on the bottom task bar which would take me to a control centre for the audio which gave the...
Drivers & Hardware

Eight Forums Android App Eight Forums IOS App Follow us on Facebook