Windows 8 and 8.1 Forums


No Sound from X-FI Xtreme Gamer

  1. #1

    No Sound from X-FI Xtreme Gamer


    I have the latest Creative driver on here for Win 7 64bit, and I'm not getting any sound. Anybody else having this problem.

      My System SpecsSystem Spec

  2. #2


    Posts : 3
    Windows 8 Dev Preview


    Im afraid that I have my soundblaster X-FI Extremegamer running fine. Or as fine as it can be running given that Windows 8 is still buggy as hell.
      My System SpecsSystem Spec

  3. #3


    Posts : 3
    Windows 8 Dev Preview


    Quote Originally Posted by deathjesteruk View Post
    Im afraid that I have my soundblaster X-FI Extremegamer running fine. Or as fine as it can be running given that Windows 8 is still buggy as hell.
    Scratch that, I installed the driver for my extreme gamer and was continually crashing. Infact, even after a total reinstall without installing the drivers, it was crashing. I have now removed the soundcard entirely and am using my onboard sound. So far so good, I will let you know how it goes.
      My System SpecsSystem Spec


  4. #4


    Posts : 2
    Windows 7 x64


    This is a widespread issue currently for various X-fi cards. People can be a little confused at first because the issue isn't apparent right away after installing the drivers and apps - most people (including me) report that the problems happen after restarting the system and finding that settings have reverted to default (in the Console Launcher) and that there's no sound. If you click on "default", the sound should come back - but this is not a fix, as it's not an option to do this upon every boot/reboot. Your problem might not manifest itself as mine does, but all in all, X-fi and Windows 8 do not work well together at this point.



    Windows 8 Pro x64 Retail No Sound after Restart Creative X-Fi Titanium HD Driver
      My System SpecsSystem Spec

  5. #5


    USA/Tenn/Oak Ridge
    Posts : 246
    Win 8.1 Pro 64 Bit


    Yea.. I have the same issue. And the same issue was occurring with Vista, it seems to me at least that Creative has issues with their drivers.
      My System SpecsSystem Spec

  6. #6


    USA/Tenn/Oak Ridge
    Posts : 246
    Win 8.1 Pro 64 Bit


    I found one way around this issue. I re-installed the Win 7 drivers for the sound card. Then I restated the PC. When it was up and going I went into the Creative control panel and selected the Entertainment mode.. the sound was back. I have not tried this with the beta drivers.. but it might work. HTH


      My System SpecsSystem Spec

  7. #7


    Wyandotte, MI (South of Detroit)
    Posts : 1,931
    Win 8.1 Pro 64bit


    My X-FI card stopped working yesterday after installing a driver update through Win8 Update. I rolled back the driver and the card works fine now. How can I see the updates that Windows Updates is applying? Thnaks!
      My System SpecsSystem Spec

  8. #8


    USA/Tenn/Oak Ridge
    Posts : 246
    Win 8.1 Pro 64 Bit


    I wish I could help you on that. I hope someone else can answer,.
      My System SpecsSystem Spec

  9. #9


    Posts : 1
    Windows 8 Pro


    Quote Originally Posted by omnimodis78 View Post
    This is a widespread issue currently for various X-fi cards. People can be a little confused at first because the issue isn't apparent right away after installing the drivers and apps - most people (including me) report that the problems happen after restarting the system and finding that settings have reverted to default (in the Console Launcher) and that there's no sound. If you click on "default", the sound should come back - but this is not a fix, as it's not an option to do this upon every boot/reboot. Your problem might not manifest itself as mine does, but all in all, X-fi and Windows 8 do not work well together at this point.



    Windows 8 Pro x64 Retail No Sound after Restart Creative X-Fi Titanium HD Driver
    works for me I had same prob try adding this to the reg ...

    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run]
    "CtxfiReg"="CTXFIREG.EXE /FORCE"
      My System SpecsSystem Spec

  10. #10


    USA/Tenn/Oak Ridge
    Posts : 246
    Win 8.1 Pro 64 Bit


    I just tried the Beta driver from Creative and so far so good.
      My System SpecsSystem Spec

Page 1 of 2 12 LastLast
No Sound from X-FI Xtreme Gamer

Similar Threads
Thread Forum
Creative Sound Blaster X-fi Xtreme Audio card
The Creative Sound Blaster X-fi Xtreme Audio card works fine in Windows 8. The drivers for Windows 7 work without any problem and the Creative updater and control panel also work as they should in Windows 8. The drivers can be downloaded here for the X-Fi Xtreme Audio card - Creative Worldwide...
Sound & Audio
PC infected with XTreme Rat
Hi, I recently installed AVG on the family computer and ran a virus scan, which came up with a few problems. The biggest one was that the computer was infected with the XTreme RAT trojan. This has been removed, but looking at the capabilities a RAT gives I would like to see what damage has...
System Security
Anybody still using x-fi xtreme gamer on windows 8.1 ????
Hi, i'm curious if anybody is still using their x-fi xtremegamer soundcard on windows 8.1 OS. I really wanted to dump it and use my onboard realtek ALC892. But, the audio to my surprise was inferior. Odd that a card I acquired in 2008 still beats out a modern onboard sound solution even...
Sound & Audio
Creative Sound Blaster X-fi Xtreme Audio card
Drivers & Hardware
Xbox live gamer tag
My gamer tag is not associated with my main Microsoft account that I use. It seems like a big pain to have to create a whole new user and switch to it in order to use the xbox live app. Does anyone know if there is anyway to log into a different Xbox live gamer tag than the user account you are...
Gaming
Soundblaster Extreme Gamer Crashing Windows 8
It seems that the soundblaster cards are currently not working with Windows 8. To be expected since this is a pre beta. But I installed the drivers for my Extreme Gamer and it was crashing every few minutes. I then reinstalled Windows without installing the drivers and it was STILL crashing every...
Sound & Audio

Eight Forums Android App Eight Forums IOS App Follow us on Facebook