What release of Lotus Smart Suite is needed to operate properly on a new Lenovo H430 i5 chip machine? I have tried version 9.8 millennium edition (about 3-5 years old which worked on a vista laptop) but it will not load on this machine. Note the version I tried is not 9.8.1, .2, .3, .4, .5 etc.

Thank you