Windows 8 and 8.1 Forums

Corrupt Windows files, do i need to worry?

  1. #1

    Posts : 5
    Windows 8.1

    Corrupt Windows files, do i need to worry?

    Hi all,
    A few Google Searches brought me to this forum I hope this is the right sub-forum.

    I recently re-installed windows 8.1 on a new SSD. (Completely from scratch, old Windows drive was unplugged)
    A program required NetFrameWork 3.5, but Windows failed to install it. The following Google Search suggested that some files may be corrupt.

    I ran sfc /scannow and some errors were found (Log attached).
    As far as I saw, it concerns 8 files, most of them Windows Defender stuff.

    I tried to repair with DISM.
    DISM /Online /Cleanup-Image /RestoreHealth
    This yielded another error “The Source Files could not be downloaded”

    I tried to manually specify source and tried to set it to download through windows update in group policy editor.
    Also tried to use my old Windows installation and a Win8 ISO as source
    DISM /Online /Cleanup-Image /RestoreHealth /source:wim:X:\sources\install.wim:1 /limitaccess
    But nothing, always the same error. Log attached

    After a few Days and a few reboots, the NetFrameWork 3.5 would install without a problem. But the sfc /scannow still yields errors and reports corrupt files.

    1. Do I need to worry? Windows itself runs absolutely stable.
    2. I also experience a strange problem with my network printer since I re-installed windows. When I try to add and install the printer through “Devices and Printers” I get the error “Could not install the printer” The Handle is Invalid”. An HP Forum suggested this could be due to corrupt (windows) driver files. Never had this Problem on 10+ other computers in my Home network. Maybe a coincidence, but maybe it is connected to the above?

    Any help would be greatly appreciated!
    Attached Files
    Last edited by Windguy; 31 May 2015 at 16:39.

      My System SpecsSystem Spec

  2. #2

    Posts : 2,067
    Windows 10 Home/ Windows 10 TP/ Windows 8.1 Pro/ Windows 7 Pro

    Your OS indeed has some corrupt files and missing files.
    (p)    CBS Catalog Missing            Package_10_for_KB3025417~31bf3856ad364e35~amd64~~    CSI Payload Corrupt            amd64_windows-defender-ui.resources_31bf3856ad364e35_6.3.9600.17672_en-us_784d8bf981326a95\EppManifest.dll.mui
    Repair failed: Missing replacement payload.
    (p)    CSI Payload Corrupt            amd64_windows-defender-ui.resources_31bf3856ad364e35_6.3.9600.17672_en-us_784d8bf981326a95\MsMpRes.dll.mui
    Repair failed: Missing replacement payload.
    (p)    CSI Payload Corrupt            wow64_windows-defender-ui.resources_31bf3856ad364e35_6.3.9600.17672_en-us_82a2364bb5932c90\EppManifest.dll.mui
    Repair failed: Missing replacement payload.
    (p)    CSI Payload Corrupt            amd64_windows-defender-service.resources_31bf3856ad364e35_6.3.9600.17672_en-us_60846cacdae9c828\MpAsDesc.dll.mui
    Repair failed: Missing replacement payload.
    (p)    CSI Payload Corrupt            wow64_windows-defender-service.resources_31bf3856ad364e35_6.3.9600.17672_en-us_6ad916ff0f4a8a23\MpAsDesc.dll.mui
    Repair failed: Missing replacement payload.
    (p)    CSI Payload Corrupt            msil_system.runtime.remoting_b77a5c561934e089_4.0.9600.17080_none_8b3f5c62eb42e2b0\System.Runtime.Remoting.dll
    Repair failed: Missing replacement payload.
    (p)    CSI Payload Corrupt            wow64_windows-defender-service.resources_31bf3856ad364e35_6.3.9600.17079_en-us_6ae00da10f444c9a\MpAsDesc.dll.mui
    Repair failed: Missing replacement payload.
    Tried all these commands? If not I suggest in this order.
    Dism.exe /Online /Cleanup-Image /StartComponentCleanup
    Dism /Online /Cleanup-Image /RestoreHealth
      My System SpecsSystem Spec

  3. #3

    Posts : 5
    Windows 8.1

    thanks for the reply!

    Well, i already tried those commands in that order and i just tried them again. Still no luck.

    The first command yields an "success"output , but the following scan finds the same corrupt files. The second command generates a "The Source Files could not be found" output.

    Attached a txt with the full CMD output

    Edit: I looked at some more threads in the forum, apparently a lot of people have problems like this currently. I tried some more of the suggested solutions, found out that i have to convert esd-files to wim-files to use them as source. Did that, tried once again. Still "source files could not be found"
    Attached Files
    Last edited by Windguy; 31 May 2015 at 17:25.
      My System SpecsSystem Spec

Corrupt Windows files, do i need to worry?

Similar Threads
Thread Forum
SFC can't fix some corrupt files
Hi guys I bought a HP 15-r003sv notebook two weeks ago with windows 8.1 installed . I ran SFC \SCANNOW two days ago and received the message " could not fix some corrupted files etc " I ran the command five times but the same result , so opened Notepad as Administrator and using the Open I...
Performance & Maintenance
trying to repair corrupt Windows Store files
I'm pretty new to all of this and have a question. I am trying to repair corrupt Windows Store files and SFC or DISM is unable to find them. Here is a list from the DISM log. Does anyone know what these files are and where to source them? Thanks 2015-01-25 08:59:28, Info ...
Performance & Maintenance
windows resource protection found corrupt files unable fix
Hi, I recently ran the Sfc Scan now thing in command prompt and found corrupt files it was unable to fix and I am not sure where to go from here.
Performance & Maintenance
Windows 8.1 pro corrupt files/ unable to fix
I am running Windows 8.1 Pro WMC I Found KB2938527 in windows update and it downloded perfectly. But when i installed it showed errors: WindowsUpdate_80073712 and WindowsUpdate_dt000. When I ran sfc /scannow the I get the following output C:\Windows\system32>sfc /scannow
Windows Updates & Activation
Windows resource found corrupt files but was unable to fix
It seems my windows ran into a problem.:sarc: I am using Sony VAIO with OS windows 8, ram 8 GB with Nvidia gt780m graphic card 1 GB. It all started when i restored my pc (without recovery disks) as i was getting some problem in installation of Game (assassin Creed 4) and after restoration it...
General Support
Windows Resource Protection found corrupt files unable fix
Hi, everyone: Windows 8 Toshiba L855 Laptop I attempted to create a manual System Restore point. I received the following error: Restore Point failed. "Writer experienced a transient error." I'm sorry I missed the error code. I did a search but I wasn't sure if it was the same number. I...
Performance & Maintenance

Eight Forums Android App Eight Forums IOS App Follow us on Facebook