Windows 8 and 8.1 Forums

SSD File "Eraser" Needed ??

  1. #21

    Posts : 4,515
    Vista and Win7

    @WHS ........ what is the purpose in halting the systrem in BIOS mode ?? And how do you do it
    The purpose is to give ths SSD power but prevent any read/write activity on the SSD so that garbage collection has the SSD to itself.

    On most systems you can get into the BIOS by tapping F2 after power-on.

      My System SpecsSystem Spec

  2. #22

    Posts : 453
    Windows 8.1 Pro with Media Center

    Quote Originally Posted by CountMike View Post
    Quote Originally Posted by adamf View Post
    Seems turning on bitlocker is far easier and more reliable. No-one can retrieve anything and you can always forget and destroy the keys if you feel the need to sanitise the drive.
    Yes that is but it doesn't get rid of stuff and I also heard that certain agencies have "Master key" for it. Given enough computing power and time, any code could be broken anyway.
    FWIW, Microsoft adamantly denies there is or has ever been a BitLocker backdoor. I have not heard any credible reports that (say) 20+ character BitLocker strong passwords are being cracked.

    Quote Originally Posted by rrecroc View Post
    what is the purpose in halting the systrem in BIOS mode ??
    I'm familiar with that from dealing with Crucial SSDs, e.g.

    My SSD used to be so much faster... What happened? - Crucial Community

    you may simply need to force Active Garbage Collection to run on the drive by powering the SSD on and leaving it idle for 6 to 8 hours...
    On a desktop PC, simply disconnect the SATA cable from your SSD and only leave the power cable connected. After switching your PC on, the SSD will be in an idle state but still have power so Garbage Collection can function. On a laptop, power on with the SSD installed and enter your system BIOS

    That's one of the most random procedures I've ever heard of, and I use the term "procedure" very loosely. Note that the laptop advice will work just as well for the desktop and doesn't require opening the desktop and disconnecting cables, the latter just ratcheting up the randomness and inconvenience.

    While 6 to 8 hours is a crazy time range, at least it's somewhat specific. I'm not aware other manufacturers (I use Intel and Samsung) give specific advice or even recommend the BIOS procedure. They tend to provide manual TRIM tools, AKA "optimizers", which Crucial does not do, and I have no idea if the Crucial procedure applies to them. Hopefully, Windows 8.1's defrag covers all drives with its scheduled SSD optimizer operation and makes the BIOS procedure unnecessary for drives with working TRIM. I don't know how you would tell other than losing performance, which I haven't ever observed, so I don't worry about it. I take that back. It's been almost a year since I fooled with this, but you can tell if the sectors are zeroed by examining them after a normal file deletion, e.g. doing what is described here in the "How to Verify TRIM Is Working" section:

    AnandTech | TRIM & RAID-0 SSD Arrays Work With Intel 6-Series Motherboards Too

    It is part of an article about RAID, but that is irrelevant. I've applied the technique after formatting with TrueCrypt and found that TC doesn't issue TRIM after formatting; BitLocker, OTOH, does following a full drive format/encrypt. I based these obsevations on the presence or absence of huge blocks of zeroed sectors representing free (TRIMmed) space when viewing the drive in the encrypted state, e.g. outside Windows in Parted Magic's wxHexEditor. I also have done this for file deletion with my Samsung 830 and Crucial M500 SSDs inside Windows, and they were both quick (talking seconds if disk activity is nil) to display zeroed sectors where the deleted file's data previously resided. There is a free tool "TrimCheck" that automates this method, but I haven't used it.
      My System SpecsSystem Spec

  3. #23

    Posts : 31
    Windows 8.1

    A website I visited the other day said SSD's do not have to be defragged ...... when I tell Windows to "Optimize" the drive, a "Trim" mesaage comes up ....... even after a month's activity, it only takes a few seconds for the process to completely. On WinME , it could take 30 minutes to defrag after a few years ownership, and I would have to do ir several times to get good results ..... it took less time each cycle of course.
      My System SpecsSystem Spec

  4. #24

    Posts : 4,515
    Vista and Win7

    Nice story but that is not the full story. What you have done is trimmed the deleted files - that is marked them as deleted. But the real work will have to be done by the garbage collection and that takes a lot longer.

    Garbage Collection and TRIM in SSDs Explained - An SSD Primer | The SSD Review
      My System SpecsSystem Spec

  5. #25

    Trying to Sith things out
    Bamberg Germany
    Posts : 2,179
    Windows 10 Pro 64 bit

    Quote Originally Posted by crawfish View Post

    you may simply need to force Active Garbage Collection to run on the drive by powering the SSD on and leaving it idle for 6 to 8 hours...
    On a desktop PC, simply disconnect the SATA cable from your SSD and only leave the power cable connected. After switching your PC on, the SSD will be in an idle state but still have power so Garbage Collection can function. On a laptop, power on with the SSD installed and enter your system BIOS
    I never heard about this technique before and I've noticed a drop on my laptops Samsung Pro 125GB(in use for about 3 years) Random read/write IOPs using the built-in benchmarker(sequential still max-out).
    I've had different Linux installations and reimaged windows a few times, being a laptop that I always shut off immediately after use, it doesn't have time for GC and it has about 4TB writes on it. I have my data and libraries on the same disk(for portability). I usually just use the performance optimization tool. So I decided to try this to see if it improves(doing it now). I'll post after if it improved IOP speed or not. Also after I booted to BIOS (turned screen off) the fan started running and the little green disk LED started glowing so I know it's doing something.

    I'll let you know how it turns out

    I don't have to do this on my desktop because it still rocks Click image for larger version
      My System SpecsSystem Spec

  6. #26

    Hafnarfjörður IS
    Posts : 4,374
    Linux Centos 7, W8.1, W7, W2K3 Server W10

    Hi there

    I think people have missed the point.

    On a Spinner you can physically ERASE a file by say writing an 'X'00' on every physical sector of the HDD (usually called a "Secure ERASE").

    If this type of approach is used then even the CIA can't recover any data from the drive. A normal "Erase" or "Delete" just removes the directory entry while leaving the data intact which means if the old file area hasn't been re-used the data is recoverable (sometimes with difficulty but often possible).

    Now whilst I love SSD's I don't think there's any utility around that physically writes on every "sector" (note they aren't true sectors in the sense that normal HDD's have) on an SSD - nor would you want to. A Secure erase needs to be done differently -- and I'm also not sure what you would need to do either.

    Info please if anyone has any ideas.

      My System SpecsSystem Spec

  7. #27

    Posts : 4,515
    Vista and Win7

    The method of disconnecting the Sata cable to give the SSD time to do garbage collection is a bit over the top and not possible in a laptop anyhow. An easier method is to halt the PC in BIOS mode. Then the SSD gets power but nothing is being written to it.
      My System SpecsSystem Spec

  8. #28

    Yellow Belly
    Posts : 178
    Windows 8.1 with Bing x64

    This makeuseof article goes into the ins and outs quite well.
      My System SpecsSystem Spec

Page 3 of 3 FirstFirst 123
SSD File "Eraser" Needed ??

Similar Threads
Thread Forum
"Cannot repair member file " after running "sfc /scannow"
I just ran "sfc /scannow", got the message "Windows Resource Protection found corrupt files but was unable to fix some of them. Details are included in the CBS.Log ...". I opened that with texteditor, and found 4 Cannot repair member file "Amd64\CNBJ2530.DPB of prncacla.inf ... lines in the...
General Support
"Loading files ..." -> "Windows Boot Manager" -> "OneKey"
Hi all, So I'm kind of stuck.. I currently have the problem where I am in an endless cycle of "loading files" -> "Windows Boot Manager" (see: How To Boot Into Safe Mode On Windows 8 (The Easy Way)). I have tried to load all of the options -- and none successfully load. I also end up at...
General Support
Can't download exe file-- ""You'll need to provide admin"
Hi All. I'm running Windows 8.1 (standard/ home edition) and can't download a couple .exe files. I get "You'll need to provide administrator permission to copy to this folder". errors. I'm the only user on this computer and have administrator access. The file resides on mediafire and via my...
General Support
Can't reset windows 8 "could not find the files needed"
i need ur help with this guys. when i tried to reset my laptop, it read "could not find the files needed". mine is an Acer aspire V5, it didn't came with an installation disc or media, i know it should have a hidden partition for recovery, but i think the system is having trouble with it. i think a...
Installation & Setup
Windows 8.1 Update "Not Needed" Problem
I am running Windows 8.1 Pro 64 Bit Anyone know why this keeps happening? I've tried rebooting my PC a few times and it still wont budge.
Windows Updates & Activation
Windows 8 needed restart because "PC ran into a problem"
Screenshot attached below: Edit: Got the message that this is a BSOD and need to go through the procedure regarding log files. I will try to figure that out. Thanks. Problem: The screen went blue with the unhappy face telling me that my PC had a problem and had to restart. It told me the...
General Support
HELP NEEDED: Starting as "other user" upon startup...
Lately, when I start my laptop I'm logged in as "Other User" and I don't know why. It started doing this about two weeks ago. I can use the computer just fine logged in as "other user", but it's just bothersome. Any ideas about what caused this and more importantly, how to make it so I'm logged in...
User Accounts and Family Safety

Eight Forums Android App Eight Forums IOS App Follow us on Facebook