Windows 8 and 8.1 Forums

CPU doesn't drop below 30% in idle after update to 8.1

  1. #1

    Posts : 2
    Windows 8.1

    CPU doesn't drop below 30% in idle after update to 8.1


    I upgraded my OS to Windows 8.1 from Windows 8 from the store yesterday. Everything seems to be working fine - no lags or freezes, but I noticed that my PC doesn't drop below 30-35% in idle, also it doesn't downclock (balanced power settings) - it used to drop to 0.8ghz in idle and be like 1-4% in idle before the update, and now it's permanent 3.2ghz and over 30% in idle. I noticed that Service Host: Local Services and Service Host: System Services in the task manager are draining over 10% CPU each, something that didn't happen before.

    I know that this information is not very specific so I probably won't get solution to fix it, so I'm asking you for any advice how to get more specific information about the problem that's causing this CPU load. It will be best If there is someone with similiar problem to mine and has a working solution.

    Thanks in advance!

      My System SpecsSystem Spec

  2. #2

    Posts : 2,191
    Windows 8.1

    Hey yuliyan,

    IMHO, I think you have found another real issue 8.1 issue here! I just checked my CPU idle speed and it used to throttle down to 1.57 GHz during low activity periods. However, now it appears to be fairly consistent in the 2.5 to 2.7 GHz area (I'm running an Intel G2020 @ 2,9GHz) and there does seem to be a bit more idle activity as well. Personally, I don't like the way this looks and I think you have discovered a genuine difference between 8.0 and 8.1. Now, what to do about it, I don't have a clue at this point. Maybe others can chime in and confirm this is a real issue.

    Click image for larger version

    It almost seems as if the throttle down parameters have changed because I'm accustomed to a 50% throttle down (or so) on my dual-core CPU. I don't like this at all. Thanks for picking this one up. Now, what to do...
      My System SpecsSystem Spec

CPU doesn't drop below 30% in idle after update to 8.1

Similar Threads
Thread Forum
Image doesn't fill screen after BIOS update
Trying to address a different problem, Gigabyte suggested that I update the BIOS on my GA-F2A88X-D3H mb from F1 to F3. In addition to not solving the problem, after I updated the image displayed on my monitor--Dell 2209 WA--doesn't fill the screen. Everything's there, but the image stops about 3.5"...
Graphic Cards
After update to 8.1 right-click doesn't work
Hi everyone, I am using a Wacom Cintiq Companion and just upgraded to Windows 8.1. After the upgrade my right-click stopped working and when I try to right-click it freezes my left click so I have to restart. Any help would be greatly appreciated! Thanks, Jack
General Support
PC doesn't boot up after a new system update is installed
I had purchased Windows 8 in the first month of its release and since then I haven't encountered a single error. But off late, I'm experiencing serious trouble. Whenever a Windows automatic update is installed, after shutting down the laptop when it's booted again I get a message on a...
BSOD Crashes and Debugging
Java update 'doesn't prevent silent exploits at all'
Java update 'doesn't prevent silent exploits at all' | ZDNet
Windows 8 News
Win 8 Pro Update - doesn't do Time Zone correctly
Installed Win 8 Pro with 'keep Win 7 settings' option, then noticed that it displayed GMT rather than UTC+10 for Canberra, Australia. Checked and updated 'Date and Time' to (UTC+10:00) Canberra, Melbourne, Sydney, made sure Location was 'Australia' and Language 'English (Australia)' and still the...
General Support

Eight Forums Android App Eight Forums IOS App Follow us on Facebook