After my new build froze up during boot up into Windows 8, I tried to run Windows 8's built-in Windows Memory Diagnostic, extended setting, but it got stuck at 21% of 1st pass (10% overall) after running it overnight (at least 12 hours). I had 4x4GB memory modules, and re-ran this test with only one stick in different slots, all with the same result: it would quickly get to 10% overall complete, then apparently get stuck there. However I noted that I could still access F1 options when it got to 10% complete, so it wasn't frozen, but the system became extremely slow, with the screen displaying text one word at a time.

Some ideas on how to isolate the problem? I wish I could just return both the motherboard and the memory to the store, but there may be a restocking fee involved with the motherboard unless it's defective.

My parts are:
Intel Core i7-3770K
Corsair Vengeance 4x4GB DDR3 1600 (PC3 12800) model CMZ16GX3M4A1600C9

Other information/symptoms:
- I can not run memtest at bootup either by using a DVD/CD or USB key. The motherboard's boot code indicate that it keeps trying to detect the device (DVD drive or USB key) and then gives up. Maybe memtest isn't compatible with this hardware, or I am not configuring it properly, or there are some hardware problems here.
- The keyboard sometimes did not work during boot up, such as when attempting to select the USB key to boot into memtest (attaching a USB keyboard worked, but I still couldn't get memtest to run)
- I am using Secure Boot. During Windows 8 installation, the UEFI boot menu could not detect the DVD drive if it was connected to the last 2 SATA ports, which was probably due to a different chipset being used.