Windows 8 and 8.1 Forums


Windows 8 internet performance slow

Page 1 of 2 12 LastLast
  1. #1



    Junior Member

    Join Date : Dec 2012
    Boden
    Posts : 6
    windows 8 pro
    Sweden se norrland

    Windows 8 internet performance slow


    I have noticed on one of my Windows 8 Pro computers that it has longer response time when accessing Internet. It has worked flawlessly for a month. The other PCs are not affected so it has nothing to do with my Router (DIR655)

    It seems like it takes time to do a DNS-lookup and I have tried quickly changing sites via the bookmark bar. It "thinks and waits" longer on one of my computers. The sdame bookmarks on my other PC change rapidly.

    It has nothing to do with hardware. Both PCs have SSD and clean installs of Win 8 Pro. I have looked at what software has been added or updated the last week, when I started experiencing the problems and I have received 2 updates from Win update. I uninstalled them, no change, reinstalled them, no change. The only other software updated is Itunes.
    I have also experienced errors when launching the desktop. The desktop froze and you have to logout and login a few times before I could use my quick launch icons. This problem has disappeared after I applied the updates via Win update.
    Any other person experiencing this?

    I might add that it does not matter if I use Chrome or IE10.
      My System SpecsSystem Spec

  2. #2
    znod's Avatar

    Power User

    Join Date : Nov 2012
    Posts : 2,156
    Win7 Ult on DIY; Win8 Pro on MBP/Parallels; Win7 Ult on MBP/Boot Camp; Win7 Ult/Win8 Pro on HP
    USA us texas


    I am assuming that you go to the bookmarks bar sites with some frequency. Thus, related pages should be cached. Both computers should access cached pages rapidly. Perhaps you need to do some browser cleaning of your slower machine. See if you can make any progress using the advanced settings in Chrome, specifically, "Clear browsing data." Also, clear your cache maybe.

    You also could try System Maintenance. I haven't discovered how to find this program except by by searching in Help and Support under "maintenance." Ah, try Disc Cleanup. I finally found it at System > Performance Information and Tools > Open Disk Cleanup.
    Last edited by znod; 02 Dec 2012 at 07:23 AM.
      My System SpecsSystem Spec

  3. #3



    Power User

    Join Date : Nov 2012
    Posts : 307
    Win 8 64-bit


    Quote Originally Posted by sm2otu View Post
    Any other person experiencing this?
    There was another new member asking the same thing about 18 hours ago. Maybe worth comparing notes to find out what you have in common.
    Major Flaw in Windows 8 Slow Browsing on Chrome, Firefox?
      My System SpecsSystem Spec

  4. #4



    Junior Member

    Join Date : Dec 2012
    Boden
    Posts : 6
    windows 8 pro
    Sweden se norrland


    I have tried cleaning up cache och using the cache a longer time without cleaning. It makes no difference. I am convinced this is some issued with win 8. But I have no proof. It also affects my Outlook 2010 mail which I use with IMAP.
    Both PCs I use are fast and I have a 100 mbit connection.
    It is a very noticeable change. It may take seconds to access pages where it used to go in a flash before.
    Registry is defragmented with Registrybooster and I have searched and repaired all errors.
      My System SpecsSystem Spec

  5.   

  6. #5



    Member
    Array
    Join Date : Nov 2011
    Posts : 364
    Windows 8.1 Pro x64


    Can you post output of tracerts to said sites you are having issues with, or is it every site in general? Do you use ISP DNS or a third party like OpenDNS?

    Also can post output of results from Speedtest.net - The Global Broadband Speed Test and Pingtest.net - The Global Broadband Quality Test ?
      My System SpecsSystem Spec

  7. #6
    chev65's Avatar

    Senior Member



    Join Date : Jan 2010
    Beach house paradise
    Posts : 2,087
    Windows 8.1 Pro WMC
    USA us california


    Quote Originally Posted by sm2otu View Post
    I have tried cleaning up cache och using the cache a longer time without cleaning. It makes no difference. I am convinced this is some issued with win 8. But I have no proof. It also affects my Outlook 2010 mail which I use with IMAP.
    Both PCs I use are fast and I have a 100 mbit connection.
    It is a very noticeable change. It may take seconds to access pages where it used to go in a flash before.
    Registry is defragmented with Registrybooster and I have searched and repaired all errors.
    Did you say that you installed iTunes?

    If so you should be aware that iTunes also installs a network service famously known as Bonjour. This Bonjour service is world famous for causing problems on Windows systems.

    You will want to go into Windows Services and disable this service, type services.msc in the run box to access Windows services.

    it may appear as Bonjour or it may show up as "ID store followed by a bunch of numbers, it should be there near the top of the page. You will want to disable this service and reboot your machine.

    Check to see if this changes or fixes the connection problem you were having.
      My System SpecsSystem Spec

  8. #7



    Junior Member

    Join Date : Dec 2012
    Boden
    Posts : 6
    windows 8 pro
    Sweden se norrland


    Hi Chev65. I uninstalled Bonjour completely. Rebooted. No effect. I will look into this more later and start disabling services etc. My ISPs DNS i used btw. It works perfectly on the other machines.
    Cheers
      My System SpecsSystem Spec

  9. #8



    Junior Member

    Join Date : Dec 2012
    Boden
    Posts : 6
    windows 8 pro
    Sweden se norrland


    I have done som more user testing on random, but there is a pattern that seems to repeat itself

    When accessing a webpage for the first time, there is a delay before it loads. Once you are on that site, all links within the site load very fast. I jump to another site, same thing. Jump back to the first site and it takes time to load again.

    Pingtest reveals excellent performance (pingtest.net) but I think it pings the server it has located and established connection with.

    It is strange. The max loadtime was 8 seconds and the second longest was 6 seconds. I tried on Swedish sites which I know have excellent performance.
    Then everything works perfectly as it should for a few minutes.

    I rule out my router and my ISP. The other PC with Windows 8 has none of these problems.

    I will disable some services and autostart programs and if that does not work, I will perform a system restore. I hate to do a complete refresh though.
      My System SpecsSystem Spec

  10. #9
    znod's Avatar

    Power User

    Join Date : Nov 2012
    Posts : 2,156
    Win7 Ult on DIY; Win8 Pro on MBP/Parallels; Win7 Ult on MBP/Boot Camp; Win7 Ult/Win8 Pro on HP
    USA us texas


    Quote Originally Posted by sm2otu View Post
    Both PCs I use are fast and I have a 100 mbit connection.
    Try switching the router connections for the PCs.
      My System SpecsSystem Spec

  11. #10



    Junior Member

    Join Date : Dec 2012
    Posts : 10
    Windows 9 Pro


    10 hours of wasted time later starting and stopping, enabling and disabling services, drivers, etc.


    It was the Power Management! Power Plan was set to Power Saver mode! Why it takes about 3 minutes after boot for it to effect the browsing is beyond me. Sure threw me a curve ball and I've been around the block a few times on PC issues over the past 15-20 years!
      My System SpecsSystem Spec

Page 1 of 2 12 LastLast
Windows 8 internet performance slow
Similar Threads
Thread Forum
Slow Slow internet speed with Windows 8 Network & Sharing
Windows 8 Hidden Downloading? Slow Internet? Network & Sharing
Slow Internet when using wireless card Network & Sharing
Solved Internet Sending request (Slow Internet) Network & Sharing
Internet Explorer Performance Lab: reliably measuring browser performa Windows 8 News

Eight Forums Android App Eight Forums IOS App Follow us on Facebook