My first post in this forum, and already a tough one !

I'm having problems with my Atheros AR9271 Network wireless adapter.

Ok let's begin !

So I had W7 Home premium and decided to upgrade to 8. the whole upgrade went like a charm, I kept all my files and programs, and I had the new OS in less than 30 minutes. I had no wifi though, but after a wired connection to my modem, windows managed to find the proper driver as "Atheros AR9271". This was not my network adapter brand, [which is Multilaser, a brazilian brand, I believe inside the usb adapter is actually a atheros hardware] but it was working so I didn't bother...

After a couple days my SSD drive died [Damn you OCZ !] and I had to use a different HDD, I had to make a clean install this time. Again no wifi, but windows 8 managed to find the same Atheros AR9271, using a wired connection.

But now is the trick part, I have a wifi connection for just under a minute, and then the connection drops. The weirdest thing is, first my wifi network disappears, but i can see my neighbours networks, and after a few minutes all networks are gone.

All the hardware is the same, the only thing is between the upgrade and the clean install I updated the bios.

To sum up !

UPGRADE 7 to 8 : Installed in a 64Gb OCZ SSD; Kept files and software; No Wifi; windows found AR9271 - Steady connection

Clean W8 install :Installed in a 320Gb Samsung HDD; No wifi; windows found AR9271 - Connection drops after a minute, still able to see my neighbours network, after a few minutes no connections available whatsoever !

I'm using a Desktop computer and the following hardware:
Intel i7 processor
MB Intel DP55WB
320GB Samsung HD
GeForce GTS250 1Gb
2 monitors

I tried to install a number of different drivers from Atheros, with no sucess.

I prevented from windows to turn off the device, didn't change a thing.

I can use the internet while on cable, and I can also use my internet connection on other computers and tablets. but my desktop is far from my modem, cannot use a wired connection !

I hope I dont have to reinstall windows 7 manually install my wifi adapter, and upgrade to windows 8, so any one see anything that i'm missing ?

Thanks in advance !

PS - English is not my first language so sorry for any grammar mistakes, and also my windows copy will be in portuguese so if anyone asks for a print screen, have a dictionary with you ! haha !