Windows 8 and 8.1 Forums

Boot problems from multi drive system

  1. #1

    Posts : 4
    Windows 8

    Boot problems from multi drive system

    Firstly, let me explain my setup.
    I have just installed a new 2TB hard drive, the plan being to test drive windows 10 on one partition of a triple boot with windows 7 & 8. There is a 4th partition named Data. Windows 7 & 8 are installed and both work (when I can get them to boot!). Windows 10 in an empty partition at present.
    There are 2 other 1TB drives for data in the system.
    Problem is, the 2 1TB data drives Disc 1 & 2, both have bootmgr on them but they should not have. It depends on how I cable the 3 drives as to what choices of operating system I get presented with.

    Click image for larger version

    I'm writing this on a clean install of Windows 8.0, but as can be seen from the screenshot of EasyBCD, it shows Windows 8.1 as entry number one. This was on my old hard drive, now removed from the computer.

    Click image for larger version

    How can I get just the main drive to be the one to boot (with a choice of operating system) regardless of which cable is plugged into which disk?

      My System SpecsSystem Spec

  2. #2

    Posts : 1,121
    Windows 8.1 x64

    I suppose some info might be in order. When you install an MBR configured system, the install will put the boot files on the drive listed as primary in the Bios. This is probably what happened when Disk 2 was made the System partition and it boots into Windows 8 on Disk 0.

    Any active partition has the potential to be a System (boot Files) partition and able to boot your system if configured to do so.

    The system will boot to the first active partition it comes to following the drive priority in the Bios. When you change the connections, you are effectively changing that order, but it is better to change it in the Bios.

    You might want to set the current Disk 0 as first priority in the Bios and see where the System partition is. If it doesn't boot, set it back to its present configuration.

    Have you made any changes using EasyBCD, and if so do you remember what they were?
      My System SpecsSystem Spec

  3. #3

    Posts : 4
    Windows 8

    I made disks 1 & 2 inactive and that solved the problem. Now with only 1 active partition, the computer has to boot from there. I used EasyBCD to set the right options, but needed to boot from windows disc and run disc repair to completely solve it. Thanks
      My System SpecsSystem Spec

Boot problems from multi drive system

Similar Threads
Thread Forum
Multi Boot-Win7 & Win8.1 - Data Drive not seen in Win8.1
Hopefully my explanation of this problem is not too confusing, this my first post. My system is a multi-boot for Win7, Win8.1 & XP. I boot into Win7 most of the time. The multi-boot is controlled via EasyBCD in Win7. My data drive is a separate disk - F. I have been running this configuration...
General Support
Security permissions problems for system drive
I can't create a simple text file and place it on my C: drive in Win 8.1 - says that I don't have permission. The properties of the drive show that I do - full control, every class of user. Am I missing something really simple?
Network & Sharing
Building new system using existing SSD boot drive
Hi everyone, first time poster looking for some advice. I built a large desktop system a few years back and it's been upgraded with various bits and pieces including an SSD boot drive. I'm looking at putting together a much smaller system in a Shuttle XH61V and I want to use my existing 2.5"...
Installation & Setup
Boot problems after merging C and D drive
My hard disk was divided in 7 partitions named C, D, E, F, G, H, I.... Partition C had windows 8 installed and partition D had windows 7 installed... 1 week back, i merged partition C and D using EaseUS partition manager....It had some problem but after restart i was able to boot into...
General Support
New Laptop with OS 8 multi problems out the gate.
Hi all I am new to this forum. I just got a new Hp Laptop with Windows 8 basic 64 bit. I have been having problems with freezing all the time. The other thing is when it streams it show this thing that asks allow or deny when I click on it it does not do anything. Also streaming freezes. My...
General Support
nVidia MULTI-GPU problems
Hi there, Since the beginning of my W8 experiences, I had problems with games, while I was playing computer was crashing to black screen and then screen went to "no signal". I've tried to run games in Single-GPU mode and everything is allright now. I have Geforce 295GTX, and most of the newest...
Graphic Cards

Eight Forums Android App Eight Forums IOS App Follow us on Facebook