Windows 8 and 8.1 Forums

Windows 8 Booting (IGPU works, PCI-E GTX750Ti doesn't work

  1. #1

    Posts : 3
    Windows 8.1 Pro

    Windows 8 Booting (IGPU works, PCI-E GTX750Ti doesn't work

    Hi guys,

    I have a problem and I've tried to figure it out for the whole day now.

    It's mind-boggling and SUPER frustrating at the same time.

    Basically I installed a fresh copy of Windows 8.1 Pro to my computer and when I plug both DVI cables into the GTX 750Ti (I run Dual monitors) it goes to the 'Windows 8 Blue logo start up but then suddenly my monitors have no signal (and my mouse turns off, aka it looks like my USB shutsdown) but my mobo is still on + cpu fans/case fans, etc.

    So I tried using the IGPU and it works fine, you can plug one DVI into the IGPU DVI out, and one monitor DVI to the GTX750Ti and it will boot into windows fine.

    The biggest thing that boggles me is that upon a fresh install it worked fine, AND I can reinstall windows fine again, but it *SEEMS* like after I install the NVIDIA graphics card drivers it starts happening again and I can only use IGPU to boot into windows. Now, when I first installed windows it was working fine, till I shut it down and it won't boot again hence having to try IGPU. I tried formatting, I've tried everything!

    All my parts are brand new, I've tried everything there is to try, and googled alot (I've enabled/disabled secureboot multiple times, I've done 'primary display adapter 'PCI-E' and switched between them), I've tried almost everything!

    My specs are as follows:

    ASUS Geforce GTX750Ti GPU
    Asrock H97M-ITX/ac MOBO
    RAM: Corsair Vengeance 8gb
    Samsung EVO 840 SSD

    I've fiddled around with all the Asrock bios settings to no avail.

    Someone help me PLZ!!!! As I need my computer for the week

      My System SpecsSystem Spec

  2. #2

    Posts : 3
    Windows 8.1 Pro

    The craziest thing is - Sometimes it works sometimes it doesn't - remember it goes to blue windows 8 logo AND THEN there is no monitor signal.

    If I use Integrated Graphics it 100% always works. I'm thinking it might be some sort of bios problem maybe? I really don't know anymore :|
      My System SpecsSystem Spec

  3. #3

    Posts : 3
    Windows 8.1 Pro

    Also, it boots to safemode just fine.
      My System SpecsSystem Spec

  4. #4

    Posts : 1,121
    Windows 8.1 x64

    Which slot do you have the card in, the one closest to the processor?

    Have you checked the paperwork on the GTX to see if there are restrictions on which outputs can be used as the same time?

    Are the monitors matched?

    I will have to research on having the onboard and discreet video outputs operational at the same time. I believe on mine, the system will disable one or the other. You might check your bios settings to see what options are available for that configuration.
      My System SpecsSystem Spec

Windows 8 Booting (IGPU works, PCI-E GTX750Ti doesn't work

Similar Threads
Thread Forum
Will Works 7 work on a Windows 8 machine?
Hi, I have just been given an Asus laptop as a present, it is running Windows 8. I have a copy of Works 7 from a previous machine and wondered if it would work on the Windows 8 laptop? Thanks, Gerald
General Support
Keyboard doesn't works - 8.1
was working with my laptop and everything was ok i restarted it and now keyboard doesn't works i got folowing error could you please help me thanks!!! - <Event xmlns=""> - <System>
Drivers & Hardware
Windows explorer doesn't work
Just updated to 8.1 yesterday. Since then, there have been issues. If I left click on the Folder Icon in the task bar or right click and select "File Explorer" I will get the usual blue circle telling me to wait, except the window never appears. Instead the screen changes "purple" as if the...
General Support
Windows 8 Doesn't work! Please Help!
Okay here's the thing, my computer worked fine and all but one day i turned the computer off and now i can't get in to windows.. let me explain When i start my computer everything works fine until the windows logo shows up it's loading but never finishes. after a while it gets BSOD for like a...
BSOD Crashes and Debugging
Keyboard doesn't work in windows 8 !!
It was working ,but after installing Windows 8 Pro in my desktop the keyboard doesn't work at all !! note : the keyboard doesn't have usb port
Drivers & Hardware
dhcp works . static ip doesn't
If I set my computer to dhcp I can get access to the router and to the internet just fine. If I go into the control panel and set it to static IP then I can't get access to anything. Here are the steps I am taking: In the Network and Sharing center window I click on: Change adapter settings...
Network & Sharing
My Windows Key doesn't work
I had been using the Windows key to switch back and forth from Metro to desktop. When I am in Metro, pressing it does nothing, but it works everywhere else. I simply click on the desktop icon, so it's no big deal, but is there a solution?
General Support

Eight Forums Android App Eight Forums IOS App Follow us on Facebook