I have been using Windows 8 Enterprise 64-bit for few months now with the RTM trial they provided on MSDN.
Everything has been running perfect except when I switch between metro and desktop I will have it lag a bit on the graphics. Like when back on desktop some part of metro UI app or whatever will still be on screen until I like do something. Something like highlighting, switching back to metro and desktop again, etc. Hard to explain and hard to provide screenshots, since when I screenshotted last time it didn't show the lag. I am not sure what the proper term for this is called, but I have seen it before happen often on the good ol' Windows XP days.

I have a NVIDIA graphics card that came installed with my laptop: Notebook 310M.

I personally would prefer getting it straight from the manufacturer that made it, however they make you get it from Sony. I am not sure why, I think it may be promotion for the pointless VAIO Update software, however I am not sure if it really wouldn't work or what the reasoning behind it is.

"The following Sony VAIO notebooks are included in the Verde notebook program: Sony VAIO F Series with NVIDIA GeForce 310M, GeForce GT 330M, GeForce GT 425M, GeForce GT 520M or GeForce GT 540M. Other Sony VAIO notebooks are not included (please contact Sony for driver support)."

I went ahead to the Sony live support chat and here are the chat logs:
You are chatting with Braiden - (C3CJ). 10:32 AM Connecting... 10:32 AM Co - Pastebin.com
It was beyond crappy support, though I never had much hope in the first place.

Can someone help me out without purchasing a new PC\hardware?

Thanks, any help will be highly appreciated. Also I apologize if I am unclear on portions of this post.
Also the reason why I really care is because I was about to purchase Windows 8 Professional.